mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-06 08:26:50 +01:00
python/python-gattlib: Fix setup.py for the newer boost.
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
This commit is contained in:
parent
fd8a792973
commit
4c1b53ba32
2 changed files with 21 additions and 0 deletions
19
python/python-gattlib/dont_hardcode_python_versions.patch
Normal file
19
python/python-gattlib/dont_hardcode_python_versions.patch
Normal file
|
@ -0,0 +1,19 @@
|
|||
Matteo Bernardini <ponce@slackbuilds.org>
|
||||
---
|
||||
Don't hardcode python versions
|
||||
|
||||
diff -Naur gattlib-0.20150805.orig/setup.py gattlib-0.20150805/setup.py
|
||||
--- gattlib-0.20150805.orig/setup.py 2015-08-05 15:16:56.000000000 +0200
|
||||
+++ gattlib-0.20150805/setup.py 2018-05-02 09:45:04.625893000 +0200
|
||||
@@ -19,9 +19,9 @@
|
||||
glib_libs = [x.strip() for x in glib_libs if x]
|
||||
|
||||
if sys.version_info.major == 3:
|
||||
- boost_libs = ["boost_python-py34"]
|
||||
+ boost_libs = ["boost_python3"+str(sys.version_info.minor)]
|
||||
else:
|
||||
- boost_libs = ["boost_python"]
|
||||
+ boost_libs = ["boost_python2"+str(sys.version_info.minor)]
|
||||
extension_modules = [
|
||||
Extension(
|
||||
'gattlib',
|
|
@ -57,6 +57,8 @@ find -L . \
|
|||
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
|
||||
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
|
||||
|
||||
patch -p1 < $CWD/dont_hardcode_python_versions.patch
|
||||
|
||||
python setup.py install --root=$PKG
|
||||
|
||||
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
|
||||
|
|
Loading…
Reference in a new issue