gis/gpsbabel: Updated for version 1.6.0.

Signed-off-by: Kyle Guinn <elyk03@gmail.com>
This commit is contained in:
Kyle Guinn 2019-10-10 23:12:48 -05:00 committed by Willy Sudiarto Raharjo
parent a7f354eec6
commit 4b2a87f2d0
No known key found for this signature in database
GPG key ID: 887B8374D7333381
5 changed files with 25 additions and 82 deletions

View file

@ -11,8 +11,3 @@ server-side processing or as the backend for other tools.
It does not convert, transfer, send, or manipulate maps. We process data that It does not convert, transfer, send, or manipulate maps. We process data that
may (or may not be) placed on a map, such as waypoints, tracks, and routes. may (or may not be) placed on a map, such as waypoints, tracks, and routes.
NOTE: Qt5 is required starting with version 1.5.4. If you would rather not
build and install Qt5, then download the sources for 1.5.3 and execute:
VERSION=1.5.3 ./gpsbabel.SlackBuild

View file

@ -1,58 +0,0 @@
diff -wbBur gpsbabel-1.5.4/tef_xml.cc gpsbabel-1.5.4.my/tef_xml.cc
--- gpsbabel-1.5.4/tef_xml.cc 2017-01-02 08:05:19.000000000 +0300
+++ gpsbabel-1.5.4.my/tef_xml.cc 2017-02-16 16:20:22.788961096 +0300
@@ -72,11 +72,11 @@
bool valid = false;
foreach(QXmlStreamAttribute attr, *attrv) {
- if (attr.name().compare("Comment", Qt::CaseInsensitive) == 0) {
- if (attr.value().compare("TourExchangeFormat", Qt::CaseInsensitive) == 0) {
+ if (attr.name().compare((QString&)"Comment", Qt::CaseInsensitive) == 0) {
+ if (attr.value().compare((QString&)"TourExchangeFormat", Qt::CaseInsensitive) == 0) {
valid = true;
}
- } else if (attr.name().compare("Version", Qt::CaseInsensitive) == 0) {
+ } else if (attr.name().compare((QString&)"Version", Qt::CaseInsensitive) == 0) {
version = attr.value().toString().toDouble();
}
}
@@ -95,9 +95,9 @@
{
route = route_head_alloc();
foreach(QXmlStreamAttribute attr, *attrv) {
- if (attr.name().compare("Name", Qt::CaseInsensitive) == 0) {
+ if (attr.name().compare((QString&)"Name", Qt::CaseInsensitive) == 0) {
route->rte_name = attr.value().toString().trimmed();
- } else if (attr.name().compare("Software", Qt::CaseInsensitive) == 0) {
+ } else if (attr.name().compare((QString&)"Software", Qt::CaseInsensitive) == 0) {
route->rte_desc = attr.value().toString().trimmed();
}
}
@@ -248,20 +248,20 @@
QString attrstr = attr.value().toString();
QByteArray attrtext = attrstr.toUtf8();
- if (attr.name().compare("SegDescription", Qt::CaseInsensitive) == 0) {
+ if (attr.name().compare((QString&)"SegDescription", Qt::CaseInsensitive) == 0) {
wpt_tmp->shortname = attrstr.trimmed();
- } else if (attr.name().compare("PointDescription", Qt::CaseInsensitive) == 0) {
+ } else if (attr.name().compare((QString&)"PointDescription", Qt::CaseInsensitive) == 0) {
wpt_tmp->description = attrstr.trimmed();
- } else if (attr.name().compare("ViaStation", Qt::CaseInsensitive) == 0 &&
- attr.value().compare("true", Qt::CaseInsensitive) == 0) {
+ } else if (attr.name().compare((QString&)"ViaStation", Qt::CaseInsensitive) == 0 &&
+ attr.value().compare((QString&)"true", Qt::CaseInsensitive) == 0) {
wpt_tmp->wpt_flags.fmt_use = 1; /* only a flag */
/* new in TEF V2 */
- } else if (attr.name().compare("Instruction", Qt::CaseInsensitive) == 0) {
+ } else if (attr.name().compare((QString&)"Instruction", Qt::CaseInsensitive) == 0) {
wpt_tmp->description = attrstr.trimmed();
- } else if (attr.name().compare("Altitude", Qt::CaseInsensitive) == 0) {
+ } else if (attr.name().compare((QString&)"Altitude", Qt::CaseInsensitive) == 0) {
wpt_tmp->altitude = attrstr.toDouble();
- } else if (attr.name().compare("TimeStamp", Qt::CaseInsensitive) == 0) {
+ } else if (attr.name().compare((QString&)"TimeStamp", Qt::CaseInsensitive) == 0) {
/* nothing for the moment */
}
}

9
gis/gpsbabel/doinst.sh Normal file
View file

@ -0,0 +1,9 @@
if [ -x /usr/bin/update-desktop-database ]; then
/usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
fi
if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
if [ -x /usr/bin/gtk-update-icon-cache ]; then
/usr/bin/gtk-update-icon-cache -f usr/share/icons/hicolor >/dev/null 2>&1
fi
fi

View file

@ -2,7 +2,7 @@
# Slackware build script for gpsbabel # Slackware build script for gpsbabel
# Copyright 2017 Kyle Guinn <elyk03@gmail.com>, USA # Copyright 2017-2019 Kyle Guinn <elyk03@gmail.com>
# All rights reserved. # All rights reserved.
# #
# Redistribution and use of this script, with or without modification, is # Redistribution and use of this script, with or without modification, is
@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=gpsbabel PRGNAM=gpsbabel
VERSION=${VERSION:-1.5.4} VERSION=${VERSION:-1.6.0}
SRCVER=${PRGNAM}_$(echo ${VERSION} | tr . _) SRCVER=${PRGNAM}_$(echo ${VERSION} | tr . _)
BUILD=${BUILD:-1} BUILD=${BUILD:-1}
TAG=${TAG:-_SBo} TAG=${TAG:-_SBo}
@ -38,7 +38,7 @@ fi
CWD=$(pwd) CWD=$(pwd)
TMP=${TMP:-/tmp/SBo} TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM PKG=$TMP/package-$PRGNAM-$VERSION
OUTPUT=${OUTPUT:-/tmp} OUTPUT=${OUTPUT:-/tmp}
DOCS="AUTHORS COPYING README*" DOCS="AUTHORS COPYING README*"
@ -77,23 +77,17 @@ chmod -R u+w,go-w,a+rX-st .
sed -i \ sed -i \
-e '/reportStatistics_/s/true/false/' \ -e '/reportStatistics_/s/true/false/' \
-e '/startupVersionCheck_/s/true/false/' \ -e '/startupVersionCheck_/s/true/false/' \
-e '/ignoreVersionMismatch/s/false/true/' \ -e '/ignoreVersionMismatch_/s/false/true/' \
gui/babeldata.h gui/babeldata.h
# Make it more FHS-compliant by moving gmapbase.html and the translations # Make it more FHS-compliant by moving gmapbase.html and the translations
# to /usr/share. Tell the GUI where to find them. Thanks to Arch. # to /usr/share. Tell the GUI where to find them. Thanks to Arch.
sed -i 's|QApplication::applicationDirPath() +|"/usr/share/gpsbabel"|' gui/map.cc sed -i 's|langPath_ = QApplication::applicationDirPath();|langPath_ = "/usr/share/gpsbabel";|' gui/mainwindow.cc
sed -i 's|QApplication::applicationDirPath()|"/usr/share/gpsbabel"|' gui/mainwindow.cc sed -i 's|baseFile = QApplication::applicationDirPath() + "/gmapbase.html";|baseFile = "/usr/share/gpsbabel/gmapbase.html";|' gui/map.cc
# Build using the system zlib and libminizip from SBo (see --with-zlib=system). # Fix the .desktop file and icon. Thanks to Arch.
# Thanks to Gentoo. sed -i 's|gpsbabelfe-bin|gpsbabelfe|' gui/gpsbabel.desktop
sed -i '/AC_CHECK_LIB(\[z\], \[gzopen\])/aAC_CHECK_LIB([minizip], [zipOpen64])' configure.in convert gui/images/appicon.png +set date:create +set date:modify -background none -gravity center -extent 512x512 gui/images/appicon.png
sed -i 's|"zlib/contrib/minizip/zip.h"|<minizip/zip.h>|' src/core/ziparchive.cc src/core/ziparchive.h
# Patched to build against Qt5
patch -p1 < $CWD/build-fix.patch
autoreconf -vif
./configure \ ./configure \
--prefix=/usr \ --prefix=/usr \
@ -112,7 +106,9 @@ make
make gui make gui
install -D -m0755 -s gpsbabel $PKG/usr/bin/gpsbabel install -D -m0755 -s gpsbabel $PKG/usr/bin/gpsbabel
install -D -m0755 -s gui/objects/gpsbabelfe-bin $PKG/usr/bin/gpsbabelfe install -D -m0755 -s gui/objects/gpsbabelfe $PKG/usr/bin/gpsbabelfe
install -D -m0644 gui/gpsbabel.desktop $PKG/usr/share/applications/gpsbabel.desktop
install -D -m0644 gui/images/appicon.png $PKG/usr/share/icons/hicolor/512x512/apps/gpsbabel.png
install -D -m0644 gui/gmapbase.html $PKG/usr/share/gpsbabel/gmapbase.html install -D -m0644 gui/gmapbase.html $PKG/usr/share/gpsbabel/gmapbase.html
install -d -m0755 $PKG/usr/share/gpsbabel/translations/ install -d -m0755 $PKG/usr/share/gpsbabel/translations/
install -D -m0644 gui/*.qm $PKG/usr/share/gpsbabel/translations/ install -D -m0644 gui/*.qm $PKG/usr/share/gpsbabel/translations/
@ -123,6 +119,7 @@ cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz} /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}

View file

@ -1,8 +1,8 @@
PRGNAM="gpsbabel" PRGNAM="gpsbabel"
VERSION="1.5.4" VERSION="1.6.0"
HOMEPAGE="https://www.gpsbabel.org/" HOMEPAGE="https://www.gpsbabel.org/"
DOWNLOAD="https://github.com/gpsbabel/gpsbabel/archive/gpsbabel_1_5_4/gpsbabel-gpsbabel_1_5_4.tar.gz" DOWNLOAD="https://github.com/gpsbabel/gpsbabel/archive/gpsbabel_1_6_0/gpsbabel-gpsbabel_1_6_0.tar.gz"
MD5SUM="0f2d422dbae82f939564cf8305a4654c" MD5SUM="accb9f923ebe1b2d2a00c67d0e1dc430"
DOWNLOAD_x86_64="" DOWNLOAD_x86_64=""
MD5SUM_x86_64="" MD5SUM_x86_64=""
REQUIRES="libminizip qt5" REQUIRES="libminizip qt5"