development/python3: Updated for version 3.1.3.

Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
This commit is contained in:
Audrius Kažukauskas 2010-12-11 00:29:31 -06:00 committed by Robby Workman
parent 88c4fa7683
commit 4b0d56e91f
4 changed files with 51 additions and 66 deletions

View file

@ -1,6 +1,6 @@
diff -uar Python-3.1.2.orig//Lib/distutils/command/install.py Python-3.1.2/Lib/distutils/command/install.py
--- Python-3.1.2.orig//Lib/distutils/command/install.py 2010-05-30 21:01:34.000000000 +0300
+++ Python-3.1.2/Lib/distutils/command/install.py 2010-05-30 21:03:07.000000000 +0300
diff -uar Python-3.1.3.orig/Lib/distutils/command/install.py Python-3.1.3/Lib/distutils/command/install.py
--- Python-3.1.3.orig/Lib/distutils/command/install.py 2010-11-29 22:16:59.433287434 +0200
+++ Python-3.1.3/Lib/distutils/command/install.py 2010-11-29 22:21:28.544937484 +0200
@@ -46,14 +46,14 @@
INSTALL_SCHEMES = {
@ -18,9 +18,9 @@ diff -uar Python-3.1.2.orig//Lib/distutils/command/install.py Python-3.1.2/Lib/d
'platlib': '$base/lib64/python',
'headers': '$base/include/python/$dist_name',
'scripts': '$base/bin',
diff -uar Python-3.1.2.orig//Lib/distutils/sysconfig.py Python-3.1.2/Lib/distutils/sysconfig.py
--- Python-3.1.2.orig//Lib/distutils/sysconfig.py 2010-05-30 21:01:34.000000000 +0300
+++ Python-3.1.2/Lib/distutils/sysconfig.py 2010-05-30 21:03:41.000000000 +0300
diff -uar Python-3.1.3.orig/Lib/distutils/sysconfig.py Python-3.1.3/Lib/distutils/sysconfig.py
--- Python-3.1.3.orig/Lib/distutils/sysconfig.py 2010-11-29 22:16:59.434287447 +0200
+++ Python-3.1.3/Lib/distutils/sysconfig.py 2010-11-29 22:29:32.627720854 +0200
@@ -120,7 +120,7 @@
if plat_specific or standard_lib:
lib = "lib64"

View file

@ -1,6 +1,6 @@
diff -uar Python-3.1.2.orig//Lib/distutils/command/install.py Python-3.1.2/Lib/distutils/command/install.py
--- Python-3.1.2.orig//Lib/distutils/command/install.py 2009-06-04 10:39:50.000000000 +0300
+++ Python-3.1.2/Lib/distutils/command/install.py 2010-05-30 15:10:17.000000000 +0300
diff -uar Python-3.1.3.orig/Lib/distutils/command/install.py Python-3.1.3/Lib/distutils/command/install.py
--- Python-3.1.3.orig/Lib/distutils/command/install.py 2009-06-04 10:39:50.000000000 +0300
+++ Python-3.1.3/Lib/distutils/command/install.py 2010-11-29 21:24:50.939437490 +0200
@@ -47,14 +47,14 @@
INSTALL_SCHEMES = {
'unix_prefix': {
@ -18,9 +18,9 @@ diff -uar Python-3.1.2.orig//Lib/distutils/command/install.py Python-3.1.2/Lib/d
'headers': '$base/include/python/$dist_name',
'scripts': '$base/bin',
'data' : '$base',
diff -uar Python-3.1.2.orig//Lib/distutils/sysconfig.py Python-3.1.2/Lib/distutils/sysconfig.py
--- Python-3.1.2.orig//Lib/distutils/sysconfig.py 2009-06-11 11:31:17.000000000 +0300
+++ Python-3.1.2/Lib/distutils/sysconfig.py 2010-05-30 15:48:29.000000000 +0300
diff -uar Python-3.1.3.orig/Lib/distutils/sysconfig.py Python-3.1.3/Lib/distutils/sysconfig.py
--- Python-3.1.3.orig/Lib/distutils/sysconfig.py 2010-08-04 00:33:04.000000000 +0300
+++ Python-3.1.3/Lib/distutils/sysconfig.py 2010-11-29 21:36:39.452228520 +0200
@@ -117,8 +117,12 @@
prefix = plat_specific and EXEC_PREFIX or PREFIX
@ -35,10 +35,10 @@ diff -uar Python-3.1.2.orig//Lib/distutils/sysconfig.py Python-3.1.2/Lib/distuti
if standard_lib:
return libpython
else:
diff -uar Python-3.1.2.orig//Lib/site.py Python-3.1.2/Lib/site.py
--- Python-3.1.2.orig//Lib/site.py 2009-03-31 02:16:10.000000000 +0300
+++ Python-3.1.2/Lib/site.py 2010-05-30 16:26:34.000000000 +0300
@@ -258,12 +258,16 @@
diff -uar Python-3.1.3.orig/Lib/site.py Python-3.1.3/Lib/site.py
--- Python-3.1.3.orig/Lib/site.py 2010-10-13 01:56:55.000000000 +0300
+++ Python-3.1.3/Lib/site.py 2010-11-29 21:38:44.804126610 +0200
@@ -262,12 +262,16 @@
if sys.platform in ('os2emx', 'riscos'):
sitedirs.append(os.path.join(prefix, "Lib", "site-packages"))
elif os.sep == '/':
@ -55,15 +55,10 @@ diff -uar Python-3.1.2.orig//Lib/site.py Python-3.1.2/Lib/site.py
sitedirs.append(os.path.join(prefix, "lib", "site-packages"))
if sys.platform == "darwin":
diff -uar Python-3.1.2.orig//Makefile.pre.in Python-3.1.2/Makefile.pre.in
--- Python-3.1.2.orig//Makefile.pre.in 2010-03-19 01:01:29.000000000 +0200
+++ Python-3.1.2/Makefile.pre.in 2010-05-30 16:27:59.000000000 +0300
@@ -90,11 +90,11 @@
# Expanded directories
BINDIR= $(exec_prefix)/bin
-LIBDIR= $(exec_prefix)/lib
+LIBDIR= $(exec_prefix)/lib64
diff -uar Python-3.1.3.orig/Makefile.pre.in Python-3.1.3/Makefile.pre.in
--- Python-3.1.3.orig/Makefile.pre.in 2010-10-14 14:35:17.000000000 +0300
+++ Python-3.1.3/Makefile.pre.in 2010-11-29 21:46:00.887367145 +0200
@@ -94,7 +94,7 @@
MANDIR= @mandir@
INCLUDEDIR= @includedir@
CONFINCLUDEDIR= $(exec_prefix)/include
@ -72,9 +67,9 @@ diff -uar Python-3.1.2.orig//Makefile.pre.in Python-3.1.2/Makefile.pre.in
# Detailed destination directories
BINLIBDEST= $(LIBDIR)/python$(VERSION)
diff -uar Python-3.1.2.orig//Modules/Setup.dist Python-3.1.2/Modules/Setup.dist
--- Python-3.1.2.orig//Modules/Setup.dist 2009-06-04 12:30:30.000000000 +0300
+++ Python-3.1.2/Modules/Setup.dist 2010-05-30 16:31:29.000000000 +0300
diff -uar Python-3.1.3.orig/Modules/Setup.dist Python-3.1.3/Modules/Setup.dist
--- Python-3.1.3.orig/Modules/Setup.dist 2009-06-04 12:30:30.000000000 +0300
+++ Python-3.1.3/Modules/Setup.dist 2010-11-29 21:47:10.734770412 +0200
@@ -351,7 +351,7 @@
# Andrew Kuchling's zlib module.
# This require zlib 1.1.3 (or later).
@ -84,10 +79,10 @@ diff -uar Python-3.1.2.orig//Modules/Setup.dist Python-3.1.2/Modules/Setup.dist
# Interface to the Expat XML parser
#
diff -uar Python-3.1.2.orig//Modules/getpath.c Python-3.1.2/Modules/getpath.c
--- Python-3.1.2.orig//Modules/getpath.c 2009-02-12 17:55:38.000000000 +0200
+++ Python-3.1.2/Modules/getpath.c 2010-05-30 16:46:30.000000000 +0300
@@ -117,8 +117,8 @@
diff -uar Python-3.1.3.orig/Modules/getpath.c Python-3.1.3/Modules/getpath.c
--- Python-3.1.3.orig/Modules/getpath.c 2010-10-08 02:39:04.000000000 +0300
+++ Python-3.1.3/Modules/getpath.c 2010-11-29 22:03:08.820526757 +0200
@@ -119,8 +119,8 @@
#endif
#ifndef PYTHONPATH
@ -98,7 +93,7 @@ diff -uar Python-3.1.2.orig//Modules/getpath.c Python-3.1.2/Modules/getpath.c
#endif
#ifndef LANDMARK
@@ -129,7 +129,7 @@
@@ -131,7 +131,7 @@
static wchar_t exec_prefix[MAXPATHLEN+1];
static wchar_t progpath[MAXPATHLEN+1];
static wchar_t *module_search_path = NULL;
@ -107,16 +102,16 @@ diff -uar Python-3.1.2.orig//Modules/getpath.c Python-3.1.2/Modules/getpath.c
/* In principle, this should use HAVE__WSTAT, and _wstat
should be detected by autoconf. However, no current
@@ -603,7 +603,7 @@
@@ -612,7 +612,7 @@
}
else
wcsncpy(zip_path, L"" PREFIX, MAXPATHLEN);
- joinpath(zip_path, L"lib/python00.zip");
+ joinpath(zip_path, L"lib64/python00.zip");
bufsz = wcslen(zip_path); /* Replace "00" with version */
bufsz = wcslen(zip_path); /* Replace "00" with version */
zip_path[bufsz - 6] = VERSION[0];
zip_path[bufsz - 5] = VERSION[2];
@@ -613,7 +613,7 @@
@@ -622,7 +622,7 @@
fprintf(stderr,
"Could not find platform dependent libraries <exec_prefix>\n");
wcsncpy(exec_prefix, L"" EXEC_PREFIX, MAXPATHLEN);
@ -125,10 +120,10 @@ diff -uar Python-3.1.2.orig//Modules/getpath.c Python-3.1.2/Modules/getpath.c
}
/* If we found EXEC_PREFIX do *not* reduce it! (Yet.) */
diff -uar Python-3.1.2.orig//setup.py Python-3.1.2/setup.py
--- Python-3.1.2.orig//setup.py 2010-01-01 18:29:51.000000000 +0200
+++ Python-3.1.2/setup.py 2010-05-30 17:03:54.000000000 +0300
@@ -295,7 +295,7 @@
diff -uar Python-3.1.3.orig/setup.py Python-3.1.3/setup.py
--- Python-3.1.3.orig/setup.py 2010-11-26 13:56:26.000000000 +0200
+++ Python-3.1.3/setup.py 2010-11-29 22:06:52.939575911 +0200
@@ -341,7 +341,7 @@
def detect_modules(self):
# Ensure that /usr/local is always used
@ -137,9 +132,9 @@ diff -uar Python-3.1.2.orig//setup.py Python-3.1.2/setup.py
add_dir_to_list(self.compiler.include_dirs, '/usr/local/include')
# Add paths specified in the environment variables LDFLAGS and
@@ -522,11 +522,11 @@
elif self.compiler.find_library_file(lib_dirs, 'curses'):
readline_libs.append('curses')
@@ -610,11 +610,11 @@
elif curses_library:
readline_libs.append(curses_library)
elif self.compiler.find_library_file(lib_dirs +
- ['/usr/lib/termcap'],
+ ['/usr/lib64/termcap'],
@ -151,7 +146,7 @@ diff -uar Python-3.1.2.orig//setup.py Python-3.1.2/setup.py
extra_link_args=readline_extra_link_args,
libraries=readline_libs) )
else:
@@ -563,8 +563,8 @@
@@ -651,8 +651,8 @@
if krb5_h:
ssl_incs += krb5_h
ssl_libs = find_library_file(self.compiler, 'ssl',lib_dirs,

View file

@ -5,16 +5,14 @@
# Based on Patrick Volkerding's official build script for python
PRGNAM=python3
VERSION=${VERSION:-3.1.2}
VERSION=${VERSION:-3.1.3}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i486 ;;
arm*) ARCH=arm ;;
# Unless $ARCH is already set, use uname -m for all other archs:
*) ARCH=$( uname -m ) ;;
esac
fi
@ -54,7 +52,7 @@ patch -p1 < $CWD/patches/python3.readline.set_pre_input_hook.diff
if [ "$ARCH" = "x86_64" ]; then
# Install to lib64 instead of lib:
patch -p1< $CWD/patches/python3.x86_64.diff
patch -p1 < $CWD/patches/python3.x86_64.diff
# Python must report /usr/lib64/python3.1/site-packages as python_lib_dir:
patch -p1 < $CWD/patches/python3.pure64.diff
fi
@ -77,29 +75,21 @@ chmod -R u+w,go+r-w,a-s+X .
make
make altinstall DESTDIR=$PKG
# Install some python-demo files:
mkdir -p $PKG/usr/doc/python3-$VERSION
cp -a Demo $PKG/usr/doc/python3-$VERSION
# Create a symlink for convenience.
( cd $PKG/usr/bin ; ln -sf python3.1 python3 )
# We'll install the python-tools under site-packages:
mkdir -p $SITEPK
cp -a Tools/* $SITEPK
mkdir -p $PKG/usr/doc/python3-$VERSION
mv $SITEPK/README $PKG/usr/doc/python3-$VERSION/README.python-tools
( cd $PKG/usr/doc/python3-$VERSION ; ln -sf $TOOLSDIR Tools )
# Install docs:
mkdir -p $PKG/usr/doc/python3-$VERSION
cp -a README LICENSE $PKG/usr/doc/python3-$VERSION
cp -a Misc $PKG/usr/doc/python3-$VERSION
cp -a Doc $PKG/usr/doc/python3-$VERSION
# Python 2.6 already has this script.
rm -f $PKG/usr/bin/2to3
# Create a symlink for convenience.
( cd $PKG/usr/bin ; ln -sf python3.1 python3 )
# Install docs and demos:
mkdir -p $PKG/usr/doc/python3-$VERSION
cp -a README LICENSE Demo Doc Misc $PKG/usr/doc/python3-$VERSION
mv $SITEPK/README $PKG/usr/doc/python3-$VERSION/README.python-tools
( cd $PKG/usr/doc/python3-$VERSION ; ln -sf $TOOLSDIR Tools )
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true

View file

@ -1,8 +1,8 @@
PRGNAM="python3"
VERSION="3.1.2"
VERSION="3.1.3"
HOMEPAGE="http://python.org/"
DOWNLOAD="http://python.org/ftp/python/3.1.2/Python-3.1.2.tar.bz2"
MD5SUM="45350b51b58a46b029fb06c61257e350"
DOWNLOAD="http://python.org/ftp/python/3.1.3/Python-3.1.3.tar.bz2"
MD5SUM="ad5e5f1c07e829321e0a015f8cafe245"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
MAINTAINER="Audrius Kažukauskas"