libraries/mxml: Updated for version 2.7.

Signed-off-by: dsomero <xgizzmo@slackbuilds.org>
This commit is contained in:
Kent Fritz 2012-06-25 21:30:35 -04:00 committed by dsomero
parent 872ea0bede
commit 4b090475ed
5 changed files with 28 additions and 34 deletions

View file

@ -1,12 +1,11 @@
diff -Naur mxml-2.6.orig/Makefile.in mxml-2.6/Makefile.in
--- mxml-2.6.orig/Makefile.in 2008-12-06 04:20:38.000000000 +0000
+++ mxml-2.6/Makefile.in 2009-06-02 07:30:21.000000000 +0000
@@ -256,7 +256,7 @@
#
--- mxml-2.7.orig/Makefile.in 2012-06-14 20:05:40.319997357 -0700
+++ mxml-2.7/Makefile.in 2012-06-14 20:23:52.961000179 -0700
@@ -297,7 +297,7 @@
libmxml.so.1.4: $(LIBOBJS)
- $(DSO) $(DSOFLAGS) -o libmxml.so.1.4 $(LIBOBJS)
+ $(DSO) $(DSOFLAGS) -o libmxml.so.1.4 $(LIBOBJS) $(LIBS)
libmxml.so.1.5: $(LIBOBJS)
echo Creating $@...
- $(DSO) $(DSOFLAGS) -o libmxml.so.1.5 $(LIBOBJS)
+ $(DSO) $(DSOFLAGS) -o libmxml.so.1.5 $(LIBOBJS) $(LIBS)
$(RM) libmxml.so libmxml.so.1
$(LN) libmxml.so.1.4 libmxml.so
$(LN) libmxml.so.1.4 libmxml.so.1
$(LN) libmxml.so.1.5 libmxml.so
$(LN) libmxml.so.1.5 libmxml.so.1

View file

@ -3,18 +3,17 @@
# Slackware build script for mxml
# Written by Larry Hajali <larryhaja[at]gmail[dot]com>
# Updated by Kent Fritz <fritz.kent@gmail.com>
PRGNAM=mxml
VERSION=${VERSION:-2.6}
VERSION=${VERSION:-2.7}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i486 ;;
arm*) ARCH=arm ;;
# Unless $ARCH is already set, use uname -m for all other archs:
*) ARCH=$( uname -m ) ;;
esac
fi
@ -71,13 +70,11 @@ CXXFLAGS="$SLKCFLAGS" \
make
make install DSTROOT=$PKG
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
( cd $PKG/usr/man
find . -type f -exec gzip -9 {} \;
for i in $( find . -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
)
find $PKG/usr/man -type f -exec gzip -9 {} \;
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc

View file

@ -1,10 +1,10 @@
PRGNAM="mxml"
VERSION="2.6"
VERSION="2.7"
HOMEPAGE="http://www.minixml.org/"
DOWNLOAD="http://ftp.easysw.com/pub/mxml/2.6/mxml-2.6.tar.gz"
MD5SUM="68977789ae64985dddbd1a1a1652642e"
DOWNLOAD="http://ftp.easysw.com/pub/mxml/2.7/mxml-2.7.tar.gz"
MD5SUM="76f2ae49bf0f5745d5cb5d9507774dc9"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
MAINTAINER="Larry Hajali"
EMAIL="larryhaja[at]gmail[dot]com"
MAINTAINER="Kent Fritz"
EMAIL="fritz.kent@gmail.com"
APPROVED="dsomero"

View file

@ -1,10 +1,8 @@
Index: trunk/configure
===================================================================
--- a/configure 2007-12-15 20:40:05.000000000 -0500
+++ b/configure 2007-12-15 20:40:37.000000000 -0500
--- mxml-2.7.orig/configure 2012-06-14 20:05:40.322997627 -0700
+++ mxml-2.7/configure 2012-06-14 20:28:11.276000237 -0700
@@ -4715,8 +4715,8 @@
echo "${ECHO_T}yes" >&6; }
LIBMXML="libmxml.so.1.4"
LIBMXML="libmxml.so.1.5"
DSO="\$(CC)"
- DSOFLAGS="$DSOFLAGS -Wl,-soname,libmxml.so.1,-rpath,\$(libdir) -shared \$(OPTIM)"
- LDFLAGS="$LDFLAGS -Wl,-rpath,\$(libdir)"

View file

@ -7,13 +7,13 @@
|-----handy-ruler------------------------------------------------------|
mxml: mxml (Lightweight xml parsing library)
mxml:
mxml:
mxml: Mini-XML is a small XML parsing library that you can use to read XML
mxml: and XML-like data files in your application without requiring large
mxml: non-standard libraries.
mxml:
mxml:
mxml: Homepage: http://www.minixml.org/
mxml:
mxml:
mxml:
mxml:
mxml:
mxml:
mxml:
mxml: