mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-18 22:06:04 +01:00
desktop/spectrwm: Updated for version 2.4.0.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
parent
01b88d8428
commit
4b01b571b3
6 changed files with 42 additions and 26 deletions
|
@ -19,8 +19,9 @@ o wifi_link_quality.sh - optional
|
||||||
|
|
||||||
|
|
||||||
spectrwm_screenshot.sh:
|
spectrwm_screenshot.sh:
|
||||||
This makes a screenshot of the actual X11 screen or optionally just a window.
|
This makes a screenshot of the whole X11 screen or optionally just a window.
|
||||||
It needs the graphics/scrot package from the SBo repository.
|
It needs the ImageMagick (included in Slackware) or GraphicsMagick (available
|
||||||
|
from the SBo repository) package's `import` utility.
|
||||||
You can configure it in your spectrwm.conf like this:
|
You can configure it in your spectrwm.conf like this:
|
||||||
program[capture] = spectrwm_screenshot.sh full
|
program[capture] = spectrwm_screenshot.sh full
|
||||||
bind[capture] = MOD+c
|
bind[capture] = MOD+c
|
||||||
|
|
|
@ -17,6 +17,7 @@ title_name_enabled = 1 # current window's title
|
||||||
title_class_enabled = 1 # current window's class name
|
title_class_enabled = 1 # current window's class name
|
||||||
window_name_enabled = 1 # current window's name
|
window_name_enabled = 1 # current window's name
|
||||||
urgent_enabled = 1 # information about the workspace's urgency hints
|
urgent_enabled = 1 # information about the workspace's urgency hints
|
||||||
|
iconic_enabled = 1 # show the number of iconified windows on the workspace
|
||||||
verbose_layout = 0 # workspace's master and stack values
|
verbose_layout = 0 # workspace's master and stack values
|
||||||
|
|
||||||
focus_mode = default # default, follow, manual
|
focus_mode = default # default, follow, manual
|
||||||
|
|
|
@ -1,21 +1,23 @@
|
||||||
#!/bin/sh
|
#!/bin/sh
|
||||||
|
|
||||||
|
|
||||||
SCROT=$(which scrot)
|
CAPTURE_TOOL=/usr/bin/import
|
||||||
[ -x "${SCROT}" ] || exit 1
|
if [ ! -x "${CAPTURE_TOOL}" ];then
|
||||||
|
echo "$0: couldn't run ${CAPTURE_TOOL}" >&2
|
||||||
|
exit 1
|
||||||
|
fi
|
||||||
|
|
||||||
screenshot() {
|
CAPTURE_PATH="${HOME}/spectrwm_capture_$(date +%FT%T).png"
|
||||||
case $1 in
|
|
||||||
full)
|
case "$1" in
|
||||||
"${SCROT}" --multidisp
|
'full')
|
||||||
;;
|
"${CAPTURE_TOOL}" -window root png:"${CAPTURE_PATH}"
|
||||||
window)
|
;;
|
||||||
|
'window')
|
||||||
sleep 0.5
|
sleep 0.5
|
||||||
"${SCROT}" --select
|
"${CAPTURE_TOOL}" png:"${CAPTURE_PATH}"
|
||||||
;;
|
;;
|
||||||
*)
|
*)
|
||||||
;;
|
echo "$0: $0 <-full | -window>" >&2
|
||||||
esac;
|
;;
|
||||||
}
|
esac
|
||||||
|
|
||||||
screenshot $1
|
|
||||||
|
|
|
@ -0,0 +1,9 @@
|
||||||
|
--- linux/Makefile.orig 2013-11-27 10:39:26.448879134 +0100
|
||||||
|
+++ linux/Makefile 2013-11-27 10:42:28.977873694 +0100
|
||||||
|
@@ -1,5 +1,5 @@
|
||||||
|
CFLAGS+= -std=c99 -Wmissing-prototypes -Wall -Wextra -Wshadow -Wno-uninitialized -g
|
||||||
|
-CFLAGS+= -D_GNU_SOURCE -I. -I/usr/include/freetype2 -DSWM_LIB=\"libswmhack.so.$(LVERS)\"
|
||||||
|
+CFLAGS+= -D_GNU_SOURCE -I. -I/usr/include/freetype2 -DSWM_LIB=\"$(LIBDIR)/libswmhack.so.$(LVERS)\"
|
||||||
|
LDADD+= -lX11 -lX11-xcb -lxcb -lxcb-icccm -lxcb-randr -lxcb-keysyms -lxcb-util -lxcb-xtest -lXft -lXcursor
|
||||||
|
|
||||||
|
PREFIX?= /usr/local
|
|
@ -24,7 +24,7 @@
|
||||||
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
||||||
|
|
||||||
PRGNAM=spectrwm
|
PRGNAM=spectrwm
|
||||||
VERSION=${VERSION:-2.3.0}
|
VERSION=${VERSION:-2.4.0}
|
||||||
BUILD=${BUILD:-1}
|
BUILD=${BUILD:-1}
|
||||||
TAG=${TAG:-_SBo}
|
TAG=${TAG:-_SBo}
|
||||||
|
|
||||||
|
@ -65,11 +65,12 @@ tar xvf $CWD/$PRGNAM-$VERSION.tgz
|
||||||
cd $PRGNAM-$VERSION
|
cd $PRGNAM-$VERSION
|
||||||
chown -R root:root .
|
chown -R root:root .
|
||||||
find -L . \
|
find -L . \
|
||||||
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
|
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
|
||||||
-exec chmod 755 {} \; -o \
|
-o -perm 511 \) -exec chmod 755 {} \; -o \
|
||||||
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
|
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
|
||||||
-exec chmod 644 {} \;
|
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
|
||||||
|
|
||||||
|
patch -p0 < $CWD/patches/01-linux_Makefile_swmhack_libdir.diff
|
||||||
cd linux
|
cd linux
|
||||||
CFLAGS="$SLKCFLAGS" make \
|
CFLAGS="$SLKCFLAGS" make \
|
||||||
PREFIX=/usr \
|
PREFIX=/usr \
|
||||||
|
@ -82,7 +83,9 @@ cd linux
|
||||||
DESTDIR=$PKG
|
DESTDIR=$PKG
|
||||||
cd ..
|
cd ..
|
||||||
|
|
||||||
strip --strip-unneeded $PKG/usr/bin/spectrwm
|
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
|
||||||
|
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
|
||||||
|
|
||||||
rm -f $PKG/usr/bin/scrotwm
|
rm -f $PKG/usr/bin/scrotwm
|
||||||
|
|
||||||
# Fixup the manpages
|
# Fixup the manpages
|
||||||
|
|
|
@ -1,8 +1,8 @@
|
||||||
PRGNAM="spectrwm"
|
PRGNAM="spectrwm"
|
||||||
VERSION="2.3.0"
|
VERSION="2.4.0"
|
||||||
HOMEPAGE="https://opensource.conformal.com/wiki/spectrwm"
|
HOMEPAGE="https://opensource.conformal.com/wiki/spectrwm"
|
||||||
DOWNLOAD="https://opensource.conformal.com/snapshots/spectrwm/spectrwm-2.3.0.tgz"
|
DOWNLOAD="https://opensource.conformal.com/snapshots/spectrwm/spectrwm-2.4.0.tgz"
|
||||||
MD5SUM="7698a5b219fdabad07a76ef45b1360d1"
|
MD5SUM="23e32c1e292f2fc94ed88195ffe60023"
|
||||||
DOWNLOAD_x86_64=""
|
DOWNLOAD_x86_64=""
|
||||||
MD5SUM_x86_64=""
|
MD5SUM_x86_64=""
|
||||||
REQUIRES=""
|
REQUIRES=""
|
||||||
|
|
Loading…
Reference in a new issue