mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-18 22:06:04 +01:00
accessibility/jpilot: Updated for version 1.8.0.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackware-id.org> Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
This commit is contained in:
parent
5ee84a7cdc
commit
4a6ac719b5
3 changed files with 7 additions and 240 deletions
|
@ -1,228 +0,0 @@
|
|||
This is a fairly trivial patch to avoid violating POLA when --libdir
|
||||
is specified. --rworkman
|
||||
|
||||
diff -Nur jpilot-1.6.2.orig/Expense/Makefile.in jpilot-1.6.2/Expense/Makefile.in
|
||||
--- jpilot-1.6.2.orig/Expense/Makefile.in 2009-02-15 15:18:34.000000000 -0600
|
||||
+++ jpilot-1.6.2/Expense/Makefile.in 2009-07-11 00:38:17.958608728 -0500
|
||||
@@ -22,7 +22,7 @@
|
||||
top_srcdir = @top_srcdir@
|
||||
VPATH = @srcdir@
|
||||
pkgdatadir = $(datadir)/@PACKAGE@
|
||||
-pkglibdir = $(libdir)/@PACKAGE@
|
||||
+pkglibdir = @libdir@/@PACKAGE@
|
||||
pkgincludedir = $(includedir)/@PACKAGE@
|
||||
top_builddir = ..
|
||||
am__cd = CDPATH="$${ZSH_VERSION+.}$(PATH_SEPARATOR)" && cd
|
||||
@@ -53,7 +53,7 @@
|
||||
mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
|
||||
CONFIG_HEADER = $(top_builddir)/config.h
|
||||
CONFIG_CLEAN_FILES =
|
||||
-am__installdirs = "$(DESTDIR)$(libdir)"
|
||||
+am__installdirs = "$(DESTDIR)$(pluginlibdir)"
|
||||
libLTLIBRARIES_INSTALL = $(INSTALL)
|
||||
LTLIBRARIES = $(lib_LTLIBRARIES)
|
||||
libexpense_la_LIBADD =
|
||||
@@ -230,7 +230,7 @@
|
||||
includedir = @includedir@
|
||||
infodir = @infodir@
|
||||
install_sh = @install_sh@
|
||||
-libdir = $(prefix)/lib/jpilot/plugins
|
||||
+pluginlibdir = $(pkglibdir)/plugins
|
||||
libexecdir = @libexecdir@
|
||||
localedir = @localedir@
|
||||
localstatedir = @localstatedir@
|
||||
@@ -284,12 +284,12 @@
|
||||
cd $(top_builddir) && $(MAKE) $(AM_MAKEFLAGS) am--refresh
|
||||
install-libLTLIBRARIES: $(lib_LTLIBRARIES)
|
||||
@$(NORMAL_INSTALL)
|
||||
- test -z "$(libdir)" || $(mkdir_p) "$(DESTDIR)$(libdir)"
|
||||
+ test -z "$(pluginlibdir)" || $(mkdir_p) "$(DESTDIR)$(pluginlibdir)"
|
||||
@list='$(lib_LTLIBRARIES)'; for p in $$list; do \
|
||||
if test -f $$p; then \
|
||||
f="`echo $$p | sed -e 's|^.*/||'`"; \
|
||||
- echo " $(LIBTOOL) --mode=install $(libLTLIBRARIES_INSTALL) $(INSTALL_STRIP_FLAG) '$$p' '$(DESTDIR)$(libdir)/$$f'"; \
|
||||
- $(LIBTOOL) --mode=install $(libLTLIBRARIES_INSTALL) $(INSTALL_STRIP_FLAG) "$$p" "$(DESTDIR)$(libdir)/$$f"; \
|
||||
+ echo " $(LIBTOOL) --mode=install $(libLTLIBRARIES_INSTALL) $(INSTALL_STRIP_FLAG) '$$p' '$(DESTDIR)$(pluginlibdir)/$$f'"; \
|
||||
+ $(LIBTOOL) --mode=install $(libLTLIBRARIES_INSTALL) $(INSTALL_STRIP_FLAG) "$$p" "$(DESTDIR)$(pluginlibdir)/$$f"; \
|
||||
else :; fi; \
|
||||
done
|
||||
|
||||
@@ -297,8 +297,8 @@
|
||||
@$(NORMAL_UNINSTALL)
|
||||
@list='$(lib_LTLIBRARIES)'; for p in $$list; do \
|
||||
p="`echo $$p | sed -e 's|^.*/||'`"; \
|
||||
- echo " $(LIBTOOL) --mode=uninstall rm -f '$(DESTDIR)$(libdir)/$$p'"; \
|
||||
- $(LIBTOOL) --mode=uninstall rm -f "$(DESTDIR)$(libdir)/$$p"; \
|
||||
+ echo " $(LIBTOOL) --mode=uninstall rm -f '$(DESTDIR)$(pluginlibdir)/$$p'"; \
|
||||
+ $(LIBTOOL) --mode=uninstall rm -f "$(DESTDIR)$(pluginlibdir)/$$p"; \
|
||||
done
|
||||
|
||||
clean-libLTLIBRARIES:
|
||||
@@ -310,7 +310,7 @@
|
||||
rm -f "$${dir}/so_locations"; \
|
||||
done
|
||||
libexpense.la: $(libexpense_la_OBJECTS) $(libexpense_la_DEPENDENCIES)
|
||||
- $(LINK) -rpath $(libdir) $(libexpense_la_LDFLAGS) $(libexpense_la_OBJECTS) $(libexpense_la_LIBADD) $(LIBS)
|
||||
+ $(LINK) -rpath $(pluginlibdir) $(libexpense_la_LDFLAGS) $(libexpense_la_OBJECTS) $(libexpense_la_LIBADD) $(LIBS)
|
||||
|
||||
mostlyclean-compile:
|
||||
-rm -f *.$(OBJEXT)
|
||||
@@ -457,7 +457,7 @@
|
||||
check: check-am
|
||||
all-am: Makefile $(LTLIBRARIES)
|
||||
installdirs:
|
||||
- for dir in "$(DESTDIR)$(libdir)"; do \
|
||||
+ for dir in "$(DESTDIR)$(pluginlibdir)"; do \
|
||||
test -z "$$dir" || $(mkdir_p) "$$dir"; \
|
||||
done
|
||||
install: install-am
|
||||
diff -Nur jpilot-1.6.2.orig/KeyRing/Makefile.in jpilot-1.6.2/KeyRing/Makefile.in
|
||||
--- jpilot-1.6.2.orig/KeyRing/Makefile.in 2009-02-15 15:18:34.000000000 -0600
|
||||
+++ jpilot-1.6.2/KeyRing/Makefile.in 2009-07-11 00:36:45.615683456 -0500
|
||||
@@ -22,7 +22,7 @@
|
||||
top_srcdir = @top_srcdir@
|
||||
VPATH = @srcdir@
|
||||
pkgdatadir = $(datadir)/@PACKAGE@
|
||||
-pkglibdir = $(libdir)/@PACKAGE@
|
||||
+pkglibdir = @libdir@/@PACKAGE@
|
||||
pkgincludedir = $(includedir)/@PACKAGE@
|
||||
top_builddir = ..
|
||||
am__cd = CDPATH="$${ZSH_VERSION+.}$(PATH_SEPARATOR)" && cd
|
||||
@@ -53,7 +53,7 @@
|
||||
mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
|
||||
CONFIG_HEADER = $(top_builddir)/config.h
|
||||
CONFIG_CLEAN_FILES =
|
||||
-am__installdirs = "$(DESTDIR)$(libdir)"
|
||||
+am__installdirs = "$(DESTDIR)$(pluginlibdir)"
|
||||
libLTLIBRARIES_INSTALL = $(INSTALL)
|
||||
LTLIBRARIES = $(lib_LTLIBRARIES)
|
||||
libkeyring_la_LIBADD =
|
||||
@@ -230,7 +230,7 @@
|
||||
includedir = @includedir@
|
||||
infodir = @infodir@
|
||||
install_sh = @install_sh@
|
||||
-libdir = $(prefix)/lib/jpilot/plugins
|
||||
+pluginlibdir = $(pkglibdir)/plugins
|
||||
libexecdir = @libexecdir@
|
||||
localedir = @localedir@
|
||||
localstatedir = @localstatedir@
|
||||
@@ -285,12 +285,12 @@
|
||||
cd $(top_builddir) && $(MAKE) $(AM_MAKEFLAGS) am--refresh
|
||||
install-libLTLIBRARIES: $(lib_LTLIBRARIES)
|
||||
@$(NORMAL_INSTALL)
|
||||
- test -z "$(libdir)" || $(mkdir_p) "$(DESTDIR)$(libdir)"
|
||||
+ test -z "$(pluginlibdir)" || $(mkdir_p) "$(DESTDIR)$(pluginlibdir)"
|
||||
@list='$(lib_LTLIBRARIES)'; for p in $$list; do \
|
||||
if test -f $$p; then \
|
||||
f="`echo $$p | sed -e 's|^.*/||'`"; \
|
||||
- echo " $(LIBTOOL) --mode=install $(libLTLIBRARIES_INSTALL) $(INSTALL_STRIP_FLAG) '$$p' '$(DESTDIR)$(libdir)/$$f'"; \
|
||||
- $(LIBTOOL) --mode=install $(libLTLIBRARIES_INSTALL) $(INSTALL_STRIP_FLAG) "$$p" "$(DESTDIR)$(libdir)/$$f"; \
|
||||
+ echo " $(LIBTOOL) --mode=install $(libLTLIBRARIES_INSTALL) $(INSTALL_STRIP_FLAG) '$$p' '$(DESTDIR)$(pluginlibdir)/$$f'"; \
|
||||
+ $(LIBTOOL) --mode=install $(libLTLIBRARIES_INSTALL) $(INSTALL_STRIP_FLAG) "$$p" "$(DESTDIR)$(pluginlibdir)/$$f"; \
|
||||
else :; fi; \
|
||||
done
|
||||
|
||||
@@ -298,8 +298,8 @@
|
||||
@$(NORMAL_UNINSTALL)
|
||||
@list='$(lib_LTLIBRARIES)'; for p in $$list; do \
|
||||
p="`echo $$p | sed -e 's|^.*/||'`"; \
|
||||
- echo " $(LIBTOOL) --mode=uninstall rm -f '$(DESTDIR)$(libdir)/$$p'"; \
|
||||
- $(LIBTOOL) --mode=uninstall rm -f "$(DESTDIR)$(libdir)/$$p"; \
|
||||
+ echo " $(LIBTOOL) --mode=uninstall rm -f '$(DESTDIR)$(pluginlibdir)/$$p'"; \
|
||||
+ $(LIBTOOL) --mode=uninstall rm -f "$(DESTDIR)$(pluginlibdir)/$$p"; \
|
||||
done
|
||||
|
||||
clean-libLTLIBRARIES:
|
||||
@@ -311,7 +311,7 @@
|
||||
rm -f "$${dir}/so_locations"; \
|
||||
done
|
||||
libkeyring.la: $(libkeyring_la_OBJECTS) $(libkeyring_la_DEPENDENCIES)
|
||||
- $(LINK) -rpath $(libdir) $(libkeyring_la_LDFLAGS) $(libkeyring_la_OBJECTS) $(libkeyring_la_LIBADD) $(LIBS)
|
||||
+ $(LINK) -rpath $(pluginlibdir) $(libkeyring_la_LDFLAGS) $(libkeyring_la_OBJECTS) $(libkeyring_la_LIBADD) $(LIBS)
|
||||
|
||||
mostlyclean-compile:
|
||||
-rm -f *.$(OBJEXT)
|
||||
@@ -458,7 +458,7 @@
|
||||
check: check-am
|
||||
all-am: Makefile $(LTLIBRARIES)
|
||||
installdirs:
|
||||
- for dir in "$(DESTDIR)$(libdir)"; do \
|
||||
+ for dir in "$(DESTDIR)$(pluginlibdir)"; do \
|
||||
test -z "$$dir" || $(mkdir_p) "$$dir"; \
|
||||
done
|
||||
install: install-am
|
||||
diff -Nur jpilot-1.6.2.orig/SyncTime/Makefile.in jpilot-1.6.2/SyncTime/Makefile.in
|
||||
--- jpilot-1.6.2.orig/SyncTime/Makefile.in 2009-02-15 15:18:34.000000000 -0600
|
||||
+++ jpilot-1.6.2/SyncTime/Makefile.in 2009-07-11 00:36:58.331536319 -0500
|
||||
@@ -22,7 +22,7 @@
|
||||
top_srcdir = @top_srcdir@
|
||||
VPATH = @srcdir@
|
||||
pkgdatadir = $(datadir)/@PACKAGE@
|
||||
-pkglibdir = $(libdir)/@PACKAGE@
|
||||
+pkglibdir = @libdir@/@PACKAGE@
|
||||
pkgincludedir = $(includedir)/@PACKAGE@
|
||||
top_builddir = ..
|
||||
am__cd = CDPATH="$${ZSH_VERSION+.}$(PATH_SEPARATOR)" && cd
|
||||
@@ -53,7 +53,7 @@
|
||||
mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
|
||||
CONFIG_HEADER = $(top_builddir)/config.h
|
||||
CONFIG_CLEAN_FILES =
|
||||
-am__installdirs = "$(DESTDIR)$(libdir)"
|
||||
+am__installdirs = "$(DESTDIR)$(pluginlibdir)"
|
||||
libLTLIBRARIES_INSTALL = $(INSTALL)
|
||||
LTLIBRARIES = $(lib_LTLIBRARIES)
|
||||
libsynctime_la_LIBADD =
|
||||
@@ -230,7 +230,7 @@
|
||||
includedir = @includedir@
|
||||
infodir = @infodir@
|
||||
install_sh = @install_sh@
|
||||
-libdir = $(prefix)/lib/jpilot/plugins
|
||||
+pluginlibdir = $(pkglibdir)/plugins
|
||||
libexecdir = @libexecdir@
|
||||
localedir = @localedir@
|
||||
localstatedir = @localstatedir@
|
||||
@@ -284,12 +284,12 @@
|
||||
cd $(top_builddir) && $(MAKE) $(AM_MAKEFLAGS) am--refresh
|
||||
install-libLTLIBRARIES: $(lib_LTLIBRARIES)
|
||||
@$(NORMAL_INSTALL)
|
||||
- test -z "$(libdir)" || $(mkdir_p) "$(DESTDIR)$(libdir)"
|
||||
+ test -z "$(pluginlibdir)" || $(mkdir_p) "$(DESTDIR)$(pluginlibdir)"
|
||||
@list='$(lib_LTLIBRARIES)'; for p in $$list; do \
|
||||
if test -f $$p; then \
|
||||
f="`echo $$p | sed -e 's|^.*/||'`"; \
|
||||
- echo " $(LIBTOOL) --mode=install $(libLTLIBRARIES_INSTALL) $(INSTALL_STRIP_FLAG) '$$p' '$(DESTDIR)$(libdir)/$$f'"; \
|
||||
- $(LIBTOOL) --mode=install $(libLTLIBRARIES_INSTALL) $(INSTALL_STRIP_FLAG) "$$p" "$(DESTDIR)$(libdir)/$$f"; \
|
||||
+ echo " $(LIBTOOL) --mode=install $(libLTLIBRARIES_INSTALL) $(INSTALL_STRIP_FLAG) '$$p' '$(DESTDIR)$(pluginlibdir)/$$f'"; \
|
||||
+ $(LIBTOOL) --mode=install $(libLTLIBRARIES_INSTALL) $(INSTALL_STRIP_FLAG) "$$p" "$(DESTDIR)$(pluginlibdir)/$$f"; \
|
||||
else :; fi; \
|
||||
done
|
||||
|
||||
@@ -297,8 +297,8 @@
|
||||
@$(NORMAL_UNINSTALL)
|
||||
@list='$(lib_LTLIBRARIES)'; for p in $$list; do \
|
||||
p="`echo $$p | sed -e 's|^.*/||'`"; \
|
||||
- echo " $(LIBTOOL) --mode=uninstall rm -f '$(DESTDIR)$(libdir)/$$p'"; \
|
||||
- $(LIBTOOL) --mode=uninstall rm -f "$(DESTDIR)$(libdir)/$$p"; \
|
||||
+ echo " $(LIBTOOL) --mode=uninstall rm -f '$(DESTDIR)$(pluginlibdir)/$$p'"; \
|
||||
+ $(LIBTOOL) --mode=uninstall rm -f "$(DESTDIR)$(pluginlibdir)/$$p"; \
|
||||
done
|
||||
|
||||
clean-libLTLIBRARIES:
|
||||
@@ -310,7 +310,7 @@
|
||||
rm -f "$${dir}/so_locations"; \
|
||||
done
|
||||
libsynctime.la: $(libsynctime_la_OBJECTS) $(libsynctime_la_DEPENDENCIES)
|
||||
- $(LINK) -rpath $(libdir) $(libsynctime_la_LDFLAGS) $(libsynctime_la_OBJECTS) $(libsynctime_la_LIBADD) $(LIBS)
|
||||
+ $(LINK) -rpath $(pluginlibdir) $(libsynctime_la_LDFLAGS) $(libsynctime_la_OBJECTS) $(libsynctime_la_LIBADD) $(LIBS)
|
||||
|
||||
mostlyclean-compile:
|
||||
-rm -f *.$(OBJEXT)
|
||||
@@ -457,7 +457,7 @@
|
||||
check: check-am
|
||||
all-am: Makefile $(LTLIBRARIES)
|
||||
installdirs:
|
||||
- for dir in "$(DESTDIR)$(libdir)"; do \
|
||||
+ for dir in "$(DESTDIR)$(pluginlibdir)"; do \
|
||||
test -z "$$dir" || $(mkdir_p) "$$dir"; \
|
||||
done
|
||||
install: install-am
|
|
@ -25,16 +25,14 @@
|
|||
# OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
||||
|
||||
PRGNAM=jpilot
|
||||
VERSION=${VERSION:-1.6.2}
|
||||
VERSION=${VERSION:-1.8.1}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
# Automatically determine the architecture we're building on:
|
||||
if [ -z "$ARCH" ]; then
|
||||
case "$( uname -m )" in
|
||||
i?86) ARCH=i486 ;;
|
||||
arm*) ARCH=arm ;;
|
||||
# Unless $ARCH is already set, use uname -m for all other archs:
|
||||
*) ARCH=$( uname -m ) ;;
|
||||
esac
|
||||
fi
|
||||
|
@ -66,14 +64,11 @@ cd $TMP rm -rf $PRGNAM-$VERSION
|
|||
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
|
||||
cd $PRGNAM-$VERSION
|
||||
chown -R root:root .
|
||||
find . \
|
||||
find -L . \
|
||||
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
|
||||
-exec chmod 755 {} \; -o \
|
||||
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
|
||||
-exec chmod 644 {} \;
|
||||
|
||||
# Use correct libdir for the plugins
|
||||
patch -p1 < $CWD/jpilot-1.6.2-fixup_plugins_libdir.diff
|
||||
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
|
||||
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
|
||||
|
||||
CFLAGS="$SLKCFLAGS" \
|
||||
CXXFLAGS="$SLKCFLAGS" \
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
PRGNAM="jpilot"
|
||||
VERSION="1.6.2"
|
||||
VERSION="1.8.1"
|
||||
HOMEPAGE="http://www.jpilot.org"
|
||||
DOWNLOAD="http://jpilot.org/jpilot-1.6.2.tar.gz"
|
||||
MD5SUM="72967dee4a1715ebe27e50e12f1e63d8"
|
||||
DOWNLOAD="http://jpilot.org/jpilot-1.8.1.tar.gz"
|
||||
MD5SUM="ac59a5708f37e30d39e85b1fcedd266f"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
REQUIRES=""
|
||||
|
|
Loading…
Reference in a new issue