mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-07 20:27:02 +01:00
libraries/flatbuffers: Updated for version 1.12.0.
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
This commit is contained in:
parent
75bf431eae
commit
4994981b74
3 changed files with 5 additions and 25 deletions
|
@ -23,7 +23,7 @@
|
|||
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
||||
|
||||
PRGNAM=flatbuffers
|
||||
VERSION=${VERSION:-1.7.1}
|
||||
VERSION=${VERSION:-1.12.0}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
|
@ -69,7 +69,6 @@ find -L . \
|
|||
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
|
||||
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
|
||||
|
||||
patch -p1 < $CWD/flatbuffers.patch
|
||||
mkdir -p build
|
||||
cd build
|
||||
cmake \
|
||||
|
@ -77,7 +76,7 @@ cd build
|
|||
-DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
|
||||
-DCMAKE_BUILD_TYPE=Release \
|
||||
-DCMAKE_INSTALL_PREFIX=/usr \
|
||||
-DLIB_SUFFIX=${LIBDIRSUFFIX} \
|
||||
-DCMAKE_INSTALL_LIBDIR=/usr/lib${LIBDIRSUFFIX} \
|
||||
-DFLATBUFFERS_BUILD_FLATC=ON \
|
||||
-DFLATBUFFERS_BUILD_FLATHASH=ON \
|
||||
-DFLATBUFFERS_BUILD_FLATLIB=ON \
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
PRGNAM="flatbuffers"
|
||||
VERSION="1.7.1"
|
||||
VERSION="1.12.0"
|
||||
HOMEPAGE="https://github.com/google/flatbuffers/"
|
||||
DOWNLOAD="https://github.com/google/flatbuffers/archive/v1.7.1/flatbuffers-1.7.1.tar.gz"
|
||||
MD5SUM="81934736f31fbd2cfdb513e71b53b358"
|
||||
DOWNLOAD="https://github.com/google/flatbuffers/archive/v1.12.0/flatbuffers-1.12.0.tar.gz"
|
||||
MD5SUM="c62ffefb3d4548b127cca14ce047f16c"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
REQUIRES=""
|
||||
|
|
|
@ -1,19 +0,0 @@
|
|||
diff -ur flatbuffers-1.5.0.old/CMakeLists.txt flatbuffers-1.5.0/CMakeLists.txt
|
||||
--- flatbuffers-1.5.0.old/CMakeLists.txt 2017-01-03 20:56:44.000000000 -0200
|
||||
+++ flatbuffers-1.5.0/CMakeLists.txt 2017-01-05 18:41:09.742061141 -0200
|
||||
@@ -224,13 +224,13 @@
|
||||
if(FLATBUFFERS_INSTALL)
|
||||
install(DIRECTORY include/flatbuffers DESTINATION include)
|
||||
if(FLATBUFFERS_BUILD_FLATLIB)
|
||||
- install(TARGETS flatbuffers DESTINATION lib)
|
||||
+ install(TARGETS flatbuffers DESTINATION lib${LIB_SUFFIX})
|
||||
endif()
|
||||
if(FLATBUFFERS_BUILD_FLATC)
|
||||
install(TARGETS flatc DESTINATION bin)
|
||||
endif()
|
||||
if(FLATBUFFERS_BUILD_SHAREDLIB)
|
||||
- install(TARGETS flatbuffers_shared DESTINATION lib)
|
||||
+ install(TARGETS flatbuffers_shared DESTINATION lib${LIB_SUFFIX})
|
||||
endif()
|
||||
endif()
|
||||
|
Loading…
Reference in a new issue