network/weechat: Added (a curses-based IRC client).

This commit is contained in:
Coredumb 2010-05-13 01:19:34 -05:00 committed by Robby Workman
parent 455e696cca
commit 4992dbb3e5
5 changed files with 132 additions and 0 deletions

13
network/weechat/README Normal file
View file

@ -0,0 +1,13 @@
WeeChat is a light & fast multilingual curses-based multiplatform IRC client.
WeeChat supports:
DCC files and chats, multi-server connections, background connections,
IPv6, SSL, proxy, auto-reconnection, DCC2, nicklist, window splitting,
FIFO pipe for remote control, aspell, perl, python, ruby, nick auto-
completion, lag indication, auto-logging, client upgrades without
dropping connections.
WeeChat will build with support for:
aspell, perl scripting, python scripting, ruby scripting, lua scripting,
and gnutls depending on whether or not they are installed on the system
on which WeeChat is built.

View file

@ -0,0 +1,19 @@
# HOW TO EDIT THIS FILE:
# The "handy ruler" below makes it easier to edit a package description. Line
# up the first '|' above the ':' following the base package name, and the '|'
# on the right side marks the last column you can put a character in. You must
# make exactly 11 lines for the formatting to be correct. It's also
# customary to leave one space after the ':'.
|-----handy-ruler------------------------------------------------------|
weechat: weechat (a light & fast curses-based IRC client)
weechat:
weechat: WeeChat is a fast & light multilingual curses-based multiplatform
weechat: IRC client written from scratch and released under the GPL.
weechat:
weechat:
weechat:
weechat:
weechat:
weechat:
weechat:

View file

@ -0,0 +1,12 @@
diff -Nur weechat-0.3.2.orig//CMakeLists.txt weechat-0.3.2/CMakeLists.txt
--- weechat-0.3.2.orig//CMakeLists.txt 2010-04-17 04:24:46.000000000 -0500
+++ weechat-0.3.2/CMakeLists.txt 2010-05-13 01:02:38.829782889 -0500
@@ -108,7 +108,7 @@
SET(PACKAGE "${PROJECT_NAME}")
SET(prefix "${CMAKE_INSTALL_PREFIX}")
SET(exec_prefix "\${prefix}")
-SET(libdir "\${exec_prefix}/lib")
+SET(libdir "\${exec_prefix}/lib64")
SET(includedir "\${prefix}/include")
CONFIGURE_FILE(${CMAKE_CURRENT_SOURCE_DIR}/weechat.pc.in ${CMAKE_CURRENT_BINARY_DIR}/weechat.pc @ONLY)
INSTALL(FILES ${CMAKE_CURRENT_BINARY_DIR}/weechat.pc DESTINATION ${LIBDIR}/../pkgconfig)

View file

@ -0,0 +1,78 @@
#!/bin/sh
## Written by hollywoodb (hollywoodb@fastmail.fm)
# Modified by the SlackBuilds.org project
# Modified for Slackware 13 and V0.3.2 by oliver_dot_mauras_AT_gmail_dot_com
PRGNAM=weechat
VERSION=0.3.2
ARCH=${ARCH:-i486}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
if [ "$ARCH" = "i486" ]; then
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
LIBDIRSUFFIX="64"
fi
set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $TMP/$PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
cd $PRGNAM-$VERSION
chown -R root:root .
chmod -R u+w,go+r-w,a-s .
if [ "$ARCH" = "x86_64" ]; then
patch -p1 < $CWD/weechat-0.3.2-set_pkgconfig_libdir_on_x86_64.diff || exit 1
fi
mkdir build
cd build
cmake \
-DPREFIX=/usr \
-DLIBDIR=/usr/lib${LIBDIRSUFFIX} \
-DCMAKE_BUILD_TYPE=Debug \
-DCFLAGS="$SLKCFLAGS" \
-DCXXFLAGS="$SLKCFLAGS" \
..
make
make install DESTDIR=$PKG
cd ..
# Make the binary and manpage required for this a bit more obvious
( cd $PKG/usr/bin ; ln -s weechat-curses weechat )
( mv $PKG/usr/share/man $PKG/usr/man/ )
( cd $PKG/usr/man/man1 ; ln -s weechat-curses.1 weechat.1 )
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
( cd $PKG/usr/man
find . -type f -exec gzip -9 {} \;
for i in $( find . -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
)
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a AUTHORS COPYING ChangeLog INSTALL NEWS README $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}

View file

@ -0,0 +1,10 @@
PRGNAM="weechat"
VERSION="0.3.2"
HOMEPAGE="http://www.weechat.org"
DOWNLOAD="http://www.weechat.org/files/src/weechat-0.3.2.tar.bz2"
MD5SUM="b0b00b321203dd5746a25248a9adaa92"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
MAINTAINER="Coredumb"
EMAIL="oliver.mauras@gmail.com"
APPROVED="rworkman"