mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-24 10:02:29 +01:00
academic/octave: Remove Qt5 detection.
Patch by Larry Hajali Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
This commit is contained in:
parent
3795956fae
commit
49395366cd
3 changed files with 27 additions and 6 deletions
|
@ -4,11 +4,10 @@ linear and nonlinear problems numerically, and for performing other numerical
|
|||
experiments using a language that is mostly compatible with Matlab. It may
|
||||
also be used as a batch-oriented language.
|
||||
|
||||
These optional dependencies will be used if found. See INSTALL.OCTAVE (in the
|
||||
Octave source) for a description of what each dependency offers.
|
||||
|
||||
AMD, CAMD, COLAMD, CCOLAMD, CHOLMOD, UMFPACK, CXSparse, glpk, arpack-ng,
|
||||
qrupdate, qhull, HDF5, fltk, ftgl, gl2ps, jdk, GraphicsMagick
|
||||
These optional dependencies will be used if found (see INSTALL.OCTAVE, in the
|
||||
Octave source, for a description of what each dependency offers):
|
||||
amd, camd, colamd, ccolamd, cholmod, umfpack, cxsparse, glpk, arpack-ng,
|
||||
qrupdate, qhull, hdf5, fltk, ftgl, gl2ps, jdk, GraphicsMagick.
|
||||
|
||||
Octave can use ImageMagick (part of Slackware) or GraphicsMagick (available
|
||||
from SBo) for some functionality. ImageMagick 6.8.6-10 from Slackware 14.1
|
||||
|
|
|
@ -24,7 +24,7 @@
|
|||
|
||||
PRGNAM=octave
|
||||
VERSION=${VERSION:-3.8.0}
|
||||
BUILD=${BUILD:-1}
|
||||
BUILD=${BUILD:-2}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
if [ -z "$ARCH" ]; then
|
||||
|
@ -82,6 +82,10 @@ find -L . \
|
|||
# https://savannah.gnu.org/bugs/?41054
|
||||
patch -p1 < $CWD/patches/compressed-info.diff
|
||||
|
||||
# Don't try to detect Qt5. It's not supported yet.
|
||||
# https://savannah.gnu.org/bugs/?40252
|
||||
patch -p1 < $CWD/patches/no-qt5.diff
|
||||
|
||||
# Fix several configure checks due to the above umfpack.h -> amd.h issue.
|
||||
# https://savannah.gnu.org/bugs/?41209
|
||||
patch -p1 < $CWD/patches/umfpack-cppflags.diff
|
||||
|
|
18
academic/octave/patches/no-qt5.diff
Normal file
18
academic/octave/patches/no-qt5.diff
Normal file
|
@ -0,0 +1,18 @@
|
|||
diff --git a/configure.ac b/configure.ac
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -2707,10 +2707,10 @@
|
||||
fi
|
||||
|
||||
if test $build_gui = yes; then
|
||||
- AC_CHECK_TOOLS(MOC, [moc-qt5 moc-qt4 moc])
|
||||
- AC_CHECK_TOOLS(UIC, [uic-qt5 uic-qt4 uic])
|
||||
- AC_CHECK_TOOLS(RCC, [rcc-qt5 rcc-qt4 rcc])
|
||||
- AC_CHECK_TOOLS(LRELEASE, [lrelease-qt5 lrelease-qt4 lrelease])
|
||||
+ AC_CHECK_TOOLS(MOC, [moc-qt4 moc])
|
||||
+ AC_CHECK_TOOLS(UIC, [uic-qt4 uic])
|
||||
+ AC_CHECK_TOOLS(RCC, [rcc-qt4 rcc])
|
||||
+ AC_CHECK_TOOLS(LRELEASE, [lrelease-qt4 lrelease])
|
||||
if test -n "$MOC" && test -n "$UIC" && test -n "$RCC" && test -n "$LRELEASE"; then
|
||||
AC_DEFINE(HAVE_QT, 1,
|
||||
[Define to 1 if Qt is available (libraries, developer header files, utility programs (moc, uic, rcc, and lrelease))])
|
Loading…
Reference in a new issue