network/zarafa: Updated for version 7.0.1.

Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
This commit is contained in:
Niels Horn 2011-10-02 11:05:18 -05:00 committed by Robby Workman
parent 6e2887c594
commit 475c91bd1a
5 changed files with 45 additions and 67 deletions

View file

@ -4,3 +4,6 @@ mobile phone support, Outlook sharing (100% MAPI) etc.
This requires libvmime-zarafa, and zarafa-webaccess-ajax is needed
at runtime.
If you want to upgrade a zarafa 6.x.y database, you will need the
zarafa7-upgrade tool, which needs MySQL-python.

View file

@ -1,32 +0,0 @@
--- zarafa-6.40.2/ECtools/ECTestTools/RecurrenceTest/rectest.cpp 2010-08-30 08:01:44.000000000 -0300
+++ zarafa-6.40.2_patched/ECtools/ECTestTools/RecurrenceTest/rectest.cpp 2010-09-04 13:27:42.000000000 -0300
@@ -79,7 +79,7 @@
RecurrenceState r;
- hr = r.ParseBlob((char *)strBin.c_str(), strBin.size());
+ hr = r.ParseBlob((char *)strBin.c_str(), strBin.size(), 0);
if(hr == hrSuccess) {
cerr << "Recurrence OK" << std::endl;
--- zarafa-6.40.2/ECtools/ECTestTools/ICalTests/mapi2ical.cpp 2010-08-30 08:01:44.000000000 -0300
+++ zarafa-6.40.2_patched/ECtools/ECTestTools/ICalTests/mapi2ical.cpp 2010-09-04 13:55:38.000000000 -0300
@@ -170,7 +170,7 @@
goto next;
- hr = lpMapiToICal->AddMessage(lpMessage, 0);
+ hr = lpMapiToICal->AddMessage(lpMessage, std::string(), 0);
if (hr != hrSuccess) {
cerr << "-- broken message!" << stringify(hr, 1) << endl;
goto next;
--- zarafa-6.40.2/ECtools/ECTestTools/ICalTests/Makefile.in 2010-08-30 04:31:48.000000000 -0300
+++ zarafa-6.40.2_patched/ECtools/ECTestTools/ICalTests/Makefile.in 2010-09-04 15:09:39.000000000 -0300
@@ -272,6 +272,7 @@
${top_builddir}/common/libcommon_mapi.la \
${top_builddir}/common/libcommon_util.la \
${top_builddir}/libicalmapi/libicalmapi.la \
+ ${top_builddir}/libfreebusy/libfreebusy.la \
$(PROG_LIBS) $(ICAL_LIBS)
mapi2ical_SOURCES = mapi2ical.cpp

View file

@ -1,11 +0,0 @@
--- zarafa-6.40.1/configure 2010-08-03 06:42:48.000000000 -0300
+++ zarafa-6.40.1_patched/configure 2010-08-30 23:46:08.000000000 -0300
@@ -22693,7 +22693,7 @@
_ACEOF
VMIME_CFLAGS=-I$VMIME_PREFIX
- VMIME_LIBS="-lvmime"
+ VMIME_LIBS="-lvmime-zarafa"
else

View file

@ -3,11 +3,30 @@
# Slackware build script for zarafa:
# an MS Exchange substitute
# Written by Niels Horn <niels.horn@gmail.com>
# revision date 2010/11/30
# Copyright 2009-2011 Niels Horn, Rio de Janeiro, RJ, Brazil
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
#
# 1. Redistributions of this script must retain the above copyright
# notice, this list of conditions and the following disclaimer.
#
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
# revision date 2011/09/16
PRGNAM=zarafa
VERSION=${VERSION:-6.40.3}
VERSION=${VERSION:-7.0.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@ -19,6 +38,8 @@ if [ -z "$ARCH" ]; then
esac
fi
SRCNAM=zcp
CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
@ -43,23 +64,13 @@ set -e
rm -rf $TMP/$PRGNAM-$VERSION $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
chmod -R u+w,go+r-w,a-s .
# Apply patch to use "vmime-zarafa" instead of "vmime"
patch -p1 < $CWD/vmime-zarafa.patch
# Apply patch to solve some problems with the ECTestTools in 6.40.2 & 6.40.3
# it seems upstream forgot to adapt them to the new version...
patch -p1 < $CWD/testtools.patch
SLKCFLAGS="$SLKCFLAGS -I/usr/include/vmime-zarafa"
CFLAGS=$SLKCFLAGS \
CXXFLAGS=$SLKCFLAGS \
CPPFLAGS=$SLKCFLAGS \
VMIME_LIBS="-lvmime-zarafa" \
VMIME_CFLAGS="-I/usr/include/vmime-zarafa"
./configure \
--prefix=/usr \
--libdir=/usr/lib${LIBDIRSUFFIX} \
@ -74,7 +85,14 @@ CPPFLAGS=$SLKCFLAGS \
--with-clucene-lib-prefix=/usr/lib${LIBDIRSUFFIX} \
--build=$ARCH-slackware-linux
make
# Use our CFLAGS
for mf in $(find . -name Makefile); do
sed -i "/^C[X]*[X]*FLAGS/s/=/+=/" $mf
done
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
make
make install DESTDIR=$PKG
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
@ -88,9 +106,9 @@ for cfg in $PKG/etc/$PRGNAM/*.cfg; do
mv $cfg $cfg.new
done
# The sample config of zarafa-indexer ends up in the wrong directory somehow...
mv $PKG/usr/share/doc/zarafa-indexer/example-config/* $PKG/usr/doc/$PRGNAM-$VERSION/example-config/
rm -rf $PKG/usr/share/doc
# The doc of zarafa-gateway ends up in the wrong directory somehow...
mv $PKG/usr/doc/zarafa-gateway/* $PKG/usr/doc/$PRGNAM-$VERSION/
rmdir $PKG/usr/doc/zarafa-gateway
# Remove sysconfig files. We don't use them and they only set the collation,
# which is taken care of in the rc.* scripts as well

View file

@ -1,10 +1,10 @@
PRGNAM="zarafa"
VERSION="6.40.3"
VERSION="7.0.1"
HOMEPAGE="http://www.zarafa.com/"
DOWNLOAD="http://www.nielshorn.net/_download/slackware/source/zarafa-6.40.3.tar.gz"
MD5SUM="a2177498a1cc054b8beaba9a3887ec89"
DOWNLOAD="http://download.zarafa.com/community/final/7.0/7.0.1-28479/sourcecode/zcp-7.0.1.tar.gz"
MD5SUM="2c268b1e5cba538c7d84ec9a742c3347"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
MAINTAINER="Niels Horn"
EMAIL="niels.horn@gmail.com"
APPROVED="Erik Hanson"
APPROVED="rworkman"