mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-21 19:42:24 +01:00
multimedia/mlt: fix build against Qt 5.7.1
Signed-off-by: Larry Hajali <larryhaja[at]gmail[dot]com>
This commit is contained in:
parent
b67bfa3061
commit
468a62df15
3 changed files with 35 additions and 4 deletions
|
@ -18,5 +18,3 @@ fi
|
|||
if [ -x /usr/bin/update-mime-database ]; then
|
||||
/usr/bin/update-mime-database usr/share/mime >/dev/null 2>&1
|
||||
fi
|
||||
|
||||
config etc/php.d/mlt.ini.new
|
||||
|
|
|
@ -51,7 +51,7 @@
|
|||
|
||||
PRGNAM=mlt
|
||||
VERSION=${VERSION:-6.2.0}
|
||||
BUILD=${BUILD:-2}
|
||||
BUILD=${BUILD:-3}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
if [ -z "$ARCH" ]; then
|
||||
|
@ -118,6 +118,9 @@ find -L . \
|
|||
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
|
||||
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
|
||||
|
||||
# Fix building against qt >= 5.7.
|
||||
patch -p1 < $CWD/qt5-5.7.patch
|
||||
|
||||
CFLAGS="$SLKCFLAGS" \
|
||||
CXXFLAGS="$SLKCFLAGS" \
|
||||
./configure \
|
||||
|
@ -164,7 +167,6 @@ if [ "$php" ]; then
|
|||
; extension=$PRGNAM.so
|
||||
EOF
|
||||
)
|
||||
echo "config etc/php.d/$PRGNAM.ini.new" >> $CWD/doinst.sh
|
||||
fi
|
||||
if [ "$python" ]; then
|
||||
PYTHONSITEPKG=$(python -c "import sys, os; print os.path.join('/usr/lib${LIBDIRSUFFIX}', 'python%s' % sys.version[:3], 'site-packages')")
|
||||
|
@ -205,5 +207,9 @@ mkdir -p $PKG/install
|
|||
cat $CWD/slack-desc > $PKG/install/slack-desc
|
||||
cat $CWD/doinst.sh > $PKG/install/doinst.sh
|
||||
|
||||
if [ "$php" ]; then
|
||||
echo "config etc/php.d/$PRGNAM.ini.new" >> $PKG/install/doinst.sh
|
||||
fi
|
||||
|
||||
cd $PKG
|
||||
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
|
||||
|
|
27
multimedia/mlt/qt5-5.7.patch
Normal file
27
multimedia/mlt/qt5-5.7.patch
Normal file
|
@ -0,0 +1,27 @@
|
|||
From 053204f4a243559644af2c47ae9895810685cb5a Mon Sep 17 00:00:00 2001
|
||||
From: Dan Dennedy <dan@dennedy.org>
|
||||
Date: Sun, 8 Jan 2017 10:22:33 -0800
|
||||
Subject: [PATCH] Only use --std=c++11 CXXFLAG for g++.
|
||||
|
||||
The addition of --std=c++11 breaks build on my OS X 10.8 build agent,
|
||||
which uses clang version "Apple LLVM version 8.0.0 (clang-800.0.42.1)"
|
||||
---
|
||||
src/modules/qt/Makefile | 6 +++++-
|
||||
1 file changed, 5 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/modules/qt/Makefile b/src/modules/qt/Makefile
|
||||
index e7b55ae..d88e519 100644
|
||||
--- a/src/modules/qt/Makefile
|
||||
+++ b/src/modules/qt/Makefile
|
||||
@@ -39,7 +39,11 @@ ifneq ($(targetos), MinGW)
|
||||
endif
|
||||
endif
|
||||
|
||||
CXXFLAGS := $(QTCXXFLAGS) $(CXXFLAGS) $(CFLAGS) $(EXIFCXXFLAGS) $(KDECXXFLAGS) -Wno-deprecated
|
||||
+
|
||||
+ifneq (, $(shell $(CXX) --version | grep -is gcc))
|
||||
+ CXXFLAGS += --std=c++11
|
||||
+endif
|
||||
|
||||
LDFLAGS += $(QTLIBS) $(EXIFLIBS) $(KDELIBS)
|
||||
|
Loading…
Reference in a new issue