mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-06 08:26:50 +01:00
office/LibreOffice: Updated for version 7.1.2.2.
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
This commit is contained in:
parent
bfbbae8991
commit
45e2c3bca8
4 changed files with 55 additions and 65 deletions
|
@ -4,7 +4,7 @@
|
|||
|
||||
# Slackware build script for LibreOffice
|
||||
|
||||
# Copyright 2015-2019 Christoph Willing Brisbane, Australia
|
||||
# Copyright 2015-2021 Christoph Willing Brisbane, Australia
|
||||
# All rights reserved.
|
||||
#
|
||||
# Redistribution and use of this script, with or without modification, is
|
||||
|
@ -26,11 +26,10 @@
|
|||
|
||||
PRGNAM=LibreOffice
|
||||
SRCNAM=libreoffice
|
||||
VERSION=${VERSION:-6.2.8.2}
|
||||
VERSION=${VERSION:-7.1.2.2}
|
||||
SHORT_VERSION=${VERSION%.*.*}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
PACKAGER=${PACKAGER:-"AnonymousCoward"}
|
||||
|
||||
HAVE_SRCS_TARBALL=${HAVE_SRCS_TARBALL:-1}
|
||||
|
||||
|
@ -91,16 +90,22 @@ jval="$(echo $MAKEFLAGS |grep -o "\-j *[0-9]*" | grep -o "[0-9]*")" || true
|
|||
# If PARALLEL environment variable is set, use that to override everything.
|
||||
[ "${PARALLEL:-0}" != "0" ] && parallel="--with-parallelism=$PARALLEL"
|
||||
|
||||
JAVA=${JAVA:-openjdk7}
|
||||
if [ "$JAVA" = "openjdk7" ]; then
|
||||
. /etc/profile.d/openjdk7.sh
|
||||
use_java="--with-java=java"
|
||||
elif [ "$JAVA" = "openjdk8" ]; then
|
||||
. /etc/profile.d/openjdk8.sh
|
||||
use_java="--with-java=java"
|
||||
elif [ "$JAVA" = "jdk" ]; then
|
||||
. /etc/profile.d/jdk.sh
|
||||
use_java="--with-java=java"
|
||||
JAVA=${JAVA:-jdk11}
|
||||
if [ "$JAVA" = "jdk11" ]; then
|
||||
. /etc/profile.d/jdk11.sh
|
||||
use_java="--with-jdk-home=$JAVA_HOME"
|
||||
elif [ "$JAVA" = "jdk12" ]; then
|
||||
. /etc/profile.d/jdk12.sh
|
||||
use_java="--with-jdk-home=$JAVA_HOME"
|
||||
elif [ "$JAVA" = "jdk13" ]; then
|
||||
. /etc/profile.d/jdk13.sh
|
||||
use_java="--with-jdk-home=$JAVA_HOME"
|
||||
elif [ "$JAVA" = "jdk14" ]; then
|
||||
. /etc/profile.d/jdk14.sh
|
||||
use_java="--with-jdk-home=$JAVA_HOME"
|
||||
elif [ "$JAVA" = "jdk15" ]; then
|
||||
. /etc/profile.d/jdk15.sh
|
||||
use_java="--with-jdk-home=$JAVA_HOME"
|
||||
elif [ "$JAVA" = "no" ]; then
|
||||
use_java="--with-java=no"
|
||||
fi
|
||||
|
@ -154,7 +159,6 @@ if pkg-config --exists python3 ; then Python3="--enable-python=system" ; else Py
|
|||
if pkg-config --exists Qt5 ; then qt5="--enable-qt5" ; else qt5="" ; fi
|
||||
if pkg-config --exists valgrind ; then valgrind="--with-valgrind" ; else valgrind="" ; fi
|
||||
|
||||
kde4="--enable-kde4" ; [ "${KDE4:-yes}" != "yes" ] && kde4="--disable-kde4"
|
||||
use_ccache="--disable-ccache" ; [ "${USE_CCACHE:-no}" != "no" ] && use_ccache=""
|
||||
|
||||
# Extensions
|
||||
|
@ -175,7 +179,6 @@ extnlpsolver="--enable-ext-nlpsolver"; [ "${EXTNLPSOLVER:-yes}" != "yes" ] &
|
|||
--libdir=/usr/lib$LIBDIRSUFFIX \
|
||||
--sysconfdir=/etc \
|
||||
--build=$ARCH-slackware-linux \
|
||||
--with-build-version="SlackBuild for $PRGNAM-$VERSION by $PACKAGER" \
|
||||
--with-vendor="Just Another Slacker" \
|
||||
--with-lang="$LOLANGS" \
|
||||
--enable-release-build=yes \
|
||||
|
@ -188,7 +191,6 @@ extnlpsolver="--enable-ext-nlpsolver"; [ "${EXTNLPSOLVER:-yes}" != "yes" ] &
|
|||
$avahi \
|
||||
$Python3 \
|
||||
$vlc \
|
||||
$kde4 \
|
||||
$use_ccache \
|
||||
$use_java \
|
||||
$parallel \
|
||||
|
@ -225,7 +227,6 @@ extnlpsolver="--enable-ext-nlpsolver"; [ "${EXTNLPSOLVER:-yes}" != "yes" ] &
|
|||
--with-system-openldap \
|
||||
--with-system-openssl \
|
||||
--with-system-poppler \
|
||||
--with-system-redland \
|
||||
--with-system-sane \
|
||||
--with-system-zlib \
|
||||
$coinmp \
|
||||
|
@ -273,6 +274,13 @@ fi
|
|||
|
||||
patch -p0 < $CWD/no-check-if-root.diff
|
||||
|
||||
# GCC10 requirements (Tx alienBOB)
|
||||
sed -i external/libcdr/ExternalProject_libcdr.mk \
|
||||
-e '/configure /i \\t\t&& sed -i "s/TRUE/true/g" src/lib/libcdr_utils.cpp \\'
|
||||
sed -i external/libebook/ExternalProject_libebook.mk \
|
||||
-e '/configure /i \\t\t&& sed -i "s/TRUE/true/g" src/lib/EBOOKCharsetConverter.cpp \\'
|
||||
sed -i i18npool/source/calendar/calendar_gregorian.cxx -e 's/TRUE/true/'
|
||||
|
||||
export LDFLAGS="-lboost_system"
|
||||
make build-nocheck
|
||||
make distro-pack-install DESTDIR=$PKG
|
||||
|
|
|
@ -1,12 +1,12 @@
|
|||
PRGNAM="LibreOffice"
|
||||
VERSION="6.2.8.2"
|
||||
VERSION="7.1.2.2"
|
||||
HOMEPAGE="https://www.libreoffice.org"
|
||||
DOWNLOAD="https://download.documentfoundation.org/libreoffice/src/6.2.8/libreoffice-6.2.8.2.tar.xz \
|
||||
http://sourceforge.net/projects/slackbuildsdirectlinks/files/LibreOffice/libreoffice-6.2.8.2-srcs.tar.xz"
|
||||
MD5SUM="1438fdfae3076b8b1b1460054a318f0b \
|
||||
b5d5e57832056d8a5625b1d5dc3aa024"
|
||||
DOWNLOAD="https://download.documentfoundation.org/libreoffice/src/7.1.2/libreoffice-7.1.2.2.tar.xz \
|
||||
https://sourceforge.net/projects/slackbuildsdirectlinks/files/LibreOffice/libreoffice-7.1.2.2-srcs.tar.xz"
|
||||
MD5SUM="60af85a8960ef2bc0f70880e589dc12c \
|
||||
2dafa97e09bb43c3f7ea7f122940597d"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
REQUIRES="python3 openjdk7 apache-ant perl-Archive-Zip"
|
||||
REQUIRES="jdk11 apache-ant perl-Archive-Zip"
|
||||
MAINTAINER="Christoph Willing"
|
||||
EMAIL="chris.willing@linux.com"
|
||||
|
|
|
@ -20,7 +20,7 @@ internal versions. Packages from SBo that will be use in this way are:
|
|||
libexttextcat libfreehand libmspub libmwaw libnumbertext liborcus
|
||||
libpagemaker libqxp libnumbertext libstaroffice libtommath libwps libzmf
|
||||
lpsolve mythes postgresql qt5 valgrind ucpp unixODBC avahi
|
||||
libetonyek xmlsec vlc
|
||||
libetonyek xmlsec
|
||||
|
||||
Remember, these packages are not essential but entirely optional. If not found,
|
||||
LibreOffice will simply build its own internal versions.
|
||||
|
@ -31,34 +31,26 @@ e.g. if avahi is detected and used at build time, it will also need to be
|
|||
installed at run time.
|
||||
|
||||
Build time environment variables that may be set to vary features are as follows:
|
||||
1. enable the experimental VLC avmedia backend (disabled by default) with:
|
||||
VLC="yes"
|
||||
This requires the vlc package (available from SBo) to be installed.
|
||||
|
||||
2. disable kde4 support (enabled by default) with:
|
||||
KDE4="no"
|
||||
|
||||
3. support additional languages by overriding the LOLANGS variable, whose
|
||||
1. support additional languages by overriding the LOLANGS variable, whose
|
||||
default setting is LOLANGS="de es fr id it ja nl vi zh-CN". Note that en-US
|
||||
is always added to whatever LOLANGS is set. Thus building with, for example,
|
||||
LOLANGS="de" sh LibreOffice
|
||||
LOLANGS="de" sh LibreOffice.SlackBuild
|
||||
would build LibreOffice with support for german and US english languages.
|
||||
Additionally, setting LOLANGS="ALL" will build in support for all available
|
||||
languages.
|
||||
|
||||
4. A number of Java Development Kits are suitable for building LibreOffice.
|
||||
The default JDK for this SlackBuild is openjdk7. Others may be chosen by
|
||||
setting the JAVA environment variable when running the SlackBuild. Recognised
|
||||
values are openjdk7 (the default, not explicitly required), openjdk8 and jdk
|
||||
e.g. JAVA=jdk (to use SBo jdk package with Oracle binary version). Using an
|
||||
alternate JDK will require presence of the appropriate package when building
|
||||
LibreOffice. Since the apache-ant package is already required by openjdk7,
|
||||
hence openjdk8, its listing in the REQUIRES field is redundant in these cases.
|
||||
However it remains listed to accomodate the case of JAVA=jdk, in which the
|
||||
apache-ant package is needed to build LibreOffice.
|
||||
Finally, setting JAVA=no will build LibreOffice without any Java support.
|
||||
2. A number of Java Development Kits are suitable for building LibreOffice.
|
||||
At the moment (since, at least, LO version 7.0.0.3) the default JDK is the
|
||||
latest LTS release, jdk11. Other JDK's supported by the SlackBuild are jdk12,
|
||||
jdk13, jdk14 & jdk15 but these non-default JDK's must be explicitly specified
|
||||
when running the SlackBuild using the JAVA environment variable e.g.
|
||||
JAVA=jdk15 sh LibreOffice.SlackBuild
|
||||
|
||||
5. The number of parallel make jobs used by the LibreOffice build system defaults
|
||||
It is also possible to build LibreOffice without any JAVA support (with
|
||||
somewhat reduced capability in LO Base) by running:
|
||||
JAVA=no sh LibreOffice.SlackBuild
|
||||
|
||||
3. The number of parallel make jobs used by the LibreOffice build system defaults
|
||||
to the number of available cpu cores. If the MAKEFLAGS environment variable
|
||||
contains the -j option e.g.
|
||||
MAKEFLAGS=-j6
|
||||
|
@ -69,7 +61,7 @@ Build time environment variables that may be set to vary features are as follows
|
|||
which would limit building to a single make process, overriding any value set
|
||||
with the -j option in MAKEFLAGS.
|
||||
|
||||
6. Use of ccache during building is turned off by default to save disk space (and
|
||||
4. Use of ccache during building is turned off by default to save disk space (and
|
||||
possible build failure due to lack of disk space). It may be reinstated by
|
||||
setting the USE_CCACHE environment to "yes" e.g.
|
||||
USE_CCACHE=yes sh LibreOffice.SlackBuild
|
||||
|
|
|
@ -1,20 +1,10 @@
|
|||
--- Makefile.orig 2018-02-07 22:18:13.161535968 +1000
|
||||
+++ Makefile 2018-02-07 22:17:41.560533422 +1000
|
||||
@@ -9,7 +9,7 @@
|
||||
--- Makefile.orig 2020-12-13 08:04:37.172000000 +1000
|
||||
+++ Makefile 2020-12-13 08:04:58.538000000 +1000
|
||||
@@ -63,7 +63,6 @@
|
||||
echo; \
|
||||
echo 'Building LibreOffice as root is a very bad idea, use a regular user.'; \
|
||||
echo; \
|
||||
- exit 1; \
|
||||
fi
|
||||
|
||||
gb_Top_MODULE_CHECK_TARGETS := slowcheck unitcheck subsequentcheck perfcheck uicheck screenshot
|
||||
|
||||
-.PHONY : all check-if-root bootstrap gbuild build build-non-l10n-only build-l10n-only check clean clean-build clean-host test-install distclean distro-pack-install docs download etags fetch get-submodules id install install-gdb-printers install-strip tags debugrun help showmodules translations packageinfo internal.clean $(gb_Top_MODULE_CHECK_TARGETS)
|
||||
+.PHONY : all bootstrap gbuild build build-non-l10n-only build-l10n-only check clean clean-build clean-host test-install distclean distro-pack-install docs download etags fetch get-submodules id install install-gdb-printers install-strip tags debugrun help showmodules translations packageinfo internal.clean $(gb_Top_MODULE_CHECK_TARGETS)
|
||||
|
||||
MAKECMDGOALS?=all
|
||||
build_goal:=$(if $(filter build check,$(MAKECMDGOALS)),all)\
|
||||
@@ -254,7 +254,7 @@
|
||||
#
|
||||
# Bootstrap
|
||||
#
|
||||
-bootstrap: check-if-root compilerplugins
|
||||
+bootstrap: compilerplugins
|
||||
|
||||
#
|
||||
# Build
|
||||
gb_Side ?= host
|
||||
|
|
Loading…
Reference in a new issue