libraries/gtksourceview: Fix several build issues.

Signed-off-by: Mikko Värri <vmj@linuxbox.fi>
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
This commit is contained in:
Mikko Värri 2012-09-11 08:30:23 -05:00 committed by Robby Workman
parent 45bde4d181
commit 4546743ec0
4 changed files with 90 additions and 2 deletions

View file

@ -0,0 +1,10 @@
--- configure.orig 2012-09-11 11:07:07.750998010 +0300
+++ configure 2012-09-11 11:07:25.848998458 +0300
@@ -10955,7 +10955,6 @@
if test "$enable_deprecations" = "yes"; then
DISABLE_DEPRECATED_CFLAGS="\
--DG_DISABLE_DEPRECATED \
-DGDK_DISABLE_DEPRECATED \
-DGTK_DISABLE_DEPRECATED \
-DGDK_PIXBUF_DISABLE_DEPRECATED \

View file

@ -0,0 +1,47 @@
--- configure.orig 2012-09-11 02:15:41.304005832 +0300
+++ configure 2012-09-11 02:17:41.957003984 +0300
@@ -10820,23 +10820,6 @@
fi
-if test "$enable_deprecations" = "yes"; then
- DISABLE_DEPRECATED_CFLAGS="\
--DG_DISABLE_DEPRECATED \
--DGDK_DISABLE_DEPRECATED \
--DGTK_DISABLE_DEPRECATED \
--DGDK_PIXBUF_DISABLE_DEPRECATED \
--DGNOME_DISABLE_DEPRECATED"
-
- if $PKG_CONFIG --atleast-version 2.90 $GTK_REQUIRED; then
- DISABLE_DEPRECATED_CFLAGS="$DISABLE_DEPRECATED_CFLAGS -DGSEAL_ENABLE"
- fi
-
-
-fi
-
-
-
if test "x$ac_cv_env_PKG_CONFIG_set" != "xset"; then
if test -n "$ac_tool_prefix"; then
# Extract the first word of "${ac_tool_prefix}pkg-config", so it can be a program name with args.
@@ -10970,6 +10953,20 @@
fi
+if test "$enable_deprecations" = "yes"; then
+ DISABLE_DEPRECATED_CFLAGS="\
+-DG_DISABLE_DEPRECATED \
+-DGDK_DISABLE_DEPRECATED \
+-DGTK_DISABLE_DEPRECATED \
+-DGDK_PIXBUF_DISABLE_DEPRECATED \
+-DGNOME_DISABLE_DEPRECATED"
+
+ if $PKG_CONFIG --atleast-version 2.90 $GTK_REQUIRED; then
+ DISABLE_DEPRECATED_CFLAGS="$DISABLE_DEPRECATED_CFLAGS -DGSEAL_ENABLE"
+ fi
+
+
+fi
pkg_failed=no

View file

@ -0,0 +1,13 @@
--- configure.orig 2012-09-11 03:34:25.354997735 +0300
+++ configure 2012-09-11 03:35:50.618000004 +0300
@@ -10935,8 +10935,8 @@
fi
if test -n "$PKG_CONFIG" && \
- { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"gtk+-3.0 >= 2.90\""; } >&5
- ($PKG_CONFIG --exists --print-errors "gtk+-3.0 >= 2.90") 2>&5
+ { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"gtk+-3.0 >= 3.5\""; } >&5
+ ($PKG_CONFIG --exists --print-errors "gtk+-3.0 >= 3.5") 2>&5
ac_status=$?
$as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
test $ac_status = 0; }; then

View file

@ -26,7 +26,7 @@
PRGNAM=gtksourceview
VERSION=${VERSION:-2.11.2}
BUILD=${BUILD:-1}
BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
# Automatically determine the architecture we're building on:
@ -73,6 +73,22 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
# In configure.ac, PKG_CONFIG environment variable is used before it
# is set. Instead of fixing configure.ac and regenerating all of the
# build framework, let's just monkey patch the configure script.
patch -p0 <$CWD/fix-pkg-config-use-before-set.patch
# gtksourceview 2.11.2 seems to claim to be compatible with gtk3 =>
# 2.90, but in reality is not compatible with the one in Slackware
# 14.0. Let's force the configure script to pick up gtk2 instead by
# raising the minimum gtk3 version.
patch -p0 <$CWD/force-gtk2.patch
# Code is still using G_CONST_RETURN which is deprecated in the
# version of glib shipping with Slackware 14.0. Let's remove the
# G_DISABLE_DEPRECATED from C preprocessor flags.
patch -p0 <$CWD/allow-deprecated-glib-symbols.patch
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
@ -85,7 +101,9 @@ CXXFLAGS="$SLKCFLAGS" \
--enable-glade-catalog \
--build=$ARCH-slackware-linux
make
# At the end of build process, the uninstalled gtksourceview.pc is
# used. Let's make sure pkg-config can find it.
PKG_CONFIG_PATH=$PKG_CONFIG_PATH:$TMP/$PRGNAM-$VERSION make
make install-strip DESTDIR=$PKG
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \