mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-20 19:41:34 +01:00
libraries/ClientForm: Added to 12.2 repository
This commit is contained in:
parent
1b9c385766
commit
4406fcfcb5
5 changed files with 101 additions and 0 deletions
55
libraries/ClientForm/ClientForm.SlackBuild
Normal file
55
libraries/ClientForm/ClientForm.SlackBuild
Normal file
|
@ -0,0 +1,55 @@
|
|||
#!/bin/sh
|
||||
|
||||
# Slackware build script for ClientForm
|
||||
|
||||
# Written by Larry Hajali <larryhaja[at]gmail[dot]com>
|
||||
|
||||
PRGNAM=ClientForm
|
||||
VERSION=${VERSION:-0.2.10}
|
||||
ARCH=${ARCH:-i486}
|
||||
BUILD=${BUILD:-2}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
CWD=$(pwd)
|
||||
TMP=${TMP:-/tmp/SBo}
|
||||
PKG=$TMP/package-$PRGNAM
|
||||
OUTPUT=${OUTPUT:-/tmp}
|
||||
|
||||
set -eu
|
||||
|
||||
rm -rf $PKG
|
||||
mkdir -p $TMP $PKG $OUTPUT
|
||||
cd $TMP
|
||||
rm -rf $PRGNAM-$VERSION
|
||||
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
|
||||
cd $PRGNAM-$VERSION
|
||||
chown -R root:root .
|
||||
find . \
|
||||
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
|
||||
-exec chmod 755 {} \; -o \
|
||||
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
|
||||
-exec chmod 644 {} \;
|
||||
|
||||
# Use system pysetuptools
|
||||
patch -p1 < $CWD/pysetuptools.diff
|
||||
|
||||
python setup.py install --root=$PKG
|
||||
|
||||
( cd $PKG
|
||||
find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | \
|
||||
xargs strip --strip-unneeded 2> /dev/null || true
|
||||
find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | \
|
||||
xargs strip --strip-unneeded 2> /dev/null
|
||||
)
|
||||
|
||||
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
mv testdata $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cp -a *.txt *.html $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cp -a test/test_clientform.py examples/* $PKG/usr/doc/$PRGNAM-$VERSION/testdata
|
||||
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
|
||||
|
||||
mkdir -p $PKG/install
|
||||
cat $CWD/slack-desc > $PKG/install/slack-desc
|
||||
|
||||
cd $PKG
|
||||
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
|
8
libraries/ClientForm/ClientForm.info
Normal file
8
libraries/ClientForm/ClientForm.info
Normal file
|
@ -0,0 +1,8 @@
|
|||
PRGNAM="ClientForm"
|
||||
VERSION="0.2.10"
|
||||
HOMEPAGE="http://wwwsearch.sourceforge.net/ClientForm/"
|
||||
DOWNLOAD="http://wwwsearch.sourceforge.net/ClientForm/src/ClientForm-0.2.10.tar.gz"
|
||||
MD5SUM="832c0ca78674f9263d1fc5fab8756e66"
|
||||
MAINTAINER="Larry Hajali"
|
||||
EMAIL="larryhaja[at]gmail[dot]com"
|
||||
APPROVED="dsomero,rworkman"
|
7
libraries/ClientForm/README
Normal file
7
libraries/ClientForm/README
Normal file
|
@ -0,0 +1,7 @@
|
|||
ClientForm is a Python module for handling HTML forms on the client
|
||||
side, useful for parsing HTML forms, filling them in and returning
|
||||
the completed forms to the server. It developed from a port of Gisle
|
||||
Aas' Perl module HTML::Form, from the libwww-perl library, but the
|
||||
interface is not the same.
|
||||
|
||||
Requires pysetuptools.
|
12
libraries/ClientForm/pysetuptools.diff
Normal file
12
libraries/ClientForm/pysetuptools.diff
Normal file
|
@ -0,0 +1,12 @@
|
|||
diff -Naur ClientForm-0.2.10.orig/setup.py ClientForm-0.2.10/setup.py
|
||||
--- ClientForm-0.2.10.orig/setup.py 2008-12-03 23:12:31.000000000 +0000
|
||||
+++ ClientForm-0.2.10/setup.py 2009-03-16 15:48:45.000000000 +0000
|
||||
@@ -89,8 +89,6 @@
|
||||
del kwargs["py_modules"]
|
||||
apply(_setup, (), kwargs)
|
||||
else:
|
||||
- import ez_setup
|
||||
- ez_setup.use_setuptools()
|
||||
from setuptools import setup
|
||||
|
||||
setup(
|
19
libraries/ClientForm/slack-desc
Normal file
19
libraries/ClientForm/slack-desc
Normal file
|
@ -0,0 +1,19 @@
|
|||
# HOW TO EDIT THIS FILE:
|
||||
# The "handy ruler" below makes it easier to edit a package description. Line
|
||||
# up the first '|' above the ':' following the base package name, and the '|' on
|
||||
# the right side marks the last column you can put a character in. You must make
|
||||
# exactly 11 lines for the formatting to be correct. It's also customary to
|
||||
# leave one space after the ':'.
|
||||
|
||||
|-----handy-ruler------------------------------------------------------|
|
||||
ClientForm: ClientForm (Python module for handling HTML forms)
|
||||
ClientForm:
|
||||
ClientForm: ClientForm is a Python module for handling HTML forms on the client
|
||||
ClientForm: side, useful for parsing HTML forms, filling them in and returning
|
||||
ClientForm: the completed forms to the server.
|
||||
ClientForm:
|
||||
ClientForm: Homepage: http://wwwsearch.sourceforge.net/ClientForm/
|
||||
ClientForm:
|
||||
ClientForm:
|
||||
ClientForm:
|
||||
ClientForm:
|
Loading…
Reference in a new issue