network/offlineimap: Updated for version 6.3.3.

Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
This commit is contained in:
Nishant Limbachia 2011-07-14 23:38:28 -05:00 committed by Robby Workman
parent 620bcf57a3
commit 4324182352
6 changed files with 24 additions and 42 deletions

View file

@ -1,2 +1,4 @@
OfflineIMAP is a tool to sync remote imap mailboxes and
specifically useful in syncing imap servers.
OfflineIMAP is a tool to sync remote imap mailboxes and particularly
useful in syncing mailboxes between two imap servers.
This requires docutils.

View file

@ -1,11 +0,0 @@
--- Makefile.orig 2009-05-06 21:10:37.578993290 -0500
+++ Makefile 2009-05-06 21:11:37.266485486 -0500
@@ -38,7 +38,7 @@
docbook2man offlineimap.sgml
docbook2html -u offlineimap.sgml
mv offlineimap.html manual.html
- man -t -l offlineimap.1 > manual.ps
+ man -t ./offlineimap.1 > manual.ps
ps2pdf manual.ps
groff -Tascii -man offlineimap.1 | sed $$'s/.\b//g' > manual.txt
-rm manpage.links manpage.refs manual.ps

View file

@ -11,4 +11,3 @@ config() {
# Otherwise, we leave the .new copy for the admin to consider...
}
config etc/offlineimap.conf.new

View file

@ -1,9 +1,9 @@
#!/bin/sh
# Slackware build script for OfflineIMAP
# Home Page http://software.complete.org/software/projects/show/offlineimap
# Home Page https://github.com/nicolas33/offlineimap
# Copyright (c) 2008-2009, Nishant Limbachia, Hoffman Est, IL, USA (nishant@mnspace.net)
# Copyright (c) 2008-2011, Nishant Limbachia, Hoffman Estates, IL, USA <nishant _AT_ mnspace _DOT_ net>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@ -24,23 +24,20 @@
# NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
# SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=offlineimap
VERSION=6.2.0
SRCNAM="nicolas33-offlineimap-v6.3.3-0-g3b09695"
PRGNAM="offlineimap"
VERSION=${VERSION:-6.3.3}
BUILD=${BUILD:-1}
TAG=${TAG=_SBo}
TAG=${TAG:-_SBo}
# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i486 ;;
arm*) ARCH=arm ;;
# Unless $ARCH is already set, use uname -m for all other archs:
*) ARCH=$( uname -m ) ;;
esac
fi
SRCNAM="nicolas33-offlineimap-debian-6.2.0-0-g5d4fe0c.tar.gz"
CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
@ -51,9 +48,10 @@ set -e # Exit on most errors
rm -fr $TMP/$PRGNAM-$VERSION $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
tar xvf $CWD/$SRCNAM
mv nicolas33-offlineimap-1a9381a $PRGNAM-$VERSION
tar xvf $CWD/$SRCNAM.tar.gz
mv nicolas33-offlineimap-cf325d5 $PRGNAM-$VERSION
cd $PRGNAM-$VERSION
chown -R root.root .
find . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
@ -61,25 +59,18 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
### build and install
python setup.py install --root=$PKG
### patch makefile to fix document generation
patch -p0 < $CWD/doc_generation_fix.patch
### make and install docs
make doc
mkdir -p $PKG/usr/{man/man1,doc/$PRGNAM-$VERSION} $PKG/etc
python setup.py install --root=$PKG
make doc man
### install config file
install -m 0644 -D $PRGNAM.conf $PKG/etc/$PRGNAM.conf.new
install -m 0644 $PRGNAM.1 $PKG/usr/man/man1
gzip -9 $PKG/usr/man/man1/$PRGNAM.1
cp -a \
COPYING COPYRIGHT UPGRADING FAQ.html manual.* $PRGNAM.conf* \
$PKG/usr/doc/$PRGNAM-$VERSION
COPYING COPYRIGHT readme.html $PRGNAM.conf* docs/*.html \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install

View file

@ -1,8 +1,8 @@
PRGNAM="offlineimap"
VERSION="6.2.0"
VERSION="6.3.3"
HOMEPAGE="https://github.com/nicolas33/offlineimap"
DOWNLOAD="http://download.github.com/nicolas33-offlineimap-debian-6.2.0-0-g5d4fe0c.tar.gz"
MD5SUM="50723cdc1370e53138e896d676369a31"
DOWNLOAD="https://github.com/nicolas33/offlineimap/tarball/v6.3.3"
MD5SUM="cdccc3f22011e4fefd6e1ba36e0bae66"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
MAINTAINER="Nishant Limbachia"

View file

@ -3,15 +3,16 @@
# up the first '|' above the ':' following the base package name, and the '|'
# on the right side marks the last column you can put a character in. You must
# make exactly 11 lines for the formatting to be correct. It's also
# customary to leave one space after the ':'.
|-----handy-ruler-----------------------------------------------|
# customary to leave one space after the ':' except on otherwise blank lines.
|-----handy-ruler------------------------------------------------------|
offlineimap: offlineimap (IMAP sync tool)
offlineimap:
offlineimap: OfflineIMAP allows you to sync imap mailboxes between remote
offlineimap: and local machines. It is most useful in syncing user
offlineimap: mailboxes between imap servers.
offlineimap:
offlineimap: http://software.complete.org/software/projects/show/offlineimap
offlineimap: Homepage: https://github.com/nicolas33/offlineimap
offlineimap:
offlineimap:
offlineimap: