mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-04 20:29:09 +01:00
desktop/dmenu: Updated for version 4.6.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
parent
dfd57b9de4
commit
3ef94c2968
5 changed files with 109 additions and 37 deletions
|
@ -1,27 +0,0 @@
|
|||
diff -Naur dmenu-4.5-orig/config.mk dmenu-4.5/config.mk
|
||||
--- dmenu-4.5-orig/config.mk 2012-01-08 07:18:43.000000000 -0500
|
||||
+++ dmenu-4.5/config.mk 2012-03-03 13:13:44.000000000 -0500
|
||||
@@ -4,6 +4,7 @@
|
||||
# paths
|
||||
PREFIX = /usr/local
|
||||
MANPREFIX = ${PREFIX}/share/man
|
||||
+LIBDIR = /usr/local/lib
|
||||
|
||||
X11INC = /usr/X11R6/include
|
||||
X11LIB = /usr/X11R6/lib
|
||||
@@ -14,12 +15,13 @@
|
||||
|
||||
# includes and libs
|
||||
INCS = -I${X11INC}
|
||||
-LIBS = -L${X11LIB} -lX11 ${XINERAMALIBS}
|
||||
+LIBS = -L${LIBDIR} -L${X11LIB} -lX11 ${XINERAMALIBS}
|
||||
|
||||
# flags
|
||||
+OPTS ?= -Os
|
||||
CPPFLAGS = -D_BSD_SOURCE -D_POSIX_C_SOURCE=2 -DVERSION=\"${VERSION}\" ${XINERAMAFLAGS}
|
||||
#CFLAGS = -g -std=c99 -pedantic -Wall -O0 ${INCS} ${CPPFLAGS}
|
||||
-CFLAGS = -std=c99 -pedantic -Wall -Os ${INCS} ${CPPFLAGS}
|
||||
+CFLAGS = -std=c99 -pedantic -Wall ${OPTS} ${INCS} ${CPPFLAGS}
|
||||
LDFLAGS = -s ${LIBS}
|
||||
|
||||
# compiler and linker
|
71
desktop/dmenu/dmenu-4.6-ReleaseNotes.txt
Normal file
71
desktop/dmenu/dmenu-4.6-ReleaseNotes.txt
Normal file
|
@ -0,0 +1,71 @@
|
|||
From: Hiltjo Posthuma <hiltjo_AT_codemadness.org>
|
||||
Date: Mon, 9 Nov 2015 00:50:44 +0100
|
||||
|
||||
Hi suckless developers!,
|
||||
|
||||
After a long time (dwm 4.5 was released on 2012-01-08) it is time for a new
|
||||
dmenu release. Thanks goes out to all the people involved at making the software
|
||||
better in various ways!
|
||||
|
||||
Alot of things have changed, make sure to update your config.h and rebase the
|
||||
wiki patches you maintain on dmenu 4.6.
|
||||
|
||||
The older wiki patches (specifically pre-4.5 and legacy) and
|
||||
functionality that was merged
|
||||
(xft) will be removed in a while (few weeks time).
|
||||
|
||||
|
||||
Download
|
||||
========
|
||||
|
||||
dmenu-4.6: http://dl.suckless.org/tools/dmenu-4.6.tar.gz
|
||||
SHA1: 16297db470b370a16d532fba3cfd9743758ada80
|
||||
|
||||
|
||||
Release notes
|
||||
=============
|
||||
|
||||
I tried to reconstruct the notes from the git log and give credit to
|
||||
the proper authors, there may be some mistakes.
|
||||
|
||||
Features:
|
||||
- Now uses Xft for font rendering by default with fallback-font
|
||||
support, this also allows anti-aliased fonts and such.
|
||||
The font string matching will be different, check out
|
||||
http://www.freedesktop.org/software/fontconfig/fontconfig-user.html
|
||||
for the font string syntax, huge thanks to Eric Pruitt and the
|
||||
other people who worked on the dmenu-xft patch (previously on the
|
||||
wiki).
|
||||
- Uses a shared libdraw codebase (also used for dwm right now).
|
||||
- Merged wiki patches:
|
||||
- monarg: allow to specify monitor number to start on with -m (Martin Kühl).
|
||||
- multisel: allow selecting multiple items (ctrl-enter) (Evan Gates).
|
||||
- xft: see above.
|
||||
- Accepted vi'is exit approach ^[ (Arkaduisz).
|
||||
- Add ^G escape keybinding (Karl F).
|
||||
- Separate config options to config.h (Alex Sedov).
|
||||
- Support keybind C-S-[jm] (Connor Lane Smith).
|
||||
- stest: get rid of getopt, use suckless arg.h (Hiltjo).
|
||||
- stest: support inverse matching (flag -v) (Martin Kühl).
|
||||
|
||||
Notable fixes:
|
||||
- Buffer nul termination on tab (Alex Sedov's).
|
||||
- Crash (pointer dereference) with ctrl-enter as input (Hiltjo).
|
||||
- Ignore prompt if it is empty in addition to NULL (Moritz Wilhelmy).
|
||||
- Incorrect ordering of match results (Davide Del Zompo).
|
||||
- Input text matching (Quentin Rameau).
|
||||
- Paste from clipboard (ctrl+shift+y) (Joshua Lloret).
|
||||
- Replace deprecated usleep() with nanosleep() (Quentin Rameau).
|
||||
- dmenu_run: Split cache logic to dmenu_path again (Quentin Glidic).
|
||||
- multimon: always spawn client on first monitor if specified with
|
||||
-m 0 (Hiltjo).
|
||||
- reset ControlMask for C-j and C-m (Hiltjo).
|
||||
|
||||
Build improvements:
|
||||
- config.mk: add $FREETYPELIBS and $FREETYPEINC, simpler to override
|
||||
(ports and *BSDs).
|
||||
- config.mk: improve feature test check (k0ga, stateless).
|
||||
- config.mk: use -std=c99 by default.
|
||||
|
||||
Kind regards,
|
||||
Hiltjo Posthuma
|
26
desktop/dmenu/dmenu-4.6-libdir_cflags_fixups.diff
Normal file
26
desktop/dmenu/dmenu-4.6-libdir_cflags_fixups.diff
Normal file
|
@ -0,0 +1,26 @@
|
|||
diff -Naur dmenu-4.6-orig/config.mk dmenu-4.6/config.mk
|
||||
--- dmenu-4.6-orig/config.mk 2015-11-08 17:42:21.000000000 -0500
|
||||
+++ dmenu-4.6/config.mk 2015-11-29 17:13:56.521190400 -0500
|
||||
@@ -4,6 +4,7 @@
|
||||
# paths
|
||||
PREFIX = /usr/local
|
||||
MANPREFIX = ${PREFIX}/share/man
|
||||
+LIBDIR = /usr/local/lib
|
||||
|
||||
X11INC = /usr/X11R6/include
|
||||
X11LIB = /usr/X11R6/lib
|
||||
@@ -20,11 +21,12 @@
|
||||
|
||||
# includes and libs
|
||||
INCS = -I${X11INC} -I${FREETYPEINC}
|
||||
-LIBS = -L${X11LIB} -lX11 ${XINERAMALIBS} ${FREETYPELIBS}
|
||||
+LIBS = -L${LIBDIR} -L${X11LIB} -lX11 ${XINERAMALIBS} ${FREETYPELIBS}
|
||||
|
||||
# flags
|
||||
+OPTS ?= -Os
|
||||
CPPFLAGS = -D_BSD_SOURCE -D_XOPEN_SOURCE=700 -D_POSIX_C_SOURCE=200809L -DVERSION=\"${VERSION}\" ${XINERAMAFLAGS}
|
||||
-CFLAGS = -std=c99 -pedantic -Wall -Os ${INCS} ${CPPFLAGS}
|
||||
+CFLAGS = -std=c99 -pedantic -Wall ${OPTS} ${INCS} ${CPPFLAGS}
|
||||
LDFLAGS = -s ${LIBS}
|
||||
|
||||
# compiler and linker
|
|
@ -24,7 +24,7 @@
|
|||
# Modified by Phillip Warner for version >= 4.0
|
||||
|
||||
PRGNAM=dmenu
|
||||
VERSION=4.5
|
||||
VERSION=${VERSION:-4.6}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
|
@ -65,13 +65,13 @@ tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
|
|||
cd $PRGNAM-$VERSION
|
||||
chown -R root:root .
|
||||
find -L . \
|
||||
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
|
||||
-exec chmod 755 {} \; -o \
|
||||
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
|
||||
-exec chmod 644 {} \;
|
||||
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
|
||||
-o -perm 511 \) -exec chmod 755 {} \; -o \
|
||||
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
|
||||
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
|
||||
|
||||
# Fixup the CFLAGS and LIBDIR settings to prevent multilib conflicts
|
||||
patch -p1 < $CWD/dmenu-4.5-libdir_cflags_fixups.diff
|
||||
patch -p1 < $CWD/dmenu-4.6-libdir_cflags_fixups.diff
|
||||
|
||||
make install \
|
||||
OPTS="$SLKCFLAGS" \
|
||||
|
@ -82,7 +82,7 @@ make install \
|
|||
X11LIB=/usr/lib${LIBDIRSUFFIX}/X11 \
|
||||
DESTDIR=$PKG
|
||||
|
||||
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
|
||||
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
|
||||
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
|
||||
|
||||
find $PKG/usr/man -type f -exec gzip -9 {} \;
|
||||
|
@ -91,6 +91,8 @@ for i in $(find $PKG/usr/man -type l) ; do ln -s $(readlink $i).gz $i.gz ; rm $i
|
|||
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cp -a LICENSE README $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
|
||||
# Include important changes listed in the release notes in the mailing list group
|
||||
cat $CWD/${PRGNAM}-${VERSION}-ReleaseNotes.txt > $PKG/usr/doc/$PRGNAM-$VERSION/ReleaseNotes
|
||||
|
||||
mkdir -p $PKG/install
|
||||
cat $CWD/slack-desc > $PKG/install/slack-desc
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
PRGNAM="dmenu"
|
||||
VERSION="4.5"
|
||||
VERSION="4.6"
|
||||
HOMEPAGE="http://tools.suckless.org/dmenu"
|
||||
DOWNLOAD="http://dl.suckless.org/tools/dmenu-4.5.tar.gz"
|
||||
MD5SUM="9c46169ed703732ec52ed946c27d84b4"
|
||||
DOWNLOAD="http://dl.suckless.org/tools/dmenu-4.6.tar.gz"
|
||||
MD5SUM="6fedf081133bc0725cb040b3b8ac3fac"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
REQUIRES=""
|
||||
|
|
Loading…
Reference in a new issue