mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-21 19:42:24 +01:00
network/luakit: Updated for version 2.3.6.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
parent
3cb0706bee
commit
3e7b494108
3 changed files with 25 additions and 10 deletions
15
network/luakit/gtk.patch
Normal file
15
network/luakit/gtk.patch
Normal file
|
@ -0,0 +1,15 @@
|
||||||
|
diff -rupN a/clib/unique.c b/clib/unique.c
|
||||||
|
--- a/clib/unique.c 2024-01-30 20:31:08.000000000 +0100
|
||||||
|
+++ b/clib/unique.c 2024-01-31 08:22:48.919908308 +0100
|
||||||
|
@@ -78,11 +78,7 @@ luaH_unique_new(lua_State *L)
|
||||||
|
|
||||||
|
GError *error = NULL;
|
||||||
|
if (!globalconf.application) {
|
||||||
|
-#if GTK_CHECK_VERSION(2,74,0)
|
||||||
|
- globalconf.application = gtk_application_new(name, G_APPLICATION_DEFAULT_FLAGS);
|
||||||
|
-#else
|
||||||
|
globalconf.application = gtk_application_new(name, G_APPLICATION_FLAGS_NONE);
|
||||||
|
-#endif
|
||||||
|
}
|
||||||
|
|
||||||
|
g_application_register(G_APPLICATION(globalconf.application), NULL, &error);
|
|
@ -3,7 +3,7 @@
|
||||||
# Slackware build script for luakit
|
# Slackware build script for luakit
|
||||||
|
|
||||||
# Copyright 2013, Andrew Tkalia <anddt@yandex.ru>, Ukraine, Kyiv
|
# Copyright 2013, Andrew Tkalia <anddt@yandex.ru>, Ukraine, Kyiv
|
||||||
# Updates 2018-2023 by Marek Šrejma <marek@modweb.de>, Germany
|
# Updates 2018-2024 by Marek Šrejma <marek@modweb.de>, Germany
|
||||||
# All rights reserved.
|
# All rights reserved.
|
||||||
#
|
#
|
||||||
# Redistribution and use of this script, with or without modification, is
|
# Redistribution and use of this script, with or without modification, is
|
||||||
|
@ -26,8 +26,8 @@
|
||||||
cd $(dirname $0) ; CWD=$(pwd)
|
cd $(dirname $0) ; CWD=$(pwd)
|
||||||
|
|
||||||
PRGNAM=luakit
|
PRGNAM=luakit
|
||||||
VERSION=${VERSION:-2.3.3}
|
VERSION=${VERSION:-2.3.6}
|
||||||
BUILD=${BUILD:-3}
|
BUILD=${BUILD:-1}
|
||||||
TAG=${TAG:-_SBo}
|
TAG=${TAG:-_SBo}
|
||||||
PKGTYPE=${PKGTYPE:-tgz}
|
PKGTYPE=${PKGTYPE:-tgz}
|
||||||
LUAJIT=${LUAJIT:-0} # 0 or 1
|
LUAJIT=${LUAJIT:-0} # 0 or 1
|
||||||
|
@ -78,6 +78,7 @@ find -L . \
|
||||||
|
|
||||||
sed -e 's#(PREFIX)/lib/luakit#(LIBDIR)#g' -i Makefile
|
sed -e 's#(PREFIX)/lib/luakit#(LIBDIR)#g' -i Makefile
|
||||||
sed -e "/^Exec=/ s/lua/env Malloc=1 lua/" -i extras/luakit.desktop
|
sed -e "/^Exec=/ s/lua/env Malloc=1 lua/" -i extras/luakit.desktop
|
||||||
|
patch -p1 < $CWD/gtk.patch
|
||||||
|
|
||||||
_CFLAGS=`grep CFLAGS config.mk | sed -e "s/CFLAGS\s*+=//g" | tr "\n" " "`
|
_CFLAGS=`grep CFLAGS config.mk | sed -e "s/CFLAGS\s*+=//g" | tr "\n" " "`
|
||||||
make install \
|
make install \
|
||||||
|
@ -101,9 +102,8 @@ find $PKG/usr/man -type f -exec gzip -9 {} \;
|
||||||
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
|
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
|
||||||
|
|
||||||
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
|
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
|
||||||
cp -a AUTHORS CHANGELOG.md \
|
cp -a AUTHORS CHANGELOG.md CONTRIBUTING.md COPYING.GPLv3 README.md MIGRATE.md \
|
||||||
CONTRIBUTING.md COPYING.GPLv3 \
|
$PKG/usr/doc/$PRGNAM-$VERSION
|
||||||
README.md $PKG/usr/doc/$PRGNAM-$VERSION
|
|
||||||
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
|
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
|
||||||
|
|
||||||
mkdir -p $PKG/install
|
mkdir -p $PKG/install
|
||||||
|
|
|
@ -1,10 +1,10 @@
|
||||||
PRGNAM="luakit"
|
PRGNAM="luakit"
|
||||||
VERSION="2.3.3"
|
VERSION="2.3.6"
|
||||||
HOMEPAGE="https://github.com/luakit/luakit"
|
HOMEPAGE="https://github.com/luakit/luakit"
|
||||||
DOWNLOAD="https://github.com/luakit/luakit/archive/2.3.3/luakit-2.3.3.tar.gz"
|
DOWNLOAD="https://github.com/luakit/luakit/releases/download/2.3.6/luakit-2.3.6.tar.gz"
|
||||||
MD5SUM="378fdc9b857ac9e813fed1cc3218f840"
|
MD5SUM="f9e623c23ce560fdfd14d9ccb9ef71e6"
|
||||||
DOWNLOAD_x86_64=""
|
DOWNLOAD_x86_64=""
|
||||||
MD5SUM_x86_64=""
|
MD5SUM_x86_64=""
|
||||||
REQUIRES="webkit2gtk lua-filesystem"
|
REQUIRES="webkit2gtk4.1 lua-filesystem"
|
||||||
MAINTAINER="Marek Šrejma"
|
MAINTAINER="Marek Šrejma"
|
||||||
EMAIL="marek@modweb.de"
|
EMAIL="marek@modweb.de"
|
||||||
|
|
Loading…
Reference in a new issue