mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-14 21:56:41 +01:00
system/fdupes: Update to version 1.6.1
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
parent
272d6117d5
commit
3c6647cb77
5 changed files with 42 additions and 44 deletions
|
@ -1,29 +0,0 @@
|
|||
diff -Naur fdupes-1.51.orig/Makefile fdupes-1.51/Makefile
|
||||
--- fdupes-1.51.orig/Makefile 2013-04-20 12:51:58.000000000 -0500
|
||||
+++ fdupes-1.51/Makefile 2013-07-16 09:22:30.169197997 -0500
|
||||
@@ -46,6 +46,8 @@
|
||||
#
|
||||
PROGRAM_NAME=fdupes
|
||||
|
||||
+DESTDIR =
|
||||
+
|
||||
#
|
||||
# BIN_DIR indicates directory where program is to be installed.
|
||||
# Suggested value is "$(PREFIX)/bin"
|
||||
@@ -103,12 +105,12 @@
|
||||
$(CC) $(CFLAGS) -o fdupes $(OBJECT_FILES)
|
||||
|
||||
installdirs:
|
||||
- test -d $(BIN_DIR) || $(MKDIR) $(BIN_DIR)
|
||||
- test -d $(MAN_DIR) || $(MKDIR) $(MAN_DIR)
|
||||
+ test -d $(DESTDIR)$(BIN_DIR) || $(MKDIR) $(DESTDIR)$(BIN_DIR)
|
||||
+ test -d $(DESTDIR)$(MAN_DIR) || $(MKDIR) $(DESTDIR)$(MAN_DIR)
|
||||
|
||||
install: fdupes installdirs
|
||||
- $(INSTALL_PROGRAM) fdupes $(BIN_DIR)/$(PROGRAM_NAME)
|
||||
- $(INSTALL_DATA) fdupes.1 $(MAN_DIR)/$(PROGRAM_NAME).$(MAN_EXT)
|
||||
+ $(INSTALL_PROGRAM) fdupes $(DESTDIR)$(BIN_DIR)/$(PROGRAM_NAME)
|
||||
+ $(INSTALL_DATA) fdupes.1 $(DESTDIR)$(MAN_DIR)/$(PROGRAM_NAME).$(MAN_EXT)
|
||||
|
||||
clean:
|
||||
$(RM) $(OBJECT_FILES)
|
24
system/fdupes/fdupes-makefile.patch
Normal file
24
system/fdupes/fdupes-makefile.patch
Normal file
|
@ -0,0 +1,24 @@
|
|||
Index: Makefile
|
||||
===================================================================
|
||||
--- Makefile.orig 2016-08-21 06:54:46.000000000 +0200
|
||||
+++ Makefile 2016-11-04 13:46:21.037423459 +0100
|
||||
@@ -11,7 +11,7 @@
|
||||
# determination of the actual installation directories.
|
||||
# Suggested values are "/usr/local", "/usr", "/pkgs/fdupes-$(VERSION)"
|
||||
#
|
||||
-PREFIX = /usr/local
|
||||
+PREFIX = /usr
|
||||
|
||||
#
|
||||
# When compiling for 32-bit systems, FILEOFFSET_64BIT must be enabled
|
||||
--- Makefile.orig 2019-01-31 06:02:58.000000000 +0200
|
||||
+++ Makefile 2019-01-31 06:04:24.000000000 +0200
|
||||
@@ -49,7 +49,7 @@
|
||||
# MAN_DIR indicates directory where the fdupes man page is to be
|
||||
# installed. Suggested value is "$(PREFIX)/man/man1"
|
||||
#
|
||||
-MAN_BASE_DIR = $(PREFIX)/share/man
|
||||
+MAN_BASE_DIR = $(PREFIX)/man
|
||||
MAN_DIR = $(MAN_BASE_DIR)/man1
|
||||
MAN_EXT = 1
|
||||
|
|
@ -4,7 +4,7 @@
|
|||
|
||||
# Copyright 2008-2011 Pierre Cazenave <pwcazenave {at} gmail [dot] com>
|
||||
# Copyright 2013-2014 LukenShiro, Italy
|
||||
|
||||
# Copyright 2019 yukoff, Chernihiv, Ukraine
|
||||
# All rights reserved.
|
||||
#
|
||||
# Redistribution and use of this script, with or without modification, is
|
||||
|
@ -13,7 +13,7 @@
|
|||
# 1. Redistributions of this script must retain the above copyright
|
||||
# notice, this list of conditions and the following disclaimer.
|
||||
#
|
||||
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
|
||||
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
|
||||
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
|
||||
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
|
||||
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
|
||||
|
@ -27,15 +27,16 @@
|
|||
# 17/12/2008 - Original script.
|
||||
# 28/05/2009 - Updated for Slackware64 and general tidy up.
|
||||
# 19/06/2011 - Updated to version 1.50-PR2
|
||||
# 30/01/2019 - Updated to version 1.6.1, i486 -> i586
|
||||
|
||||
PRGNAM=fdupes
|
||||
VERSION=${VERSION:-1.51}
|
||||
BUILD=${BUILD:-2}
|
||||
VERSION=${VERSION:-1.6.1}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
if [ -z "$ARCH" ]; then
|
||||
case "$( uname -m )" in
|
||||
i?86) ARCH=i486 ;;
|
||||
i?86) ARCH=i586 ;;
|
||||
arm*) ARCH=arm ;;
|
||||
*) ARCH=$( uname -m ) ;;
|
||||
esac
|
||||
|
@ -46,8 +47,8 @@ TMP=${TMP:-/tmp/SBo}
|
|||
PKG=$TMP/package-$PRGNAM
|
||||
OUTPUT=${OUTPUT:-/tmp}
|
||||
|
||||
if [ "$ARCH" = "i486" ]; then
|
||||
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
|
||||
if [ "$ARCH" = "i586" ]; then
|
||||
SLKCFLAGS="-O2 -march=i586 -mtune=i686"
|
||||
LIBDIRSUFFIX=""
|
||||
elif [ "$ARCH" = "i686" ]; then
|
||||
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
|
||||
|
@ -68,8 +69,10 @@ rm -rf $PKG
|
|||
mkdir -p $TMP $PKG $OUTPUT
|
||||
cd $TMP
|
||||
rm -rf $PRGNAM-$PRGNAM-$VERSION
|
||||
tar -xvf $CWD/$PRGNAM-$VERSION.tar.gz || tar -xvf $CWD/$PRGNAM-$PRGNAM-$VERSION.tar.gz
|
||||
cd $PRGNAM-$PRGNAM-$VERSION
|
||||
tar -xvf $CWD/$PRGNAM-$VERSION.tar.?z* \
|
||||
|| tar -xvf $CWD/v$VERSION.tar.?z* \
|
||||
|| tar -xvf $CWD/$PRGNAM-$PRGNAM-$VERSION.tar.?z*
|
||||
cd $PRGNAM-$VERSION
|
||||
chown -R root:root .
|
||||
find -L . \
|
||||
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
|
||||
|
@ -77,8 +80,8 @@ find -L . \
|
|||
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
|
||||
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
|
||||
|
||||
# apply a patch by hobbes1069<at>gmail<dot>com for DESTDIR (issue #29)
|
||||
patch -p1 < $CWD/fdupes-1.51-destdir.patch
|
||||
# patch Makefile for PREFIX and MAN_BASE_DIR
|
||||
patch -p0 < $CWD/fdupes-makefile.patch
|
||||
|
||||
make install DESTDIR=$PKG PREFIX=/usr COMPILER_OPTIONS="$SLKCFLAGS"
|
||||
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
PRGNAM="fdupes"
|
||||
VERSION="1.51"
|
||||
VERSION="1.6.1"
|
||||
HOMEPAGE="https://github.com/adrianlopezroche/fdupes"
|
||||
DOWNLOAD="https://github.com/adrianlopezroche/fdupes/archive/fdupes-1.51.tar.gz"
|
||||
MD5SUM="cc90047dea9f1e0a849c3c1a6e8b2d68"
|
||||
DOWNLOAD="https://github.com/adrianlopezroche/fdupes/archive/v1.6.1/fdupes-1.6.1.tar.gz"
|
||||
MD5SUM="4fc41681fb506e518a40d610fec50aea"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
REQUIRES=""
|
||||
|
|
|
@ -11,7 +11,7 @@ fdupes:
|
|||
fdupes: FDUPES is a program for identifying or deleting duplicate files
|
||||
fdupes: residing within specified directories.
|
||||
fdupes:
|
||||
fdupes: Homepage: http://code.google.com/p/fdupes/
|
||||
fdupes: Homepage: https://github.com/adrianlopezroche/fdupes
|
||||
fdupes:
|
||||
fdupes:
|
||||
fdupes:
|
||||
|
|
Loading…
Reference in a new issue