mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-24 10:02:29 +01:00
misc/mosquitto: Updated for version 1.4.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
parent
8532c7bb72
commit
3bc9b2a3a3
6 changed files with 33 additions and 17 deletions
13
misc/mosquitto/010_no-cmp0042.diff
Normal file
13
misc/mosquitto/010_no-cmp0042.diff
Normal file
|
@ -0,0 +1,13 @@
|
|||
--- CMakeLists.txt.orig 2015-02-18 11:44:09.000000000 +1000
|
||||
+++ CMakeLists.txt 2015-02-23 15:30:27.797877114 +1000
|
||||
@@ -9,7 +9,9 @@
|
||||
project(mosquitto)
|
||||
|
||||
cmake_minimum_required(VERSION 2.8)
|
||||
-cmake_policy(SET CMP0042 NEW)
|
||||
+if (POLICY CMP0042)
|
||||
+ cmake_policy(SET CMP0042 NEW) # CMake 3
|
||||
+endif (POLICY CMP0042)
|
||||
|
||||
set (VERSION 1.4)
|
||||
|
11
misc/mosquitto/020_link-option.diff
Normal file
11
misc/mosquitto/020_link-option.diff
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- src/CMakeLists.txt.orig 2015-02-18 11:44:09.000000000 +1000
|
||||
+++ src/CMakeLists.txt 2015-02-21 14:24:10.423277309 +1000
|
||||
@@ -113,7 +113,7 @@
|
||||
if (APPLE)
|
||||
set_target_properties(mosquitto PROPERTIES LINK_FLAGS "-Wl,-exported_symbols_list -Wl,${mosquitto_SOURCE_DIR}/src/linker-macosx.syms")
|
||||
else (APPLE)
|
||||
- set_target_properties(mosquitto PROPERTIES LINK_FLAGS "-Wl,-exported_symbols_list -Wl,${mosquitto_SOURCE_DIR}/src/linker.syms")
|
||||
+ set_target_properties(mosquitto PROPERTIES LINK_FLAGS "-Wl,-dynamic-list -Wl,${mosquitto_SOURCE_DIR}/src/linker.syms")
|
||||
endif (APPLE)
|
||||
endif (UNIX)
|
||||
|
|
@ -3,15 +3,7 @@ mqtt protocol. IBM have a closed source version of this server, known as
|
|||
Really Small Message Broker (rsmb). The plan is to make this a more or less
|
||||
drop in replacement.
|
||||
|
||||
See the following links for more information on mqtt:
|
||||
|
||||
http://mqtt.org/
|
||||
http://publib.boulder.ibm.com/infocenter/wmbhelp/v6r0m0/topic/com.ibm.etools.mft.doc/ac10840_.htm
|
||||
|
||||
Mosquitto project information is available at the following locations:
|
||||
|
||||
http://mosquitto.org/ (main homepage)
|
||||
http://launchpad.net/mosquitto (bug tracking, translations)
|
||||
http://bitbucket.org/oojah/mosquitto (hg source code repository)
|
||||
From version 1.4, Python bindings are no longer included, but are available
|
||||
separately from the Eclipse paho-mqtt project.
|
||||
|
||||
Mosquitto was written by Roger Light <roger@atchoo.org>
|
||||
|
|
|
@ -12,4 +12,3 @@ config() {
|
|||
}
|
||||
|
||||
config etc/mosquitto/mosquitto.conf.new
|
||||
|
||||
|
|
|
@ -23,7 +23,7 @@
|
|||
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
||||
|
||||
PRGNAM=mosquitto
|
||||
VERSION=${VERSION:-1.3.2}
|
||||
VERSION=${VERSION:-1.4}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
|
@ -62,6 +62,8 @@ cd $TMP
|
|||
rm -rf $PRGNAM-$VERSION
|
||||
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
|
||||
cd $PRGNAM-$VERSION
|
||||
patch -p0 <$CWD/010_no-cmp0042.diff
|
||||
patch -p0 <$CWD/020_link-option.diff
|
||||
chown -R root:root .
|
||||
find -L . \
|
||||
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
|
||||
|
@ -76,7 +78,6 @@ cd build
|
|||
-DLIB_SUFFIX=${LIBDIRSUFFIX}
|
||||
make
|
||||
make install DESTDIR=$PKG
|
||||
make -C ../lib/python install DESTDIR=$PKG prefix=/usr
|
||||
cd ..
|
||||
|
||||
# Preserve existing mosquitto.conf during package installation
|
||||
|
@ -91,7 +92,7 @@ for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; r
|
|||
|
||||
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cp -a \
|
||||
LICENSE.txt LICENSE-3rd-party.txt compiling.txt mosquitto.conf *.example readme.txt \
|
||||
LICENSE.txt CONTRIBUTING.md compiling.txt mosquitto.conf *.example examples readme.txt \
|
||||
$PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
|
||||
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
PRGNAM="mosquitto"
|
||||
VERSION="1.3.2"
|
||||
VERSION="1.4"
|
||||
HOMEPAGE="http://mosquitto.org/"
|
||||
DOWNLOAD="http://mosquitto.org/files/source/mosquitto-1.3.2.tar.gz"
|
||||
MD5SUM="5d2fe7c8bf2518eb9829547751c04bbf"
|
||||
DOWNLOAD="http://mosquitto.org/files/source/mosquitto-1.4.tar.gz"
|
||||
MD5SUM="cd879f5964311501ba8e2275add71484"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
REQUIRES="c-ares"
|
||||
|
|
Loading…
Reference in a new issue