mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-16 19:50:19 +01:00
system/exa: Updated for new zoneinfo crate.
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
This commit is contained in:
parent
1ab50bb44a
commit
3b75d69b7a
3 changed files with 277 additions and 45 deletions
|
@ -67,6 +67,9 @@ rm -rf $PRGNAM-$VERSION
|
|||
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
|
||||
cd $PRGNAM-$VERSION
|
||||
|
||||
# https://github.com/ogham/exa/issues/301
|
||||
patch -p1 < $CWD/upgrade_datetime_crate.diff
|
||||
|
||||
# build offline
|
||||
# configuration tells cargo to use the configured directory
|
||||
# for dependencies intead of downloading from crates.io
|
||||
|
@ -87,13 +90,10 @@ mkdir vendor
|
|||
|
||||
for dependency in aho-corasick=0.5.3 \
|
||||
ansi_term=0.8.0 \
|
||||
bitflags=0.7.0 \
|
||||
bitflags=0.9.1 \
|
||||
byteorder=0.4.2 \
|
||||
cmake=0.1.25 \
|
||||
conv=0.3.3 \
|
||||
custom_derive=0.1.7 \
|
||||
datetime=0.4.5 \
|
||||
datetime=0.4.7 \
|
||||
env_logger=0.3.5 \
|
||||
gcc=0.3.53 \
|
||||
getopts=0.2.14 \
|
||||
|
@ -108,29 +108,19 @@ mkdir vendor
|
|||
libz-sys=1.0.16 \
|
||||
locale=0.2.2 \
|
||||
log=0.3.8 \
|
||||
magenta=0.1.1 \
|
||||
magenta-sys=0.1.1 \
|
||||
matches=0.1.6 \
|
||||
memchr=0.1.11 \
|
||||
natord=1.0.9 \
|
||||
nom=1.2.4 \
|
||||
num=0.1.40 \
|
||||
num-bigint=0.1.40 \
|
||||
num-complex=0.1.40 \
|
||||
num-integer=0.1.35 \
|
||||
num-iter=0.1.34 \
|
||||
num-rational=0.1.39 \
|
||||
num-traits=0.1.40 \
|
||||
num_cpus=1.6.2 \
|
||||
number_prefix=0.2.7 \
|
||||
pad=0.1.4 \
|
||||
percent-encoding=1.0.0 \
|
||||
pkg-config=0.3.9 \
|
||||
rand=0.3.16 \
|
||||
redox_syscall=0.1.31 \
|
||||
regex=0.1.80 \
|
||||
regex-syntax=0.3.9 \
|
||||
rustc-serialize=0.3.24 \
|
||||
scoped_threadpool=0.1.7 \
|
||||
term_grid=0.1.6 \
|
||||
term_size=0.3.0 \
|
||||
|
@ -145,7 +135,7 @@ mkdir vendor
|
|||
vcpkg=0.2.2 \
|
||||
winapi=0.2.8 \
|
||||
winapi-build=0.1.1 \
|
||||
zoneinfo_compiled=0.4.5; do
|
||||
zoneinfo_compiled=0.4.7; do
|
||||
dep="$(echo "$dependency" | cut -d= -f1)"
|
||||
ver="$(echo "$dependency" | cut -d= -f2)"
|
||||
|
||||
|
|
|
@ -4,13 +4,10 @@ HOMEPAGE="https://github.com/ogham/exa"
|
|||
DOWNLOAD="https://github.com/ogham/exa/archive/v0.8.0/exa-0.8.0.tar.gz \
|
||||
https://crates-io.s3-us-west-1.amazonaws.com/crates/aho-corasick/aho-corasick-0.5.3.crate \
|
||||
https://crates-io.s3-us-west-1.amazonaws.com/crates/ansi_term/ansi_term-0.8.0.crate \
|
||||
https://crates-io.s3-us-west-1.amazonaws.com/crates/bitflags/bitflags-0.7.0.crate \
|
||||
https://crates-io.s3-us-west-1.amazonaws.com/crates/bitflags/bitflags-0.9.1.crate \
|
||||
https://crates-io.s3-us-west-1.amazonaws.com/crates/byteorder/byteorder-0.4.2.crate \
|
||||
https://crates-io.s3-us-west-1.amazonaws.com/crates/cmake/cmake-0.1.25.crate \
|
||||
https://crates-io.s3-us-west-1.amazonaws.com/crates/conv/conv-0.3.3.crate \
|
||||
https://crates-io.s3-us-west-1.amazonaws.com/crates/custom_derive/custom_derive-0.1.7.crate \
|
||||
https://crates-io.s3-us-west-1.amazonaws.com/crates/datetime/datetime-0.4.5.crate \
|
||||
https://crates-io.s3-us-west-1.amazonaws.com/crates/datetime/datetime-0.4.7.crate \
|
||||
https://crates-io.s3-us-west-1.amazonaws.com/crates/env_logger/env_logger-0.3.5.crate \
|
||||
https://crates-io.s3-us-west-1.amazonaws.com/crates/gcc/gcc-0.3.53.crate \
|
||||
https://crates-io.s3-us-west-1.amazonaws.com/crates/getopts/getopts-0.2.14.crate \
|
||||
|
@ -25,29 +22,19 @@ DOWNLOAD="https://github.com/ogham/exa/archive/v0.8.0/exa-0.8.0.tar.gz \
|
|||
https://crates-io.s3-us-west-1.amazonaws.com/crates/libz-sys/libz-sys-1.0.16.crate \
|
||||
https://crates-io.s3-us-west-1.amazonaws.com/crates/locale/locale-0.2.2.crate \
|
||||
https://crates-io.s3-us-west-1.amazonaws.com/crates/log/log-0.3.8.crate \
|
||||
https://crates-io.s3-us-west-1.amazonaws.com/crates/magenta/magenta-0.1.1.crate \
|
||||
https://crates-io.s3-us-west-1.amazonaws.com/crates/magenta-sys/magenta-sys-0.1.1.crate \
|
||||
https://crates-io.s3-us-west-1.amazonaws.com/crates/matches/matches-0.1.6.crate \
|
||||
https://crates-io.s3-us-west-1.amazonaws.com/crates/memchr/memchr-0.1.11.crate \
|
||||
https://crates-io.s3-us-west-1.amazonaws.com/crates/natord/natord-1.0.9.crate \
|
||||
https://crates-io.s3-us-west-1.amazonaws.com/crates/nom/nom-1.2.4.crate \
|
||||
https://crates-io.s3-us-west-1.amazonaws.com/crates/num/num-0.1.40.crate \
|
||||
https://crates-io.s3-us-west-1.amazonaws.com/crates/num-bigint/num-bigint-0.1.40.crate \
|
||||
https://crates-io.s3-us-west-1.amazonaws.com/crates/num-complex/num-complex-0.1.40.crate \
|
||||
https://crates-io.s3-us-west-1.amazonaws.com/crates/num-integer/num-integer-0.1.35.crate \
|
||||
https://crates-io.s3-us-west-1.amazonaws.com/crates/num-iter/num-iter-0.1.34.crate \
|
||||
https://crates-io.s3-us-west-1.amazonaws.com/crates/num-rational/num-rational-0.1.39.crate \
|
||||
https://crates-io.s3-us-west-1.amazonaws.com/crates/num-traits/num-traits-0.1.40.crate \
|
||||
https://crates-io.s3-us-west-1.amazonaws.com/crates/num_cpus/num_cpus-1.6.2.crate \
|
||||
https://crates-io.s3-us-west-1.amazonaws.com/crates/number_prefix/number_prefix-0.2.7.crate \
|
||||
https://crates-io.s3-us-west-1.amazonaws.com/crates/pad/pad-0.1.4.crate \
|
||||
https://crates-io.s3-us-west-1.amazonaws.com/crates/percent-encoding/percent-encoding-1.0.0.crate \
|
||||
https://crates-io.s3-us-west-1.amazonaws.com/crates/pkg-config/pkg-config-0.3.9.crate \
|
||||
https://crates-io.s3-us-west-1.amazonaws.com/crates/rand/rand-0.3.16.crate \
|
||||
https://crates-io.s3-us-west-1.amazonaws.com/crates/redox_syscall/redox_syscall-0.1.31.crate \
|
||||
https://crates-io.s3-us-west-1.amazonaws.com/crates/regex/regex-0.1.80.crate \
|
||||
https://crates-io.s3-us-west-1.amazonaws.com/crates/regex-syntax/regex-syntax-0.3.9.crate \
|
||||
https://crates-io.s3-us-west-1.amazonaws.com/crates/rustc-serialize/rustc-serialize-0.3.24.crate \
|
||||
https://crates-io.s3-us-west-1.amazonaws.com/crates/scoped_threadpool/scoped_threadpool-0.1.7.crate \
|
||||
https://crates-io.s3-us-west-1.amazonaws.com/crates/term_grid/term_grid-0.1.6.crate \
|
||||
https://crates-io.s3-us-west-1.amazonaws.com/crates/term_size/term_size-0.3.0.crate \
|
||||
|
@ -62,17 +49,14 @@ DOWNLOAD="https://github.com/ogham/exa/archive/v0.8.0/exa-0.8.0.tar.gz \
|
|||
https://crates-io.s3-us-west-1.amazonaws.com/crates/vcpkg/vcpkg-0.2.2.crate \
|
||||
https://crates-io.s3-us-west-1.amazonaws.com/crates/winapi/winapi-0.2.8.crate \
|
||||
https://crates-io.s3-us-west-1.amazonaws.com/crates/winapi-build/winapi-build-0.1.1.crate \
|
||||
https://crates-io.s3-us-west-1.amazonaws.com/crates/zoneinfo_compiled/zoneinfo_compiled-0.4.5.crate"
|
||||
https://crates-io.s3-us-west-1.amazonaws.com/crates/zoneinfo_compiled/zoneinfo_compiled-0.4.7.crate"
|
||||
MD5SUM="9024cabd9346fc3b3694e3a36f01e60d \
|
||||
df727d9f2986c9874bec190bbc9f0021 \
|
||||
f715ae93f15bac515273f287af9d130b \
|
||||
1dd9b755c91f0f7bb401e393a9ed69f2 \
|
||||
8db34042da9ec719905b996a5b7182e1 \
|
||||
9601b4fb33dec3dfc2427447b7bfe800 \
|
||||
8f41a0f8569a596728890a1db27f5118 \
|
||||
ac23d9df03916ff7e761b79e1feeec5f \
|
||||
3d131226cd630fef6336573ce993201e \
|
||||
d8077d92c231bcd05d61b9947d132dd4 \
|
||||
244e19eb0ab4ad90aa523890f7104465 \
|
||||
27d9427d2f98d6024fd8d91ba50becef \
|
||||
cd77c8af3ff188c7f4a697c8e228b17c \
|
||||
6d59f4fa29cab7bcc7ea7e0c8f96e27d \
|
||||
|
@ -87,29 +71,19 @@ MD5SUM="9024cabd9346fc3b3694e3a36f01e60d \
|
|||
ccd80468b385ca0eed5c70ac9ff0eb27 \
|
||||
4b6711425b661ef923c9ff3ef9ba8c67 \
|
||||
3aeec0abc69e407a94677199cd6a0b4b \
|
||||
7e7b2ff445a36905d01b174e1ab41595 \
|
||||
bada89bf3a09a21b2872cc3d66a1204e \
|
||||
91f355db69eb1b80980ef8a7436fbc2b \
|
||||
6a8e1bfad0f908afae0d0ca9941bd411 \
|
||||
5a9b94ba54ea1f52f2a496ba982e3282 \
|
||||
3796b5abe0f8c5f3a9e9441c5757a52c \
|
||||
f4bc9513a674e68073726101c0ac52bd \
|
||||
e383abf2be21d0ccc4a41de702a4610b \
|
||||
ca711d6e45fdd909dff56addcfca01e9 \
|
||||
5df94752cef209d786a23fefb211628c \
|
||||
29af167804eb5f90c0243bd14610bea5 \
|
||||
0b884058a00fd999f53dfbaa1ed11c34 \
|
||||
0d824de5c73b72433dedb16ad52e3a9e \
|
||||
393ca202bd5c4304c3ea90fb5cc7617f \
|
||||
ee9160e4e5f6bc37082515274324f88e \
|
||||
c1f101feae32400220f6a667c3258365 \
|
||||
f6403cafe6a20349d62ceb224a644092 \
|
||||
5dc94c21d86b663e4a1a65b47134f6c5 \
|
||||
d7242280434f2bd498a585fe937e2284 \
|
||||
e08cdbd749dde894cf8ed5fe8cf54ab8 \
|
||||
c76d9e4def697bf23faf4d2b79aac458 \
|
||||
797f26b635bbc56fdf5ef1cc3883f259 \
|
||||
5e4ad69737043efed21e99c959727ef5 \
|
||||
472037f104fd6d766b68f0c8f68f309f \
|
||||
9d2431826b200515c6f9ee1aca04db5a \
|
||||
ef6c6bda7a4b8de56b53329783b7976c \
|
||||
|
@ -124,7 +98,7 @@ MD5SUM="9024cabd9346fc3b3694e3a36f01e60d \
|
|||
ce928aff50b1256ea43cb94ecc4cb017 \
|
||||
b44489eb4799c4fabac3fceb48de54f7 \
|
||||
c900e7dbce808ff8ced375077b17a163 \
|
||||
e464b634c3ffa0515507857fbe4506bd"
|
||||
872af6020ad0bc24d439a8d0a26d7782"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
REQUIRES="rust"
|
||||
|
|
268
system/exa/upgrade_datetime_crate.diff
Normal file
268
system/exa/upgrade_datetime_crate.diff
Normal file
|
@ -0,0 +1,268 @@
|
|||
diff -Naur exa-0.8.0.bak/Cargo.lock exa-0.8.0/Cargo.lock
|
||||
--- exa-0.8.0.bak/Cargo.lock 2017-10-14 22:24:06.182951913 +1300
|
||||
+++ exa-0.8.0/Cargo.lock 2017-10-14 22:24:15.347288626 +1300
|
||||
@@ -3,7 +3,7 @@
|
||||
version = "0.8.0"
|
||||
dependencies = [
|
||||
"ansi_term 0.8.0 (registry+https://github.com/rust-lang/crates.io-index)",
|
||||
- "datetime 0.4.5 (registry+https://github.com/rust-lang/crates.io-index)",
|
||||
+ "datetime 0.4.7 (registry+https://github.com/rust-lang/crates.io-index)",
|
||||
"env_logger 0.3.5 (registry+https://github.com/rust-lang/crates.io-index)",
|
||||
"getopts 0.2.14 (registry+https://github.com/rust-lang/crates.io-index)",
|
||||
"git2 0.6.8 (registry+https://github.com/rust-lang/crates.io-index)",
|
||||
@@ -20,7 +20,7 @@
|
||||
"term_size 0.3.0 (registry+https://github.com/rust-lang/crates.io-index)",
|
||||
"unicode-width 0.1.4 (registry+https://github.com/rust-lang/crates.io-index)",
|
||||
"users 0.5.3 (registry+https://github.com/rust-lang/crates.io-index)",
|
||||
- "zoneinfo_compiled 0.4.5 (registry+https://github.com/rust-lang/crates.io-index)",
|
||||
+ "zoneinfo_compiled 0.4.7 (registry+https://github.com/rust-lang/crates.io-index)",
|
||||
]
|
||||
|
||||
[[package]]
|
||||
@@ -38,11 +38,6 @@
|
||||
|
||||
[[package]]
|
||||
name = "bitflags"
|
||||
-version = "0.7.0"
|
||||
-source = "registry+https://github.com/rust-lang/crates.io-index"
|
||||
-
|
||||
-[[package]]
|
||||
-name = "bitflags"
|
||||
version = "0.9.1"
|
||||
source = "registry+https://github.com/rust-lang/crates.io-index"
|
||||
|
||||
@@ -60,28 +55,15 @@
|
||||
]
|
||||
|
||||
[[package]]
|
||||
-name = "conv"
|
||||
-version = "0.3.3"
|
||||
-source = "registry+https://github.com/rust-lang/crates.io-index"
|
||||
-dependencies = [
|
||||
- "custom_derive 0.1.7 (registry+https://github.com/rust-lang/crates.io-index)",
|
||||
-]
|
||||
-
|
||||
-[[package]]
|
||||
-name = "custom_derive"
|
||||
-version = "0.1.7"
|
||||
-source = "registry+https://github.com/rust-lang/crates.io-index"
|
||||
-
|
||||
-[[package]]
|
||||
name = "datetime"
|
||||
-version = "0.4.5"
|
||||
+version = "0.4.7"
|
||||
source = "registry+https://github.com/rust-lang/crates.io-index"
|
||||
dependencies = [
|
||||
"iso8601 0.1.1 (registry+https://github.com/rust-lang/crates.io-index)",
|
||||
"kernel32-sys 0.2.2 (registry+https://github.com/rust-lang/crates.io-index)",
|
||||
"libc 0.2.30 (registry+https://github.com/rust-lang/crates.io-index)",
|
||||
"locale 0.2.2 (registry+https://github.com/rust-lang/crates.io-index)",
|
||||
- "num 0.1.40 (registry+https://github.com/rust-lang/crates.io-index)",
|
||||
+ "num-traits 0.1.40 (registry+https://github.com/rust-lang/crates.io-index)",
|
||||
"pad 0.1.4 (registry+https://github.com/rust-lang/crates.io-index)",
|
||||
"redox_syscall 0.1.31 (registry+https://github.com/rust-lang/crates.io-index)",
|
||||
"winapi 0.2.8 (registry+https://github.com/rust-lang/crates.io-index)",
|
||||
@@ -196,23 +178,6 @@
|
||||
source = "registry+https://github.com/rust-lang/crates.io-index"
|
||||
|
||||
[[package]]
|
||||
-name = "magenta"
|
||||
-version = "0.1.1"
|
||||
-source = "registry+https://github.com/rust-lang/crates.io-index"
|
||||
-dependencies = [
|
||||
- "conv 0.3.3 (registry+https://github.com/rust-lang/crates.io-index)",
|
||||
- "magenta-sys 0.1.1 (registry+https://github.com/rust-lang/crates.io-index)",
|
||||
-]
|
||||
-
|
||||
-[[package]]
|
||||
-name = "magenta-sys"
|
||||
-version = "0.1.1"
|
||||
-source = "registry+https://github.com/rust-lang/crates.io-index"
|
||||
-dependencies = [
|
||||
- "bitflags 0.7.0 (registry+https://github.com/rust-lang/crates.io-index)",
|
||||
-]
|
||||
-
|
||||
-[[package]]
|
||||
name = "matches"
|
||||
version = "0.1.6"
|
||||
source = "registry+https://github.com/rust-lang/crates.io-index"
|
||||
@@ -236,67 +201,6 @@
|
||||
source = "registry+https://github.com/rust-lang/crates.io-index"
|
||||
|
||||
[[package]]
|
||||
-name = "num"
|
||||
-version = "0.1.40"
|
||||
-source = "registry+https://github.com/rust-lang/crates.io-index"
|
||||
-dependencies = [
|
||||
- "num-bigint 0.1.40 (registry+https://github.com/rust-lang/crates.io-index)",
|
||||
- "num-complex 0.1.40 (registry+https://github.com/rust-lang/crates.io-index)",
|
||||
- "num-integer 0.1.35 (registry+https://github.com/rust-lang/crates.io-index)",
|
||||
- "num-iter 0.1.34 (registry+https://github.com/rust-lang/crates.io-index)",
|
||||
- "num-rational 0.1.39 (registry+https://github.com/rust-lang/crates.io-index)",
|
||||
- "num-traits 0.1.40 (registry+https://github.com/rust-lang/crates.io-index)",
|
||||
-]
|
||||
-
|
||||
-[[package]]
|
||||
-name = "num-bigint"
|
||||
-version = "0.1.40"
|
||||
-source = "registry+https://github.com/rust-lang/crates.io-index"
|
||||
-dependencies = [
|
||||
- "num-integer 0.1.35 (registry+https://github.com/rust-lang/crates.io-index)",
|
||||
- "num-traits 0.1.40 (registry+https://github.com/rust-lang/crates.io-index)",
|
||||
- "rand 0.3.16 (registry+https://github.com/rust-lang/crates.io-index)",
|
||||
- "rustc-serialize 0.3.24 (registry+https://github.com/rust-lang/crates.io-index)",
|
||||
-]
|
||||
-
|
||||
-[[package]]
|
||||
-name = "num-complex"
|
||||
-version = "0.1.40"
|
||||
-source = "registry+https://github.com/rust-lang/crates.io-index"
|
||||
-dependencies = [
|
||||
- "num-traits 0.1.40 (registry+https://github.com/rust-lang/crates.io-index)",
|
||||
- "rustc-serialize 0.3.24 (registry+https://github.com/rust-lang/crates.io-index)",
|
||||
-]
|
||||
-
|
||||
-[[package]]
|
||||
-name = "num-integer"
|
||||
-version = "0.1.35"
|
||||
-source = "registry+https://github.com/rust-lang/crates.io-index"
|
||||
-dependencies = [
|
||||
- "num-traits 0.1.40 (registry+https://github.com/rust-lang/crates.io-index)",
|
||||
-]
|
||||
-
|
||||
-[[package]]
|
||||
-name = "num-iter"
|
||||
-version = "0.1.34"
|
||||
-source = "registry+https://github.com/rust-lang/crates.io-index"
|
||||
-dependencies = [
|
||||
- "num-integer 0.1.35 (registry+https://github.com/rust-lang/crates.io-index)",
|
||||
- "num-traits 0.1.40 (registry+https://github.com/rust-lang/crates.io-index)",
|
||||
-]
|
||||
-
|
||||
-[[package]]
|
||||
-name = "num-rational"
|
||||
-version = "0.1.39"
|
||||
-source = "registry+https://github.com/rust-lang/crates.io-index"
|
||||
-dependencies = [
|
||||
- "num-bigint 0.1.40 (registry+https://github.com/rust-lang/crates.io-index)",
|
||||
- "num-integer 0.1.35 (registry+https://github.com/rust-lang/crates.io-index)",
|
||||
- "num-traits 0.1.40 (registry+https://github.com/rust-lang/crates.io-index)",
|
||||
- "rustc-serialize 0.3.24 (registry+https://github.com/rust-lang/crates.io-index)",
|
||||
-]
|
||||
-
|
||||
-[[package]]
|
||||
name = "num-traits"
|
||||
version = "0.1.40"
|
||||
source = "registry+https://github.com/rust-lang/crates.io-index"
|
||||
@@ -336,15 +240,6 @@
|
||||
source = "registry+https://github.com/rust-lang/crates.io-index"
|
||||
|
||||
[[package]]
|
||||
-name = "rand"
|
||||
-version = "0.3.16"
|
||||
-source = "registry+https://github.com/rust-lang/crates.io-index"
|
||||
-dependencies = [
|
||||
- "libc 0.2.30 (registry+https://github.com/rust-lang/crates.io-index)",
|
||||
- "magenta 0.1.1 (registry+https://github.com/rust-lang/crates.io-index)",
|
||||
-]
|
||||
-
|
||||
-[[package]]
|
||||
name = "redox_syscall"
|
||||
version = "0.1.31"
|
||||
source = "registry+https://github.com/rust-lang/crates.io-index"
|
||||
@@ -367,11 +262,6 @@
|
||||
source = "registry+https://github.com/rust-lang/crates.io-index"
|
||||
|
||||
[[package]]
|
||||
-name = "rustc-serialize"
|
||||
-version = "0.3.24"
|
||||
-source = "registry+https://github.com/rust-lang/crates.io-index"
|
||||
-
|
||||
-[[package]]
|
||||
name = "scoped_threadpool"
|
||||
version = "0.1.7"
|
||||
source = "registry+https://github.com/rust-lang/crates.io-index"
|
||||
@@ -469,23 +359,20 @@
|
||||
|
||||
[[package]]
|
||||
name = "zoneinfo_compiled"
|
||||
-version = "0.4.5"
|
||||
+version = "0.4.7"
|
||||
source = "registry+https://github.com/rust-lang/crates.io-index"
|
||||
dependencies = [
|
||||
"byteorder 0.4.2 (registry+https://github.com/rust-lang/crates.io-index)",
|
||||
- "datetime 0.4.5 (registry+https://github.com/rust-lang/crates.io-index)",
|
||||
+ "datetime 0.4.7 (registry+https://github.com/rust-lang/crates.io-index)",
|
||||
]
|
||||
|
||||
[metadata]
|
||||
"checksum aho-corasick 0.5.3 (registry+https://github.com/rust-lang/crates.io-index)" = "ca972c2ea5f742bfce5687b9aef75506a764f61d37f8f649047846a9686ddb66"
|
||||
"checksum ansi_term 0.8.0 (registry+https://github.com/rust-lang/crates.io-index)" = "c877397e09fec7a240af5fa74ad0124054b8066149d6544cd1ace93f8de3be68"
|
||||
-"checksum bitflags 0.7.0 (registry+https://github.com/rust-lang/crates.io-index)" = "aad18937a628ec6abcd26d1489012cc0e18c21798210f491af69ded9b881106d"
|
||||
"checksum bitflags 0.9.1 (registry+https://github.com/rust-lang/crates.io-index)" = "4efd02e230a02e18f92fc2735f44597385ed02ad8f831e7c1c1156ee5e1ab3a5"
|
||||
"checksum byteorder 0.4.2 (registry+https://github.com/rust-lang/crates.io-index)" = "96c8b41881888cc08af32d47ac4edd52bc7fa27fef774be47a92443756451304"
|
||||
"checksum cmake 0.1.25 (registry+https://github.com/rust-lang/crates.io-index)" = "0c8a6541a55bcd72d3de4faee2d101a5a66df29790282c7f797082a7228a9b3d"
|
||||
-"checksum conv 0.3.3 (registry+https://github.com/rust-lang/crates.io-index)" = "78ff10625fd0ac447827aa30ea8b861fead473bb60aeb73af6c1c58caf0d1299"
|
||||
-"checksum custom_derive 0.1.7 (registry+https://github.com/rust-lang/crates.io-index)" = "ef8ae57c4978a2acd8b869ce6b9ca1dfe817bff704c220209fdef2c0b75a01b9"
|
||||
-"checksum datetime 0.4.5 (registry+https://github.com/rust-lang/crates.io-index)" = "865ed3829ccf00833e92d46f061dbbafccb4a551655a183024f97bddc0f90ccc"
|
||||
+"checksum datetime 0.4.7 (registry+https://github.com/rust-lang/crates.io-index)" = "5c44b6c112860e38412e0c4732172d723458d40db906ee4b9ce87544f022a7b9"
|
||||
"checksum env_logger 0.3.5 (registry+https://github.com/rust-lang/crates.io-index)" = "15abd780e45b3ea4f76b4e9a26ff4843258dd8a3eed2775a0e7368c2e7936c2f"
|
||||
"checksum gcc 0.3.53 (registry+https://github.com/rust-lang/crates.io-index)" = "e8310f7e9c890398b0e80e301c4f474e9918d2b27fca8f48486ca775fa9ffc5a"
|
||||
"checksum getopts 0.2.14 (registry+https://github.com/rust-lang/crates.io-index)" = "d9047cfbd08a437050b363d35ef160452c5fe8ea5187ae0a624708c91581d685"
|
||||
@@ -500,29 +387,19 @@
|
||||
"checksum libz-sys 1.0.16 (registry+https://github.com/rust-lang/crates.io-index)" = "3fdd64ef8ee652185674455c1d450b83cbc8ad895625d543b5324d923f82e4d8"
|
||||
"checksum locale 0.2.2 (registry+https://github.com/rust-lang/crates.io-index)" = "5fdbe492a9c0238da900a1165c42fc5067161ce292678a6fe80921f30fe307fd"
|
||||
"checksum log 0.3.8 (registry+https://github.com/rust-lang/crates.io-index)" = "880f77541efa6e5cc74e76910c9884d9859683118839d6a1dc3b11e63512565b"
|
||||
-"checksum magenta 0.1.1 (registry+https://github.com/rust-lang/crates.io-index)" = "4bf0336886480e671965f794bc9b6fce88503563013d1bfb7a502c81fe3ac527"
|
||||
-"checksum magenta-sys 0.1.1 (registry+https://github.com/rust-lang/crates.io-index)" = "40d014c7011ac470ae28e2f76a02bfea4a8480f73e701353b49ad7a8d75f4699"
|
||||
"checksum matches 0.1.6 (registry+https://github.com/rust-lang/crates.io-index)" = "100aabe6b8ff4e4a7e32c1c13523379802df0772b82466207ac25b013f193376"
|
||||
"checksum memchr 0.1.11 (registry+https://github.com/rust-lang/crates.io-index)" = "d8b629fb514376c675b98c1421e80b151d3817ac42d7c667717d282761418d20"
|
||||
"checksum natord 1.0.9 (registry+https://github.com/rust-lang/crates.io-index)" = "308d96db8debc727c3fd9744aac51751243420e46edf401010908da7f8d5e57c"
|
||||
"checksum nom 1.2.4 (registry+https://github.com/rust-lang/crates.io-index)" = "a5b8c256fd9471521bcb84c3cdba98921497f1a331cbc15b8030fc63b82050ce"
|
||||
-"checksum num 0.1.40 (registry+https://github.com/rust-lang/crates.io-index)" = "a311b77ebdc5dd4cf6449d81e4135d9f0e3b153839ac90e648a8ef538f923525"
|
||||
-"checksum num-bigint 0.1.40 (registry+https://github.com/rust-lang/crates.io-index)" = "8fd0f8dbb4c0960998958a796281d88c16fbe68d87b1baa6f31e2979e81fd0bd"
|
||||
-"checksum num-complex 0.1.40 (registry+https://github.com/rust-lang/crates.io-index)" = "503e668405c5492d67cf662a81e05be40efe2e6bcf10f7794a07bd9865e704e6"
|
||||
-"checksum num-integer 0.1.35 (registry+https://github.com/rust-lang/crates.io-index)" = "d1452e8b06e448a07f0e6ebb0bb1d92b8890eea63288c0b627331d53514d0fba"
|
||||
-"checksum num-iter 0.1.34 (registry+https://github.com/rust-lang/crates.io-index)" = "7485fcc84f85b4ecd0ea527b14189281cf27d60e583ae65ebc9c088b13dffe01"
|
||||
-"checksum num-rational 0.1.39 (registry+https://github.com/rust-lang/crates.io-index)" = "288629c76fac4b33556f4b7ab57ba21ae202da65ba8b77466e6d598e31990790"
|
||||
"checksum num-traits 0.1.40 (registry+https://github.com/rust-lang/crates.io-index)" = "99843c856d68d8b4313b03a17e33c4bb42ae8f6610ea81b28abe076ac721b9b0"
|
||||
"checksum num_cpus 1.6.2 (registry+https://github.com/rust-lang/crates.io-index)" = "aec53c34f2d0247c5ca5d32cca1478762f301740468ee9ee6dcb7a0dd7a0c584"
|
||||
"checksum number_prefix 0.2.7 (registry+https://github.com/rust-lang/crates.io-index)" = "59a14be9c211cb9c602bad35ac99f41e9a84b44d71b8cbd3040e3bd02a214902"
|
||||
"checksum pad 0.1.4 (registry+https://github.com/rust-lang/crates.io-index)" = "d1bf3336e626b898e7263790d432a711d4277e22faea20dd9f70e0cab268fa58"
|
||||
"checksum percent-encoding 1.0.0 (registry+https://github.com/rust-lang/crates.io-index)" = "de154f638187706bde41d9b4738748933d64e6b37bdbffc0b47a97d16a6ae356"
|
||||
"checksum pkg-config 0.3.9 (registry+https://github.com/rust-lang/crates.io-index)" = "3a8b4c6b8165cd1a1cd4b9b120978131389f64bdaf456435caa41e630edba903"
|
||||
-"checksum rand 0.3.16 (registry+https://github.com/rust-lang/crates.io-index)" = "eb250fd207a4729c976794d03db689c9be1d634ab5a1c9da9492a13d8fecbcdf"
|
||||
"checksum redox_syscall 0.1.31 (registry+https://github.com/rust-lang/crates.io-index)" = "8dde11f18c108289bef24469638a04dce49da56084f2d50618b226e47eb04509"
|
||||
"checksum regex 0.1.80 (registry+https://github.com/rust-lang/crates.io-index)" = "4fd4ace6a8cf7860714a2c2280d6c1f7e6a413486c13298bbc86fd3da019402f"
|
||||
"checksum regex-syntax 0.3.9 (registry+https://github.com/rust-lang/crates.io-index)" = "f9ec002c35e86791825ed294b50008eea9ddfc8def4420124fbc6b08db834957"
|
||||
-"checksum rustc-serialize 0.3.24 (registry+https://github.com/rust-lang/crates.io-index)" = "dcf128d1287d2ea9d80910b5f1120d0b8eede3fbf1abe91c40d39ea7d51e6fda"
|
||||
"checksum scoped_threadpool 0.1.7 (registry+https://github.com/rust-lang/crates.io-index)" = "3ef399c8893e8cb7aa9696e895427fab3a6bf265977bb96e126f24ddd2cda85a"
|
||||
"checksum term_grid 0.1.6 (registry+https://github.com/rust-lang/crates.io-index)" = "b56a46b68f4aa347ba5512b1abc12dcb641ff0e9aa3cb49b007595a320e369c5"
|
||||
"checksum term_size 0.3.0 (registry+https://github.com/rust-lang/crates.io-index)" = "e2b6b55df3198cc93372e85dd2ed817f0e38ce8cc0f22eb32391bfad9c4bf209"
|
||||
@@ -537,4 +414,4 @@
|
||||
"checksum vcpkg 0.2.2 (registry+https://github.com/rust-lang/crates.io-index)" = "9e0a7d8bed3178a8fb112199d466eeca9ed09a14ba8ad67718179b4fd5487d0b"
|
||||
"checksum winapi 0.2.8 (registry+https://github.com/rust-lang/crates.io-index)" = "167dc9d6949a9b857f3451275e911c3f44255842c1f7a76f33c55103a909087a"
|
||||
"checksum winapi-build 0.1.1 (registry+https://github.com/rust-lang/crates.io-index)" = "2d315eee3b34aca4797b2da6b13ed88266e6d612562a0c46390af8299fc699bc"
|
||||
-"checksum zoneinfo_compiled 0.4.5 (registry+https://github.com/rust-lang/crates.io-index)" = "97d89e408f902f2359bfebbdb3fd4974dad6faf4ecf5daa625c0241d40eeeafa"
|
||||
+"checksum zoneinfo_compiled 0.4.7 (registry+https://github.com/rust-lang/crates.io-index)" = "6cce4d9bb3225a0cfe4496147373cde97909be617abcf1a10952429b48830560"
|
||||
diff -Naur exa-0.8.0.bak/Cargo.toml exa-0.8.0/Cargo.toml
|
||||
--- exa-0.8.0.bak/Cargo.toml 2017-10-14 22:24:06.182951913 +1300
|
||||
+++ exa-0.8.0/Cargo.toml 2017-10-14 22:24:15.643299501 +1300
|
||||
@@ -24,7 +24,7 @@
|
||||
|
||||
[dependencies]
|
||||
ansi_term = "0.8.0"
|
||||
-datetime = "0.4.5"
|
||||
+datetime = "0.4.7"
|
||||
env_logger = "0.3"
|
||||
getopts = "0.2.14"
|
||||
glob = "0.2"
|
||||
@@ -40,7 +40,7 @@
|
||||
term_size = "0.3.0"
|
||||
unicode-width = "0.1.4"
|
||||
users = "0.5.2"
|
||||
-zoneinfo_compiled = "0.4.5"
|
||||
+zoneinfo_compiled = "0.4.7"
|
||||
|
||||
[features]
|
||||
default = [ "git" ]
|
Loading…
Reference in a new issue