system/xen: Updated for version 4.1.2 and misc build fixes

This commit includes some minor changes by rworkman to prevent
the Makefile(s) from downloading various stuff.

Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
This commit is contained in:
mario 2011-12-10 01:28:06 -06:00 committed by Niels Horn
parent 66716e78f6
commit 3aa48f231b
5 changed files with 41 additions and 8 deletions

View file

@ -34,10 +34,10 @@ and Xen VMM, and packages them up as a single file that looks like a bzImage
Linux kernel. For example this is how mbootpack works:
# cd /boot
# gzip -d -c /boot/xen-4.1.1.gz > /boot/xen-4.1.1
# gzip -d -c /boot/xen-4.1.2.gz > /boot/xen-4.1.2
# gzip -d -c /boot/initrd-xen.gz > /boot/initrd-xen
# mbootpack -o /boot/vmlinuz-2.6.34.7-xen -m /usr/src/linux-2.6.34.7-xen/vmlinux \
-m /boot/initrd-xen /boot/xen-4.1.1
-m /boot/initrd-xen /boot/xen-4.1.2
After a new kernel image is created, add something like the folowing to lilo.conf:

View file

@ -12,7 +12,7 @@ VERSION=${VERSION:-2.6.34.7}
SVERSION=${SVERSION:-2.6.34-6}
# Xen version
XVERSION=${XVERSION:-4.1.1}
XVERSION=${XVERSION:-4.1.2}
BOOTLOADER=${BOOTLOADER:-lilo}

View file

@ -0,0 +1,16 @@
diff -Nur xen-4.1.2.orig/tools/firmware/etherboot/Makefile xen-4.1.2/tools/firmware/etherboot/Makefile
--- xen-4.1.2.orig/tools/firmware/etherboot/Makefile 2011-10-20 12:05:41.000000000 -0500
+++ xen-4.1.2/tools/firmware/etherboot/Makefile 2011-12-10 00:16:40.217911034 -0600
@@ -35,12 +35,6 @@
mv -f $@.new $@
$T:
- if ! wget -O _$T $(IPXE_TARBALL_URL); then \
- $(GIT) clone $(IPXE_GIT_URL) $D.git; \
- (cd $D.git && $(GIT) archive --format=tar --prefix=$D/ \
- $(IPXE_GIT_TAG) | gzip >../_$T); \
- rm -rf $D.git; \
- fi
mv _$T $T
$D/src/arch/i386/Makefile: $T Config

View file

@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=xen
VERSION=${VERSION:-4.1.1}
VERSION=${VERSION:-4.1.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@ -72,6 +72,11 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
# Let's not download stuff during the build...
patch -p1 <$CWD/patches/use_already_present_ipxe.diff
cp -a $CWD/ipxe-git-v1.0.0.tar.gz tools/firmware/etherboot/_ipxe.tar.gz
cp -a $CWD/{lwip,zlib,newlib,pciutils,grub}-*.tar.?z* stubdom
make -C xen \
docdir=/usr/doc/$PRGNAM-$VERSION \
DOCDIR=/usr/doc/$PRGNAM-$VERSION \

View file

@ -1,10 +1,22 @@
PRGNAM="xen"
VERSION="4.1.1"
VERSION="4.1.2"
HOMEPAGE="http://www.xen.org/"
DOWNLOAD="http://bits.xensource.com/oss-xen/release/4.1.1/xen-4.1.1.tar.gz"
MD5SUM="fab4bf74d73444ff9b43bced2e4fc5a2"
DOWNLOAD="http://bits.xensource.com/oss-xen/release/4.1.2/xen-4.1.2.tar.gz \
http://xenbits.xensource.com/xen-extfiles/ipxe-git-v1.0.0.tar.gz \
http://xenbits.xensource.com/xen-extfiles/lwip-1.3.0.tar.gz \
http://xenbits.xensource.com/xen-extfiles/zlib-1.2.3.tar.gz \
http://xenbits.xensource.com/xen-extfiles/newlib-1.16.0.tar.gz \
http://xenbits.xensource.com/xen-extfiles/pciutils-2.2.9.tar.bz2 \
http://xenbits.xensource.com/xen-extfiles/grub-0.97.tar.gz"
MD5SUM="73561faf3c1b5e36ec5c089b5db848ad \
fb7df96781d337899066d82059346885 \
36cc57650cffda9a0269493be2a169bb \
debc62758716a169df9f62e6ab2bc634 \
bf8f1f9e3ca83d732c00a79a6ef29bc4 \
cec05e7785497c5e19da2f114b934ffd \
cd3f3eb54446be6003156158d51f4884"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
MAINTAINER="mario"
EMAIL="mario@slackverse.org"
APPROVED="Niels Horn"
APPROVED="Niels Horn,rworkman"