desktop/afterstep: Updated for version 20201113_f6da4b7.

Patch for binutils-2.36 (ar command syntax changed)

Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>

Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
Matteo Bernardini 2022-02-08 11:03:08 +01:00 committed by Willy Sudiarto Raharjo
parent 305a731772
commit 39bdb33a0e
No known key found for this signature in database
GPG key ID: 3F617144D7238786
3 changed files with 94 additions and 13 deletions

View file

@ -26,14 +26,14 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=afterstep
VERSION=${VERSION:-2.2.12}
VERSION=${VERSION:-20201113_f6da4b7}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i486 ;;
i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@ -51,11 +51,8 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
SRCNAM=AfterStep
TREENAM=afterstep-devel
if [ "$ARCH" = "i486" ]; then
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
if [ "$ARCH" = "i586" ]; then
SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "s390" ]; then
SLKCFLAGS="-O2"
@ -72,10 +69,10 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
rm -rf $TMP/$SRCNAM-$VERSION
cd $TMP
tar xvf $CWD/$SRCNAM-$VERSION.tar.bz2
cd $TREENAM-$VERSION
rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.?z*
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
@ -83,6 +80,9 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
# Thanks debian!
patch -p1 < $CWD/binutils-2.36.patch
CFLAGS="$SLKCFLAGS -fgnu89-inline" \
CXXFLAGS="$SLKCFLAGS" \
./configure \

View file

@ -1,8 +1,8 @@
PRGNAM="afterstep"
VERSION="2.2.12"
VERSION="20201113_f6da4b7"
HOMEPAGE="http://www.afterstep.org"
DOWNLOAD="http://ponce.cc/slackware/sources/repo/AfterStep-2.2.12.tar.bz2"
MD5SUM="a3ab1a878270998d420bb2a5ca15801b"
DOWNLOAD="https://ponce.cc/slackware/sources/repo/afterstep-20201113_f6da4b7.tar.xz"
MD5SUM="767af44b21c04319a0b7bcc5d7157924"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""

View file

@ -0,0 +1,81 @@
From: Robert Luberda <robert@debian.org>
Date: Mon, 25 Jan 2021 23:40:14 +0100
Subject: Fix compilation with new binutils
Replace 'ar clq' with 'ar cq', as binutils 2.36 started
using the 'l' option that was previously ignored most
probably for backward compatibility with ancient Unix
versions.
---
autoconf/Makefile.defines.in | 2 +-
libAfterBase/Makefile.in | 2 +-
libAfterImage/Makefile.in | 2 +-
libAfterImage/aftershow/Makefile.in | 2 +-
libAfterImage/apps/Makefile.in | 2 +-
5 files changed, 5 insertions(+), 5 deletions(-)
diff --git a/autoconf/Makefile.defines.in b/autoconf/Makefile.defines.in
index 63e7816..3e1b7ae 100644
--- a/autoconf/Makefile.defines.in
+++ b/autoconf/Makefile.defines.in
@@ -9,7 +9,7 @@ CCFLAGS = @CFLAGS@
EXTRA_DEFINES =
RANLIB = @RANLIB@
-AR = ar clq
+AR = ar cq
CP = @CP@
MV = @MV@
RM = @RM@
diff --git a/libAfterBase/Makefile.in b/libAfterBase/Makefile.in
index 7aa6253..810e65f 100644
--- a/libAfterBase/Makefile.in
+++ b/libAfterBase/Makefile.in
@@ -59,7 +59,7 @@ CCFLAGS = @CFLAGS@
EXTRA_DEFINES = @DEFINE_XLOCALE@
RANLIB = @RANLIB@
-AR = ar clq
+AR = ar cq
CP = @CP@
MV = @MV@
RM = @RM@
diff --git a/libAfterImage/Makefile.in b/libAfterImage/Makefile.in
index 2dc209f..b57900c 100644
--- a/libAfterImage/Makefile.in
+++ b/libAfterImage/Makefile.in
@@ -80,7 +80,7 @@ CCFLAGS = @CFLAGS@ @MMX_CFLAGS@
EXTRA_DEFINES = @DEFINE_XLOCALE@
RANLIB = @RANLIB@
-AR = ar clq
+AR = ar cq
CP = @CP@
MV = @MV@
RM = @RM@
diff --git a/libAfterImage/aftershow/Makefile.in b/libAfterImage/aftershow/Makefile.in
index b759292..7acdcd2 100644
--- a/libAfterImage/aftershow/Makefile.in
+++ b/libAfterImage/aftershow/Makefile.in
@@ -11,7 +11,7 @@ CCFLAGS = @CFLAGS@
EXTRA_DEFINES = @DEFINE_XLOCALE@
RANLIB = @RANLIB@
-AR = ar clq
+AR = ar cq
CP = @CP@
MV = @MV@
RM = @RM@
diff --git a/libAfterImage/apps/Makefile.in b/libAfterImage/apps/Makefile.in
index bcaab48..6b8cf60 100644
--- a/libAfterImage/apps/Makefile.in
+++ b/libAfterImage/apps/Makefile.in
@@ -8,7 +8,7 @@ CCFLAGS = @CFLAGS@
EXTRA_DEFINES = @DEFINE_XLOCALE@
RANLIB = @RANLIB@
-AR = ar clq
+AR = ar cq
CP = @CP@
MV = @MV@
RM = @RM@