mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-21 19:42:24 +01:00
audio/aseqview: Add missing patches.
Signed-off-by: Andrew Clemons <andrew.clemons@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
parent
1bd593ea87
commit
390339f780
3 changed files with 69 additions and 1 deletions
|
@ -62,7 +62,8 @@ find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
|
|||
|
||||
# From upstream's github: fix a segfault and a possible autotools issue.
|
||||
# Commits b31044a and e40717b.
|
||||
patch -p1 < $CWD/post-0.2.8-fixes.diff
|
||||
patch -p1 < $CWD/b31044a.patch
|
||||
patch -p1 < $CWD/e40717b.patch
|
||||
|
||||
# 20180916 bkw: need this due to these:
|
||||
# levelbar.o: In function `g_bit_nth_lsf':
|
||||
|
|
25
audio/aseqview/b31044a.patch
Normal file
25
audio/aseqview/b31044a.patch
Normal file
|
@ -0,0 +1,25 @@
|
|||
From b31044aeddd0b406ddbc262f20a4f069baf26783 Mon Sep 17 00:00:00 2001
|
||||
From: Takashi Iwai <tiwai@suse.de>
|
||||
Date: Fri, 25 Jun 2021 10:19:39 +0200
|
||||
Subject: [PATCH] Fix quote in configure.in
|
||||
|
||||
---
|
||||
configure.in | 4 ++--
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/configure.in b/configure.in
|
||||
index e125908..4b6907f 100644
|
||||
--- a/configure.in
|
||||
+++ b/configure.in
|
||||
@@ -12,9 +12,9 @@ AC_C_INLINE
|
||||
|
||||
AH_TEMPLATE([HAVE_LIBCAP], [Hey, we have libcap])
|
||||
AC_CHECK_HEADER(sys/capability.h,
|
||||
- AC_CHECK_LIB(cap, cap_get_proc,
|
||||
+ [AC_CHECK_LIB(cap, cap_get_proc,
|
||||
[AC_DEFINE(HAVE_LIBCAP)
|
||||
- LIBS="$LIBS -lcap"]))
|
||||
+ LIBS="$LIBS -lcap"])])
|
||||
|
||||
AM_PATH_ALSA(0.5.0)
|
||||
AC_CHECK_HEADERS(alsa/asoundlib.h)
|
42
audio/aseqview/e40717b.patch
Normal file
42
audio/aseqview/e40717b.patch
Normal file
|
@ -0,0 +1,42 @@
|
|||
From e40717bcf0d1851465a5d2531b92f6b1da2ce0c0 Mon Sep 17 00:00:00 2001
|
||||
From: Takashi Iwai <tiwai@suse.de>
|
||||
Date: Fri, 25 Jun 2021 10:20:18 +0200
|
||||
Subject: [PATCH] Fix crash at piano widget creation
|
||||
|
||||
It was a failure in piano widget that assumed that the widget type is
|
||||
an integer. It caused a segfault with the recent gtk.
|
||||
---
|
||||
piano.c | 4 ++--
|
||||
piano.h | 2 +-
|
||||
2 files changed, 3 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/piano.c b/piano.c
|
||||
index 7626373..931e3b9 100644
|
||||
--- a/piano.c
|
||||
+++ b/piano.c
|
||||
@@ -69,10 +69,10 @@ static GdkColor c60clr = { red : 18000, green : 0, blue : 54000 };
|
||||
|
||||
static GtkWidgetClass *parent_class = NULL;
|
||||
|
||||
-guint
|
||||
+GType
|
||||
piano_get_type (void)
|
||||
{
|
||||
- static guint piano_type = 0;
|
||||
+ static GType piano_type = 0;
|
||||
|
||||
if (!piano_type)
|
||||
{
|
||||
diff --git a/piano.h b/piano.h
|
||||
index 6dea3b6..c35d7da 100644
|
||||
--- a/piano.h
|
||||
+++ b/piano.h
|
||||
@@ -71,7 +71,7 @@ struct _PianoClass
|
||||
};
|
||||
|
||||
GtkWidget *piano_new (gboolean * selkeys);
|
||||
-guint piano_get_type (void);
|
||||
+GType piano_get_type (void);
|
||||
void piano_note_on (Piano * piano, guint8 keynum);
|
||||
void piano_note_off (Piano * piano, guint8 keynum);
|
||||
|
Loading…
Reference in a new issue