mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-04 20:29:09 +01:00
office/zathura-djvu: Updated for version 0.2.4.
This commit is contained in:
parent
24ded6832b
commit
37fecbe824
3 changed files with 6 additions and 53 deletions
|
@ -1,43 +0,0 @@
|
|||
diff -Naur zathura-djvu-0.2.0/djvu.c zathura-djvu-0.2.0.patched/djvu.c
|
||||
--- zathura-djvu-0.2.0/djvu.c 2012-06-09 17:37:36.000000000 -0400
|
||||
+++ zathura-djvu-0.2.0.patched/djvu.c 2012-07-24 00:00:01.000000000 -0400
|
||||
@@ -3,6 +3,7 @@
|
||||
#include <stdlib.h>
|
||||
#include <girara/datastructures.h>
|
||||
#include <string.h>
|
||||
+#include <stddef.h>
|
||||
#include <libdjvu/miniexp.h>
|
||||
#include <glib.h>
|
||||
|
||||
diff -Naur zathura-djvu-0.2.0/djvu.h zathura-djvu-0.2.0.patched/djvu.h
|
||||
--- zathura-djvu-0.2.0/djvu.h 2012-06-09 17:37:36.000000000 -0400
|
||||
+++ zathura-djvu-0.2.0.patched/djvu.h 2012-07-24 00:00:09.000000000 -0400
|
||||
@@ -5,6 +5,7 @@
|
||||
|
||||
#include <stdbool.h>
|
||||
#include <zathura/plugin-api.h>
|
||||
+#include <stddef.h>
|
||||
#include <libdjvu/ddjvuapi.h>
|
||||
#ifdef HAVE_CAIRO
|
||||
#include <cairo.h>
|
||||
diff -Naur zathura-djvu-0.2.0/page-text.c zathura-djvu-0.2.0.patched/page-text.c
|
||||
--- zathura-djvu-0.2.0/page-text.c 2012-06-09 17:37:36.000000000 -0400
|
||||
+++ zathura-djvu-0.2.0.patched/page-text.c 2012-07-24 00:00:18.000000000 -0400
|
||||
@@ -1,5 +1,6 @@
|
||||
/* See LICENSE file for license and copyright information */
|
||||
|
||||
+#include <stddef.h>
|
||||
#include <libdjvu/miniexp.h>
|
||||
#include <string.h>
|
||||
#include <sys/types.h>
|
||||
diff -Naur zathura-djvu-0.2.0/page-text.h zathura-djvu-0.2.0.patched/page-text.h
|
||||
--- zathura-djvu-0.2.0/page-text.h 2012-06-09 17:37:36.000000000 -0400
|
||||
+++ zathura-djvu-0.2.0.patched/page-text.h 2012-07-24 00:00:26.000000000 -0400
|
||||
@@ -6,6 +6,7 @@
|
||||
#include <girara/datastructures.h>
|
||||
#include <girara/macros.h>
|
||||
#include <zathura/document.h>
|
||||
+#include <stddef.h>
|
||||
#include <libdjvu/miniexp.h>
|
||||
|
||||
#include "djvu.h"
|
|
@ -7,7 +7,7 @@
|
|||
# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
|
||||
|
||||
PRGNAM=zathura-djvu
|
||||
VERSION=${VERSION:-0.2.3}
|
||||
VERSION=${VERSION:-0.2.4}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
|
@ -53,13 +53,9 @@ find -L . \
|
|||
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
|
||||
-exec chmod 644 {} \;
|
||||
|
||||
# the djvulibre package in Slackware 13.37 has a miniexp.h that doesn't include
|
||||
# stddef.h, so applications need to include it themselves.
|
||||
patch -p1 < $CWD/stddef.diff
|
||||
|
||||
sed -i "s,-fPIC,$SLKCFLAGS," config.mk
|
||||
|
||||
make VERBOSE=1
|
||||
make
|
||||
strip *.so
|
||||
make install DESTDIR=$PKG
|
||||
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
PRGNAM="zathura-djvu"
|
||||
VERSION="0.2.3"
|
||||
HOMEPAGE="http://www.pwmt.org/projects/zathura/plugins/zathura-djvu/"
|
||||
DOWNLOAD="http://www.pwmt.org/projects/zathura/plugins/download/zathura-djvu-0.2.3.tar.gz"
|
||||
MD5SUM="a472f706d6f6384d8bc2750141a84fc6"
|
||||
VERSION="0.2.4"
|
||||
HOMEPAGE="https://www.pwmt.org/projects/zathura-djvu/"
|
||||
DOWNLOAD="http://www.pwmt.org/projects/zathura/plugins/download/zathura-djvu-0.2.4.tar.gz"
|
||||
MD5SUM="672a25dc9433b2541971c2e4e052bdd3"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
REQUIRES="zathura"
|
||||
|
|
Loading…
Reference in a new issue