academic/klu: Updated for version 1.3.8.

Signed-off-by: Kyle Guinn <elyk03@gmail.com>
This commit is contained in:
Kyle Guinn 2016-11-19 14:51:44 -06:00 committed by David Spencer
parent 5d13a1088d
commit 36c393d6dd
3 changed files with 39 additions and 39 deletions

View file

@ -25,14 +25,14 @@
PRGNAM=klu PRGNAM=klu
SRCNAM=SuiteSparse SRCNAM=SuiteSparse
SUBDIR=KLU SUBDIR=KLU
VERSION=${VERSION:-1.3.3} VERSION=${VERSION:-1.3.8}
SRCVER=${SRCVER:-4.4.6} SRCVER=${SRCVER:-4.5.3}
BUILD=${BUILD:-1} BUILD=${BUILD:-1}
TAG=${TAG:-_SBo} TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then if [ -z "$ARCH" ]; then
case "$(uname -m)" in case "$(uname -m)" in
i?86) ARCH=i486 ;; i?86) ARCH=i586 ;;
arm*) ARCH=arm ;; arm*) ARCH=arm ;;
*) ARCH=$(uname -m) ;; *) ARCH=$(uname -m) ;;
esac esac
@ -43,11 +43,14 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp} OUTPUT=${OUTPUT:-/tmp}
DOCS="README.txt Doc/ChangeLog Doc/lesser.txt" DOCS="README.txt Doc/ChangeLog Doc/License.txt Doc/lesser.txt"
if [ "$ARCH" = "i486" ]; then if [ "$ARCH" = "i486" ]; then
SLKCFLAGS="-O2 -march=i486 -mtune=i686" SLKCFLAGS="-O2 -march=i486 -mtune=i686"
LIBDIRSUFFIX="" LIBDIRSUFFIX=""
elif [ "$ARCH" = "i586" ]; then
SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686" SLKCFLAGS="-O2 -march=i686 -mtune=i686"
LIBDIRSUFFIX="" LIBDIRSUFFIX=""
@ -73,10 +76,12 @@ cd $SRCNAM/$SUBDIR
chown -R root:root . chown -R root:root .
chmod -R u+w,go-w,a+rX-st . chmod -R u+w,go-w,a+rX-st .
patch -p1 < $CWD/autotoolize.diff patch -p1 < $CWD/patches/autotoolize.diff
autoreconf -vif autoreconf -vif
CFLAGS="$SLKCFLAGS" \ # Avoid rebuilding the docs.
touch Doc/KLU_UserGuide.pdf
./configure \ ./configure \
--prefix=/usr \ --prefix=/usr \
--libdir=/usr/lib${LIBDIRSUFFIX} \ --libdir=/usr/lib${LIBDIRSUFFIX} \
@ -88,7 +93,8 @@ CFLAGS="$SLKCFLAGS" \
--enable-shared \ --enable-shared \
--disable-static \ --disable-static \
--disable-dependency-tracking \ --disable-dependency-tracking \
--build=$ARCH-slackware-linux --build=$ARCH-slackware-linux \
CFLAGS="$SLKCFLAGS" \
make make
make check make check

View file

@ -1,8 +1,8 @@
PRGNAM="klu" PRGNAM="klu"
VERSION="1.3.3" VERSION="1.3.8"
HOMEPAGE="http://faculty.cse.tamu.edu/davis/suitesparse.html" HOMEPAGE="http://faculty.cse.tamu.edu/davis/suitesparse.html"
DOWNLOAD="http://faculty.cse.tamu.edu/davis/SuiteSparse/SuiteSparse-4.4.6.tar.gz" DOWNLOAD="http://faculty.cse.tamu.edu/davis/SuiteSparse/SuiteSparse-4.5.3.tar.gz"
MD5SUM="131a3a5e2dee784cd946284e44ce9af2" MD5SUM="8ec57324585df3c6483ad7f556afccbd"
DOWNLOAD_x86_64="" DOWNLOAD_x86_64=""
MD5SUM_x86_64="" MD5SUM_x86_64=""
REQUIRES="suitesparseconfig amd colamd btf" REQUIRES="suitesparseconfig amd colamd btf"

View file

@ -53,8 +53,11 @@ diff --git a/Doc/Makefile.am b/Doc/Makefile.am
new file mode 100644 new file mode 100644
--- /dev/null --- /dev/null
+++ b/Doc/Makefile.am +++ b/Doc/Makefile.am
@@ -0,0 +1,48 @@ @@ -0,0 +1,51 @@
+EXTRA_DIST = ChangeLog lesser.txt +EXTRA_DIST = \
+ ChangeLog \
+ License.txt \
+ lesser.txt
+ +
+dist_noinst_DATA = KLU_UserGuide.tex KLU_UserGuide.bib +dist_noinst_DATA = KLU_UserGuide.tex KLU_UserGuide.bib
+dist_pdf_DATA = KLU_UserGuide.pdf palamadai_e.pdf +dist_pdf_DATA = KLU_UserGuide.pdf palamadai_e.pdf
@ -112,11 +115,10 @@ diff --git a/Makefile.am b/Makefile.am
new file mode 100644 new file mode 100644
--- /dev/null --- /dev/null
+++ b/Makefile.am +++ b/Makefile.am
@@ -0,0 +1,5 @@ @@ -0,0 +1,4 @@
+SUBDIRS = Include Source User Matrix Demo Doc +SUBDIRS = Include Source User Matrix Demo Doc
+EXTRA_DIST = README.txt +EXTRA_DIST = README.txt
+ +
+pkgconfigdir = $(libdir)/pkgconfig
+pkgconfig_DATA = klu.pc +pkgconfig_DATA = klu.pc
diff --git a/Matrix/Makefile.am b/Matrix/Makefile.am diff --git a/Matrix/Makefile.am b/Matrix/Makefile.am
new file mode 100644 new file mode 100644
@ -200,45 +202,35 @@ diff --git a/configure.ac b/configure.ac
new file mode 100644 new file mode 100644
--- /dev/null --- /dev/null
+++ b/configure.ac +++ b/configure.ac
@@ -0,0 +1,62 @@ @@ -0,0 +1,54 @@
+# -*- Autoconf -*- +# -*- Autoconf -*-
+# Process this file with autoconf to produce a configure script. +# Process this file with autoconf to produce a configure script.
+ +
+AC_PREREQ([2.69]) +AC_PREREQ([2.69])
+AC_INIT([KLU],[1.3.3],[DrTimothyAldenDavis@gmail.com],[klu],[http://www.suitesparse.com/]) +AC_INIT([KLU],[1.3.8],[DrTimothyAldenDavis@gmail.com],[klu],[http://www.suitesparse.com/])
+AC_CONFIG_SRCDIR([Source/klu.c]) +AC_CONFIG_SRCDIR([Source/klu.c])
+AC_CONFIG_HEADERS([config.h]) +AC_CONFIG_HEADERS([config.h])
+AM_INIT_AUTOMAKE([foreign]) +AM_INIT_AUTOMAKE([foreign])
+LT_INIT +LT_INIT
+ +
+# Checks for programs. +# Checks for programs.
+PKG_PROG_PKG_CONFIG
+AC_PROG_INSTALL +AC_PROG_INSTALL
+AC_PROG_CC +AC_PROG_CC
+ +
+LIBS_SAVED=$LIBS +AS_VAR_SET([LIBS_SAVED], [$LIBS])
+ +
+# Checks for libraries. +# Checks for libraries.
+AC_CHECK_LIB([m], [sqrt]) +AC_CHECK_LIB([m], [sqrt])
+ +
+PKG_PROG_PKG_CONFIG +PKG_CHECK_MODULES([SUITESPARSECONFIG], [suitesparseconfig])
+PKG_CHECK_MODULES([SUITESPARSECONFIG],[suitesparseconfig], +PKG_CHECK_MODULES([AMD], [amd])
+ [], +PKG_CHECK_MODULES([COLAMD], [colamd])
+ [AC_MSG_ERROR([cannot find suitesparseconfig])]) +PKG_CHECK_MODULES([BTF], [btf])
+PKG_CHECK_MODULES([AMD],[amd], +PKG_CHECK_MODULES([CHOLMOD], [cholmod],
+ [], + [AS_VAR_SET([have_cholmod], [yes])],
+ [AC_MSG_ERROR([cannot find amd])]) + [AS_VAR_SET([have_cholmod], [no])
+PKG_CHECK_MODULES([COLAMD],[colamd], + AC_MSG_WARN([$CHOLMOD_PKG_ERRORS, disabling some functionality])])
+ [],
+ [AC_MSG_ERROR([cannot find colamd])])
+PKG_CHECK_MODULES([BTF],[btf],
+ [],
+ [AC_MSG_ERROR([cannot find btf])])
+PKG_CHECK_MODULES([CHOLMOD],[cholmod],
+ [cholmod="yes"],
+ [cholmod="no"])
+if test "x$cholmod" != "xyes"; then
+ AC_MSG_WARN([cannot find cholmod, disabling some functionality])
+fi
+ +
+# Checks for header files. +# Checks for header files.
+AC_CHECK_HEADERS([limits.h stdlib.h]) +AC_CHECK_HEADERS([limits.h stdlib.h])
@ -249,10 +241,11 @@ new file mode 100644
+# Checks for library functions. +# Checks for library functions.
+AC_CHECK_FUNCS([sqrt]) +AC_CHECK_FUNCS([sqrt])
+ +
+LIBS=$LIBS_SAVED +AS_VAR_SET([LIBS], [$LIBS_SAVED])
+ +
+AM_CONDITIONAL([CHOLMOD], [test "x$cholmod" = "xyes"]) +AM_CONDITIONAL([CHOLMOD], [test "x$have_cholmod" = "xyes"])
+ +
+PKG_INSTALLDIR
+AC_CONFIG_FILES([ +AC_CONFIG_FILES([
+ klu.pc + klu.pc
+ Makefile + Makefile
@ -261,7 +254,8 @@ new file mode 100644
+ Include/Makefile + Include/Makefile
+ Matrix/Makefile + Matrix/Makefile
+ Source/Makefile + Source/Makefile
+ User/Makefile]) + User/Makefile
+])
+AC_OUTPUT +AC_OUTPUT
diff --git a/klu.pc.in b/klu.pc.in diff --git a/klu.pc.in b/klu.pc.in
new file mode 100644 new file mode 100644