system/conky: re-added audacious support.

Signed-off-by: Chess Griffin <chess@chessgriffin.com>
This commit is contained in:
M.Dinslage 2010-05-31 11:21:07 -04:00 committed by Robby Workman
parent 11a11c7df9
commit 351f895700
2 changed files with 14 additions and 0 deletions

View file

@ -0,0 +1,12 @@
diff -up conky-1.8.0/configure.ac.00 conky-1.8.0/configure.ac
--- conky-1.8.0/configure.ac.00 2010-05-25 23:41:05.529674814 -0700
+++ conky-1.8.0/configure.ac 2010-05-25 23:41:34.475430675 -0700
@@ -149,7 +149,7 @@ AC_ARG_ENABLE([audacious],
AM_CONDITIONAL(BUILD_AUDACIOUS, test x$want_audacious = xyes -o x$want_audacious = xlegacy)
if test x$want_audacious = xyes; then
- PKG_CHECK_MODULES([Audacious], [audacious >= 1.4.0 dbus-glib-1 glib-2.0 gobject-2.0])
+ PKG_CHECK_MODULES([Audacious], [audacious >= 1.4.0 audclient dbus-glib-1 glib-2.0 gobject-2.0])
conky_CFLAGS="$conky_CFLAGS $Audacious_CFLAGS"
conky_LIBS="$conky_LIBS $Audacious_LIBS"
save_CPPFLAGS="$CPPFLAGS"

View file

@ -52,6 +52,7 @@ cd $TMP
rm -rf $PRGNAM-$VERSION
tar xjvf $CWD/$PRGNAM-$VERSION.tar.bz2
cd $PRGNAM-$VERSION
patch -p1 < $CWD/audacious-2.3-fix.txt
chown -R root:root .
find . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
@ -69,6 +70,7 @@ CXXFLAGS="$SLKCFLAGS" \
--enable-shared=yes \
--enable-static=no \
--enable-weather-xoap \
--enable-audacious \
--enable-mpd=yes \
--enable-rss=yes \
--enable-wlan=yes \