libraries/libixp: Removed (unmaintained)

Reference: http://lists.slackbuilds.org/pipermail/slackbuilds-users/2008-November/003181.html

Signed-off-by: Heinz Wiesinger <pprkut@slackbuilds.org>
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
This commit is contained in:
Robby Workman 2011-03-14 15:41:41 -05:00
parent 7d298fb311
commit 3413ee8445
5 changed files with 0 additions and 160 deletions

View file

@ -1,3 +0,0 @@
libixp is a stand-alone client/server 9P library including ixpc
client which behaves like wmiir in the past. It consists of less
than 2000 lines of code (including ixpc).

View file

@ -1,18 +0,0 @@
diff -Nur libixp-0.4.orig/mk/lib.mk libixp-0.4/mk/lib.mk
--- libixp-0.4.orig/mk/lib.mk 2007-11-05 08:36:22.000000000 -0600
+++ libixp-0.4/mk/lib.mk 2009-08-03 00:20:42.479105075 -0500
@@ -1,4 +1,4 @@
-PTARG = ${ROOT}/lib/${TARG}
+PTARG = ${ROOT}/@baselibdir@/${TARG}
LIB = ${PTARG}.a
OFILES = ${OBJ:=.o}
@@ -20,7 +20,7 @@
${LIB}: ${OFILES}
echo AR $$($(ROOT)/util/cleanname $(BASE)/$@)
- mkdir ${ROOT}/lib 2>/dev/null || true
+ mkdir ${ROOT}/@baselibdir@ 2>/dev/null || true
${AR} $@ ${OFILES}
include ${ROOT}/mk/common.mk

View file

@ -1,110 +0,0 @@
#!/bin/sh
# Slackware build script for libixp
# Copyright (c) 2008, Antonio Hernández Blas <hba.nihilismus@gmail.com>
# All rights reserved.
#
# Redistribution and use in source and binary forms, with or without
# modification, are permitted provided that the following conditions are met:
# 1.- Redistributions of source code must retain the above copyright
# notice, this list of conditions and the following disclaimer.
#
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY
# EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
# WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
# DISCLAIMED. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR ANY
# DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
# (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES;
# LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND
# ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
# (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
# SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=libixp
VERSION=0.4
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i486 ;;
arm*) ARCH=arm ;;
# Unless $ARCH is already set, use uname -m for all other archs:
*) ARCH=$( uname -m ) ;;
esac
fi
CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
if [ "$ARCH" = "i486" ]; then
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
LIBDIRSUFFIX="64"
else
SLKCFLAGS="-O2"
LIBDIRSUFFIX=""
fi
set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
-exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
# Fix cflags value
sed -i 's:^CFLAGS =:CFLAGS += :' config.mk
CFLAGS="$SLKCFLAGS" make \
PREFIX=/usr \
LIBDIR=/usr/lib${LIBDIRSUFFIX} \
MAN=/usr/man \
ETC=/etc
# Fix hardcoded /usr/lib
sed "s%@baselibdir@%lib$LIBDIRSUFFIX%g" $CWD/libixp-0.4-libdir.diff | patch -p1
make install \
PREFIX=$PKG/usr \
LIBDIR=$PKG/usr/lib${LIBDIRSUFFIX} \
MAN=$PKG/usr/man \
ETC=$PKG/etc
# Erase "/etc", it's empty
rmdir $PKG/etc
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
( cd $PKG/usr/man
find . -type f -exec gzip -9 {} \;
for i in $( find . -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
)
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a libixp/LICENSE* libixp/README $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}

View file

@ -1,10 +0,0 @@
PRGNAM="libixp"
VERSION="0.4"
HOMEPAGE="http://libs.suckless.org/libixp"
DOWNLOAD="http://code.suckless.org/dl/libs/libixp-0.4.tar.gz"
MD5SUM="59d9e918adffaf4413b32ac4f66724fd"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
MAINTAINER="Antonio Hernández Blas"
EMAIL="hba.nihilismus@gmail.com"
APPROVED="dsomero"

View file

@ -1,19 +0,0 @@
# HOW TO EDIT THIS FILE:
# The "handy ruler" below makes it easier to edit a package description. Line
# up the first '|' above the ':' following the base package name, and the '|'
# on the right side marks the last column you can put a character in. You must
# make exactly 11 lines for the formatting to be correct. It's also
# customary to leave one space after the ':'.
|-----handy-ruler------------------------------------------------------|
libixp: libixp (A standalone client/server 9P library)
libixp:
libixp: libixp is a stand-alone client/server 9P library including ixpc
libixp: client which behaves like wmiir in the past. It consists of less
libixp: than 2000 lines of code (including ixpc).
libixp:
libixp: Homepage: http://www.suckless.org/wiki/libs/libixp
libixp:
libixp:
libixp:
libixp: