libraries/tkimg: Fixed linking of the included libtiff

Thanks to Gentoo for the patch.

Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
This commit is contained in:
Robby Workman 2012-09-25 13:11:48 -05:00
parent bdd42a4cce
commit 32f1e178d6
2 changed files with 26 additions and 1 deletions

View file

@ -0,0 +1,22 @@
--- tkimg1.4/libtiff/configure.in 2010-07-06 15:48:46.000000000 +0200
+++ tkimg1.4.new/libtiff/configure.in 2011-02-28 23:24:18.471259943 +0100
@@ -67,7 +67,7 @@
else
TIFFHOST="$host"
fi
-${srcdir}/../compat/libtiff/configure --disable-zlib --disable-pixarlog --disable-jpeg \
+${srcdir}/../compat/libtiff/configure --disable-zlib --disable-pixarlog --disable-jpeg --disable-jbig \
"--with-CC=$TIFFCC" $TIFFHOST
mv -f tifftcl_confdefs.h confdefs.h
--- tkimg1.4/libtiff/configure 2010-07-07 10:09:46.000000000 +0200
+++ tkimg1.4.new/libtiff/configure 2011-02-28 23:25:53.529824614 +0100
@@ -5133,7 +5133,7 @@
else
TIFFHOST="$host"
fi
-${srcdir}/../compat/libtiff/configure --disable-zlib --disable-pixarlog --disable-jpeg \
+${srcdir}/../compat/libtiff/configure --disable-zlib --disable-pixarlog --disable-jpeg --disable-jbig \
"--with-CC=$TIFFCC" $TIFFHOST
mv -f tifftcl_confdefs.h confdefs.h

View file

@ -24,7 +24,7 @@
PRGNAM=tkimg
VERSION=${VERSION:-1.4}
BUILD=${BUILD:-1}
BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@ -69,6 +69,9 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
# https://bugs.gentoo.org/show_bug.cgi?id=356907
patch -p1 < $CWD/tkimg-1.4-nojbig.patch
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \