mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-16 19:50:19 +01:00
libraries/podofo: Update for 0.10.3 (+new maintainer)
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
parent
7091d10b9a
commit
2ee362ff9c
4 changed files with 15 additions and 83 deletions
|
@ -1,61 +0,0 @@
|
|||
diff -Naur podofo-0.9.6.orig/src/base/PdfXRefStreamParserObject.h podofo-0.9.6/src/base/PdfXRefStreamParserObject.h
|
||||
--- podofo-0.9.6.orig/src/base/PdfXRefStreamParserObject.h 2014-06-06 22:13:22.000000000 +0000
|
||||
+++ podofo-0.9.6/src/base/PdfXRefStreamParserObject.h 2020-05-03 02:26:01.119538387 +0000
|
||||
@@ -47,8 +47,11 @@
|
||||
* an XRef stream object.
|
||||
*
|
||||
* It is mainly here to make PdfParser more modular.
|
||||
+ * This is only marked PODOFO_API for the benefit of the tests,
|
||||
+ * the class is for internal use only. It is deprecated, so
|
||||
+ * don't ever rely on it (i.e. externally or in PoDoFo tools).
|
||||
*/
|
||||
-class PdfXRefStreamParserObject : public PdfParserObject {
|
||||
+class PODOFO_DEPRECATED PODOFO_API PdfXRefStreamParserObject : public PdfParserObject {
|
||||
public:
|
||||
|
||||
/** Parse the object data from the given file handle starting at
|
||||
diff -Naur podofo-0.9.6.orig/src/base/podofoapi.h podofo-0.9.6/src/base/podofoapi.h
|
||||
--- podofo-0.9.6.orig/src/base/podofoapi.h 2017-10-27 06:38:19.000000000 +0000
|
||||
+++ podofo-0.9.6/src/base/podofoapi.h 2020-05-03 02:27:03.874537513 +0000
|
||||
@@ -173,9 +173,22 @@
|
||||
|
||||
/* Set up some other compiler-specific but not platform-specific macros */
|
||||
|
||||
-#if defined(__GNUC__)
|
||||
- /* gcc will issue a warning if a function or variable so annotated is used */
|
||||
- #define PODOFO_DEPRECATED __attribute__((deprecated))
|
||||
+#ifdef __GNU__
|
||||
+ #define PODOFO_HAS_GCC_ATTRIBUTE_DEPRECATED 1
|
||||
+#elif defined(__has_attribute)
|
||||
+ #if __has_attribute(__deprecated__)
|
||||
+ #define PODOFO_HAS_GCC_ATTRIBUTE_DEPRECATED 1
|
||||
+ #endif
|
||||
+#endif
|
||||
+
|
||||
+#ifdef PODOFO_HAS_GCC_ATTRIBUTE_DEPRECATED
|
||||
+ /* gcc (or compat. clang) will issue a warning if a function or variable so annotated is used */
|
||||
+ #define PODOFO_DEPRECATED __attribute__((__deprecated__))
|
||||
+#else
|
||||
+ #define PODOFO_DEPRECATED
|
||||
+#endif
|
||||
+
|
||||
+#ifdef __GNU__
|
||||
/* gcc can do some additional optimisations on functions annotated as pure.
|
||||
* See the documentation on __attribute__((pure)) in the gcc docs. */
|
||||
#define PODOFO_PURE_FUNCTION __attribute__((pure))
|
||||
@@ -185,9 +198,12 @@
|
||||
* (see CODINGSTYLE.txt) .*/
|
||||
#define PODOFO_NOTHROW __attribute__((nothrow))
|
||||
#else
|
||||
- #define PODOFO_DEPRECATED
|
||||
- #define PODOFO_PURE_FUNCTION
|
||||
- #define PODOFO_NOTHROW __declspec(nothrow)
|
||||
+ #define PODOFO_PURE_FUNCTION
|
||||
+ #ifdef _MSC_VER
|
||||
+ #define PODOFO_NOTHROW __declspec(nothrow)
|
||||
+ #else
|
||||
+ #define PODOFO_NOTHROW
|
||||
+ #endif
|
||||
#endif
|
||||
|
||||
// Peter Petrov 27 April 2008
|
|
@ -3,6 +3,7 @@
|
|||
# Slackware build script for podofo
|
||||
|
||||
# Copyright 2009-2020 Larry Hajali <larryhaja[at]gmail[dot]com>
|
||||
# Copyright 2024 Isaac Yu <isaacyu@protonmail.com>
|
||||
# All rights reserved.
|
||||
#
|
||||
# Redistribution and use of this script, with or without modification, is
|
||||
|
@ -29,8 +30,8 @@
|
|||
cd $(dirname $0) ; CWD=$(pwd)
|
||||
|
||||
PRGNAM=podofo
|
||||
VERSION=${VERSION:-0.9.6}
|
||||
BUILD=${BUILD:-2}
|
||||
VERSION=${VERSION:-0.10.3}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
PKGTYPE=${PKGTYPE:-tgz}
|
||||
|
||||
|
@ -80,36 +81,28 @@ find -L . \
|
|||
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
|
||||
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
|
||||
|
||||
sed -i "s/BINARY_DIR}\/objects\"/BINARY_DIR}\/objects\" || true/" test/TokenizerTest/CMakeLists.txt
|
||||
|
||||
# Fix mandir directory.
|
||||
sed -i 's|share/man|man|' CMakeLists.txt
|
||||
# Ref: https://sourceforge.net/p/podofo/tickets/28/
|
||||
patch -p1 < $CWD/XRefStrParObj-deprecated.patch
|
||||
|
||||
mkdir build
|
||||
cd build
|
||||
cmake -G "Unix Makefiles" \
|
||||
-DCMAKE_INSTALL_PREFIX=/usr \
|
||||
-DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
|
||||
-DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
|
||||
-DPODOFO_BUILD_STATIC:BOOL=FALSE \
|
||||
-DPODOFO_BUILD_SHARED:BOOL=TRUE \
|
||||
-DPODOFO_USE_VISIBILITY:BOOL=1 \
|
||||
-DPODOFO_BUILD_TOOLS=TRUE \
|
||||
-DPODOFO_BUILD_STATIC=FALSE \
|
||||
-DCMAKE_CXX_STANDARD:STRING=11 \
|
||||
-DWANT_BOOST:BOOL=1 \
|
||||
-DLIB_SUFFIX:STRING="$LIBDIRSUFFIX" \
|
||||
-DCMAKE_BUILD_TYPE=Release ..
|
||||
|
||||
make VERBOSE=1
|
||||
make install/strip DESTDIR=$PKG
|
||||
cd -
|
||||
|
||||
# Install man files
|
||||
install -Dm644 -t $PKG/usr/man/man1 man/*.1
|
||||
find $PKG/usr/man -type f -exec gzip -9 {} \;
|
||||
|
||||
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cp -a \
|
||||
AUTHORS ChangeLog CODING* CONTRIBUTIONS* COPYING* FAQ* README* TODO \
|
||||
AUTHORS.md CHANGELOG.md CODING-STYLE.md COPYING README.md TODO.md \
|
||||
$PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
|
||||
|
||||
|
|
|
@ -1,10 +1,10 @@
|
|||
PRGNAM="podofo"
|
||||
VERSION="0.9.6"
|
||||
HOMEPAGE="http://podofo.sourceforge.net/"
|
||||
DOWNLOAD="http://downloads.sourceforge.net/podofo/podofo-0.9.6.tar.gz"
|
||||
MD5SUM="46336fc4c4ce4be814bb5fbb4d918334"
|
||||
VERSION="0.10.3"
|
||||
HOMEPAGE="https://github.com/podofo/podofo"
|
||||
DOWNLOAD="https://github.com/podofo/podofo/archive/0.10.3/podofo-0.10.3.tar.gz"
|
||||
MD5SUM="41580f583e3210563cb65478ee8697c0"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
REQUIRES=""
|
||||
MAINTAINER="Larry Hajali"
|
||||
EMAIL="larryhaja[at]gmail[dot]com"
|
||||
MAINTAINER="Isaac Yu"
|
||||
EMAIL="isaacyu@protonmail.com"
|
||||
|
|
|
@ -14,6 +14,6 @@ podofo: classes to parse PDF files and modify their contents into memory
|
|||
podofo: The parser can also be used to extract information from a PDF file
|
||||
podofo: (for example, the parser could be used in a PDF viewer).
|
||||
podofo:
|
||||
podofo: Homepage: http://podofo.sourceforge.net/
|
||||
podofo:
|
||||
podofo:
|
||||
podofo:
|
||||
|
|
Loading…
Reference in a new issue