desktop/openbox-menu: Update DEP.

Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
Edinaldo P. Silva 2015-11-13 02:01:26 +07:00 committed by Willy Sudiarto Raharjo
parent d963f9f10e
commit 2c780df73f
6 changed files with 182 additions and 11 deletions

View file

@ -1,7 +1,16 @@
openbox-menu (pipemenu for Openbox window manager)
Openbox-menu is a pipemenu for Openbox window manager.
It provides a dynamic menu listing installed applications.
Most of the work is done by the LXDE library menu-cache.
Openbox-menu is a pipemenu for Openbox window manager. It provides a
dynamic menu listing installed applications. Most of the work is done
by the LXDE library menu-cache.
Optional dependencies: gnome-menus, lxmenu-data.
Optional dependencie: gnome-menus.
To use, get a copy of menu.xml located in /usr/doc/openbox-menu-0.7.0
and put into ~/.config/openbox, after run:
$ openbox --reconfigure
In menu.xml these programs are included (thunar, leafpad, sakura, opera,
obmenu, obconf, lxappearance, obsession, nitrogen, gmrun), all available
on SlackBuilds, change if needed.

View file

@ -0,0 +1,15 @@
Description: Make makefile compatible with Debian's standards.
Author: Mateusz Łukasik <mati75@linuxmint.pl>
Last-Update: 2013-11-30
--- a/Makefile
+++ b/Makefile
@@ -7,7 +7,7 @@ CC=gcc
CFLAGS+=-DWITH_ICONS
# Uncomment this line if Openbox can display SVG icons
# Check SVG support with '$ ldd /usr/bin/openbox | grep svg', librsvg must appear..
-# CFLAGS+=-DWITH_SVG
+CFLAGS+=-DWITH_SVG
prefix= /usr/local
DESTDIR ?= $(prefix)

View file

@ -0,0 +1,90 @@
<?xml version="1.0" encoding="utf-8"?>
<openbox_menu xmlns="http://openbox.org/3.5/menu">
<menu execute="/usr/bin/openbox-menu lxde-applications.menu" id="desktop-app-menu" label="Applications"/>
<menu id="root-menu" label="Openbox 3">
<separator label="OpenBox Menu"/>
<menu id="desktop-app-menu"/>
<separator/>
<item label="File Manager">
<action name="Execute">
<execute>thunar</execute>
</action>
</item>
<item label="Terminal Emulator">
<action name="Execute">
<execute>sakura</execute>
</action>
</item>
<item label="Text Editor">
<action name="Execute">
<execute>leafpad</execute>
</action>
</item>
<item label="Web Browser">
<action name="Execute">
<execute>opera</execute>
</action>
</item>
<separator/>
<menu id="settings" label="Settings">
<item label="Change Wallpaper">
<action name="Execute">
<execute>nitrogen --sort=alpha ~/Images/</execute>
</action>
</item>
<item label="Customize Appearance">
<action name="Execute">
<execute>lxappearance</execute>
</action>
</item>
<item label="Edit autostart">
<action name="Execute">
<execute>leafpad ~/.config/openbox/autostart</execute>
</action>
</item>
<item label="Edit menu.xml">
<action name="Execute">
<execute>leafpad ~/.config/openbox/menu.xml</execute>
</action>
</item>
<item label="Edit rc.xml">
<action name="Execute">
<execute>leafpad ~/.config/openbox/rc.xml</execute>
</action>
</item>
<item label="Edit xinitrc">
<action name="Execute">
<execute>leafpad ~/.xinitrc</execute>
</action>
</item>
<item label="Edit OpenBox Menu">
<action name="Execute">
<execute>obmenu</execute>
</action>
</item>
<item label="OpenBox Config Tool">
<action name="Execute">
<execute>obconf</execute>
</action>
</item>
<item label="Reconfigure OpenBox">
<action name="Reconfigure"/>
</item>
<item label="Restart OpenBox">
<action name="Restart"/>
</item>
</menu>
<separator/>
<item label="Execute">
<action name="Execute">
<execute>gmrun</execute>
</action>
</item>
<separator/>
<item label="Exit">
<action name="Execute">
<execute>obsession-logout</execute>
</action>
</item>
</menu>
</openbox_menu>

View file

@ -0,0 +1,45 @@
.TH OPENBOX-MENU "1" "November 2013"
.SH NAME
openbox-menu \- Openbox pipe-menu to display entries in *.desktop files
.SH DESCRIPTION
.SS "Usage:"
.TP
openbox\-menu [OPTION...] [file.menu]
.SS "Help Options:"
.TP
\fB\-h\fR, \fB\-\-help\fR
Show help options
.SS "Application Options:"
.TP
\fB\-c\fR, \fB\-\-comment\fR
Show generic name instead of application name
.TP
\fB\-t\fR, \fB\-\-terminal\fR=\fIcmd\fR
Terminal command (default xterm \fB\-e\fR)
.TP
\fB\-g\fR, \fB\-\-gnome\fR
Show GNOME entries
.TP
\fB\-k\fR, \fB\-\-kde\fR
Show KDE entries
.TP
\fB\-x\fR, \fB\-\-xfce\fR
Show XFCE entries
.TP
\fB\-r\fR, \fB\-\-rox\fR
Show ROX entries
.TP
\fB\-p\fR, \fB\-\-persistent\fR
stay active
.TP
\fB\-s\fR, \fB\-\-sn\fR
Enable startup notification
.TP
\fB\-o\fR, \fB\-\-output\fR
file to write data to
.TP
\fB\-i\fR, \fB\-\-noicons\fR
Don't display icons in menu
.PP
This manual page was written by Mateusz Łukasik <mati75@linuxmint.pl>,
for the Debian project (and may be used by others).

View file

@ -1,6 +1,7 @@
#!/bin/sh
#
# Slackware build script for openbox-menu.
#
# Copyright 2015 Edinaldo P. Silva, Rio de Janeiro, Brazil.
# All rights reserved.
#
@ -23,7 +24,7 @@
PRGNAM=openbox-menu
VERSION=${VERSION:-0.7.0}
BUILD=${BUILD:-1}
BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@ -68,25 +69,36 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
rm -rf {archlinux,.hg*}
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
patch -p1 < $CWD/debian_build.patch
make PREFIX=/usr
make install DESTDIR=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
rm -rf $PKG/bin
install -d $PKG/usr/bin
install -D -m755 openbox-menu $PKG/usr/bin/openbox-menu
install -d $PKG/usr/man/man1
install -D -m644 $CWD/openbox-menu.1 $PKG/usr/man/man1/openbox-menu.1
find $PKG/usr/man -type f -exec gzip -9 {} \;
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
DOCS="AUTHORS ChangeLog COPYING README.md THANKS TODO"
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
cp -a $CWD/menu.xml-sample $PKG/usr/doc/$PRGNAM-$VERSION/menu.xml-sample
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
rm -rf $PKG/bin
mkdir -p $PKG/usr/bin
cp openbox-menu $PKG/usr/bin
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh

View file

@ -5,6 +5,6 @@ DOWNLOAD="https://bitbucket.org/fabriceT/openbox-menu/downloads/openbox-menu-0.7
MD5SUM="bd7e746452931e48340788c9e8ececa4"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="menu-cache"
REQUIRES="menu-cache lxmenu-data"
MAINTAINER="Edinaldo P. Silva"
EMAIL="edps.mundognu@gmail.com"