mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-18 22:06:04 +01:00
python/python-vulndb: Added (vulndb Python SDK).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
parent
3a9223ebd3
commit
2c54e81a68
5 changed files with 170 additions and 0 deletions
8
python/python-vulndb/README
Normal file
8
python/python-vulndb/README
Normal file
|
@ -0,0 +1,8 @@
|
|||
Python-vulndb is a Python SDK to access the (vulndb) vulnerability
|
||||
database. vulndb is a user, contributor, and developer friendly
|
||||
database.
|
||||
|
||||
To update the vulnerability database after installation, run
|
||||
as root:
|
||||
|
||||
# update-vulndb
|
38
python/python-vulndb/do-not-commit-vulndb-to-upstream.diff
Normal file
38
python/python-vulndb/do-not-commit-vulndb-to-upstream.diff
Normal file
|
@ -0,0 +1,38 @@
|
|||
|
||||
Removes git commits to vulndb since it seems to be broken
|
||||
Tracks vulndb repository in /tmp/vulndb_data
|
||||
|
||||
--- vulndb-0.0.19.orig/tools/update-db.sh 2015-11-17 22:47:34.506772912 -0700
|
||||
+++ vulndb-0.0.19/tools/update-db.sh 2015-11-17 22:54:12.818745899 -0700
|
||||
@@ -5,25 +5,13 @@
|
||||
#
|
||||
# Update the database
|
||||
#
|
||||
-if [ ! -d "data" ]; then
|
||||
- git clone https://github.com/vulndb/data.git
|
||||
+
|
||||
+if [ ! -d "/tmp/vulndb_data" ]; then
|
||||
+ git clone https://github.com/vulndb/data.git /tmp/vulndb_data
|
||||
fi
|
||||
|
||||
-cd data
|
||||
+cd /tmp/vulndb_data
|
||||
git pull
|
||||
cd ..
|
||||
|
||||
-mkdir -p vulndb/db/
|
||||
-cp -rf data/db/*.json vulndb/db/
|
||||
-git add vulndb/db/
|
||||
-
|
||||
-# Bump the version numbers
|
||||
-tools/semver.sh bump patch
|
||||
-
|
||||
-cd data
|
||||
-git rev-parse HEAD > ../vulndb/db-version.txt
|
||||
-cd ..
|
||||
-
|
||||
-# Push to repo
|
||||
-git commit vulndb/db/ vulndb/version.txt vulndb/db-version.txt -m 'Updated vulnerability database'
|
||||
-git push
|
||||
\ No newline at end of file
|
||||
+cp -rf /tmp/vulndb_data/db/*.json /usr/lib64/python2.7/site-packages/vulndb/db/
|
95
python/python-vulndb/python-vulndb.SlackBuild
Normal file
95
python/python-vulndb/python-vulndb.SlackBuild
Normal file
|
@ -0,0 +1,95 @@
|
|||
#!/bin/sh
|
||||
|
||||
# Slackware build script for python-vulndb
|
||||
|
||||
# Copyright 2015 Brenton Earl <brent@exitstatusone.com>
|
||||
# All rights reserved.
|
||||
#
|
||||
# Redistribution and use of this script, with or without modification, is
|
||||
# permitted provided that the following conditions are met:
|
||||
#
|
||||
# 1. Redistributions of this script must retain the above copyright
|
||||
# notice, this list of conditions and the following disclaimer.
|
||||
#
|
||||
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
|
||||
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
|
||||
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
|
||||
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
|
||||
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
|
||||
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
|
||||
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
|
||||
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
|
||||
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
|
||||
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
||||
|
||||
PRGNAM=python-vulndb
|
||||
SRCNAM=vulndb
|
||||
VERSION=${VERSION:-0.0.19}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
if [ -z "$ARCH" ]; then
|
||||
case "$( uname -m )" in
|
||||
i?86) ARCH=i486 ;;
|
||||
arm*) ARCH=arm ;;
|
||||
*) ARCH=$( uname -m ) ;;
|
||||
esac
|
||||
fi
|
||||
|
||||
CWD=$(pwd)
|
||||
TMP=${TMP:-/tmp/SBo}
|
||||
PKG=$TMP/package-$PRGNAM
|
||||
OUTPUT=${OUTPUT:-/tmp}
|
||||
|
||||
if [ "$ARCH" = "i486" ]; then
|
||||
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
|
||||
LIBDIRSUFFIX=""
|
||||
elif [ "$ARCH" = "i686" ]; then
|
||||
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
|
||||
LIBDIRSUFFIX=""
|
||||
elif [ "$ARCH" = "x86_64" ]; then
|
||||
SLKCFLAGS="-O2 -fPIC"
|
||||
LIBDIRSUFFIX="64"
|
||||
else
|
||||
SLKCFLAGS="-O2"
|
||||
LIBDIRSUFFIX=""
|
||||
fi
|
||||
|
||||
set -e
|
||||
|
||||
rm -rf $PKG
|
||||
mkdir -p $TMP $PKG $OUTPUT
|
||||
cd $TMP
|
||||
rm -rf $SRCNAM-$VERSION
|
||||
tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
|
||||
cd $SRCNAM-$VERSION
|
||||
chown -R root:root .
|
||||
find -L . \
|
||||
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
|
||||
-o -perm 511 \) -exec chmod 755 {} \; -o \
|
||||
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
|
||||
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
|
||||
|
||||
# Removes git commit to vulndb/data.git since it seems to be
|
||||
# broken. Tracks vulndb/data.git in /tmp/vulndb_data
|
||||
# After Vulndb is downloaded it is copied to:
|
||||
# /usr/lib64/python2.7/site-packages/vulndb/db/
|
||||
patch -p1 --verbose < $CWD/do-not-commit-vulndb-to-upstream.diff
|
||||
|
||||
python setup.py install --root=$PKG
|
||||
|
||||
# Installs update-db.sh and renames it to update-vulndb
|
||||
install -Dm755 tools/update-db.sh $PKG/usr/bin/update-vulndb
|
||||
|
||||
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
|
||||
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
|
||||
|
||||
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cp -a LICENSE PKG-INFO README.rst $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
|
||||
|
||||
mkdir -p $PKG/install
|
||||
cat $CWD/slack-desc > $PKG/install/slack-desc
|
||||
|
||||
cd $PKG
|
||||
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
|
10
python/python-vulndb/python-vulndb.info
Normal file
10
python/python-vulndb/python-vulndb.info
Normal file
|
@ -0,0 +1,10 @@
|
|||
PRGNAM="python-vulndb"
|
||||
VERSION="0.0.19"
|
||||
HOMEPAGE="https://github.com/vulndb/python-sdk/"
|
||||
DOWNLOAD="https://pypi.python.org/packages/source/v/vulndb/vulndb-0.0.19.tar.gz"
|
||||
MD5SUM="40f60a109aca06a928e0e0e64c13c226"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
REQUIRES="pysetuptools"
|
||||
MAINTAINER="Brenton Earl"
|
||||
EMAIL="brent@exitstatusone.com"
|
19
python/python-vulndb/slack-desc
Normal file
19
python/python-vulndb/slack-desc
Normal file
|
@ -0,0 +1,19 @@
|
|||
# HOW TO EDIT THIS FILE:
|
||||
# The "handy ruler" below makes it easier to edit a package description.
|
||||
# Line up the first '|' above the ':' following the base package name, and
|
||||
# the '|' on the right side marks the last column you can put a character in.
|
||||
# You must make exactly 11 lines for the formatting to be correct. It's also
|
||||
# customary to leave one space after the ':' except on otherwise blank lines.
|
||||
|
||||
|-----handy-ruler------------------------------------------------------|
|
||||
python-vulndb: python-vulndb (vulndb Python SDK)
|
||||
python-vulndb:
|
||||
python-vulndb: Python-vulndb is a Python SDK to access the (vulndb) vulnerability
|
||||
python-vulndb: database. vulndb is a user, contributor, and developer friendly
|
||||
python-vulndb: database.
|
||||
python-vulndb:
|
||||
python-vulndb: Home page: https://github.com/vulndb/python-sdk/
|
||||
python-vulndb:
|
||||
python-vulndb:
|
||||
python-vulndb:
|
||||
python-vulndb:
|
Loading…
Reference in a new issue