mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-22 19:44:21 +01:00
libraries/uuid: Added (OSSP Universally Unique Identifier).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
parent
3918dcef7b
commit
2bf69a6871
7 changed files with 448 additions and 0 deletions
209
libraries/uuid/01-ossp.patch
Normal file
209
libraries/uuid/01-ossp.patch
Normal file
|
@ -0,0 +1,209 @@
|
|||
diff -up uuid-1.6.1/uuid-config.in.BAD uuid-1.6.1/uuid-config.in
|
||||
--- uuid-1.6.1/uuid-config.in.BAD 2008-03-06 11:56:13.000000000 -0500
|
||||
+++ uuid-1.6.1/uuid-config.in 2008-03-06 11:56:25.000000000 -0500
|
||||
@@ -121,7 +121,7 @@ do
|
||||
output_extra="$output_extra $uuid_ldflags"
|
||||
;;
|
||||
--libs)
|
||||
- output="$output -luuid"
|
||||
+ output="$output -lossp-uuid"
|
||||
output_extra="$output_extra $uuid_libs"
|
||||
;;
|
||||
* )
|
||||
diff -up uuid-1.6.1/Makefile.in.BAD uuid-1.6.1/Makefile.in
|
||||
--- uuid-1.6.1/Makefile.in.BAD 2008-03-06 11:10:13.000000000 -0500
|
||||
+++ uuid-1.6.1/Makefile.in 2008-03-06 11:11:39.000000000 -0500
|
||||
@@ -62,13 +62,13 @@ PERL = @PERL@
|
||||
PHP = @PHP@
|
||||
PG_CONFIG = @PG_CONFIG@
|
||||
|
||||
-LIB_NAME = libuuid.la
|
||||
+LIB_NAME = libossp-uuid.la
|
||||
LIB_OBJS = uuid.lo uuid_md5.lo uuid_sha1.lo uuid_prng.lo uuid_mac.lo uuid_time.lo uuid_ui64.lo uuid_ui128.lo uuid_str.lo
|
||||
|
||||
-DCE_NAME = libuuid_dce.la
|
||||
+DCE_NAME = libossp-uuid_dce.la
|
||||
DCE_OBJS = uuid_dce.lo $(LIB_OBJS)
|
||||
|
||||
-CXX_NAME = libuuid++.la
|
||||
+CXX_NAME = libossp-uuid++.la
|
||||
CXX_OBJS = uuid++.lo $(LIB_OBJS)
|
||||
|
||||
PRG_NAME = uuid
|
||||
@@ -79,10 +79,10 @@ MAN_NAME = uuid.3 uuid++.3 uuid.1
|
||||
PERL_NAME = $(S)/perl/blib/lib/OSSP/uuid.pm
|
||||
PERL_OBJS = $(S)/perl/uuid.pm
|
||||
|
||||
-PHP_NAME = $(S)/php/modules/uuid.so
|
||||
+PHP_NAME = $(S)/php/modules/ossp-uuid.so
|
||||
PHP_OBJS = $(S)/php/uuid.c
|
||||
|
||||
-PGSQL_NAME = $(S)/pgsql/libuuid.so
|
||||
+PGSQL_NAME = $(S)/pgsql/libossp-uuid.so
|
||||
PGSQL_OBJS = $(S)/pgsql/uuid.c
|
||||
|
||||
TARGETS = $(LIB_NAME) @DCE_NAME@ @CXX_NAME@ $(PRG_NAME) @PERL_NAME@ @PHP_NAME@ @PGSQL_NAME@
|
||||
@@ -231,7 +231,7 @@ install:
|
||||
$(SHTOOL) mkdir -f -p -m 755 $(DESTDIR)$(mandir)/man1
|
||||
$(SHTOOL) install -c -m 755 uuid-config $(DESTDIR)$(bindir)/
|
||||
$(SHTOOL) install -c -m 644 $(S)/uuid-config.1 $(DESTDIR)$(mandir)/man1/
|
||||
- $(SHTOOL) install -c -m 644 $(S)/uuid.pc $(DESTDIR)$(libdir)/pkgconfig/
|
||||
+ $(SHTOOL) install -c -m 644 $(S)/uuid.pc $(DESTDIR)$(libdir)/pkgconfig/ossp-uuid.pc
|
||||
$(SHTOOL) install -c -m 644 uuid.h $(DESTDIR)$(includedir)/
|
||||
-@if [ ".$(WITH_DCE)" = .yes ]; then \
|
||||
echo "$(SHTOOL) install -c -m 644 $(S)/uuid_dce.h $(DESTDIR)$(includedir)/"; \
|
||||
@@ -241,7 +241,7 @@ install:
|
||||
echo "$(SHTOOL) install -c -m 644 $(S)/uuid++.hh $(DESTDIR)$(includedir)/"; \
|
||||
$(SHTOOL) install -c -m 644 $(S)/uuid++.hh $(DESTDIR)$(includedir)/; \
|
||||
fi
|
||||
- $(SHTOOL) install -c -m 644 $(S)/uuid.3 $(DESTDIR)$(mandir)/man3/
|
||||
+ $(SHTOOL) install -c -m 644 $(S)/uuid.3 $(DESTDIR)$(mandir)/man3/ossp-uuid.3
|
||||
-@if [ ".$(WITH_CXX)" = .yes ]; then \
|
||||
echo "$(SHTOOL) install -c -m 644 $(S)/uuid++.3 $(DESTDIR)$(mandir)/man3/"; \
|
||||
$(SHTOOL) install -c -m 644 $(S)/uuid++.3 $(DESTDIR)$(mandir)/man3/; \
|
||||
@@ -276,7 +276,7 @@ uninstall:
|
||||
-@if [ ".$(WITH_CXX)" = .yes ]; then \
|
||||
$(LIBTOOL) --mode=uninstall $(RM) $(DESTDIR)$(libdir)/$(CXX_NAME); \
|
||||
fi
|
||||
- -$(RM) $(DESTDIR)$(mandir)/man3/uuid.3
|
||||
+ -$(RM) $(DESTDIR)$(mandir)/man3/ossp-uuid.3
|
||||
-@if [ ".$(WITH_CXX)" = .yes ]; then \
|
||||
echo "$(RM) $(DESTDIR)$(mandir)/man3/uuid++.3"; \
|
||||
$(RM) $(DESTDIR)$(mandir)/man3/uuid++.3; \
|
||||
@@ -290,7 +290,7 @@ uninstall:
|
||||
echo "$(RM) $(DESTDIR)$(includedir)/uuid++.hh"; \
|
||||
$(RM) $(DESTDIR)$(includedir)/uuid++.hh; \
|
||||
fi
|
||||
- -$(RM) $(DESTDIR)$(libdir)/pkgconfig/uuid.pc
|
||||
+ -$(RM) $(DESTDIR)$(libdir)/pkgconfig/ossp-uuid.pc
|
||||
-$(RM) $(DESTDIR)$(mandir)/man1/uuid-config.1
|
||||
-$(RM) $(DESTDIR)$(bindir)/uuid-config
|
||||
-$(RMDIR) $(DESTDIR)$(mandir)/man1 >/dev/null 2>&1 || $(TRUE)
|
||||
diff -up uuid-1.6.1/pgsql/Makefile.BAD uuid-1.6.1/pgsql/Makefile
|
||||
--- uuid-1.6.1/pgsql/Makefile.BAD 2008-03-06 11:53:26.000000000 -0500
|
||||
+++ uuid-1.6.1/pgsql/Makefile 2008-03-06 11:54:14.000000000 -0500
|
||||
@@ -18,13 +18,13 @@ POSTGRES := $(shell $(PG_CONFIG
|
||||
top_builddir := $(dir $(PGXS))../..
|
||||
include $(top_builddir)/src/Makefile.global
|
||||
|
||||
-NAME = uuid
|
||||
+NAME = ossp-uuid
|
||||
OBJS = uuid.o
|
||||
SO_MAJOR_VERSION = 1
|
||||
SO_MINOR_VERSION = 0
|
||||
|
||||
override CPPFLAGS := -I.. $(CPPFLAGS)
|
||||
-SHLIB_LINK := -L../.libs -luuid
|
||||
+SHLIB_LINK := -L../.libs -lossp-uuid
|
||||
SHLIB_LINK += $(shell test $(shell uname -s) = FreeBSD && echo "-Wl,-Bsymbolic")
|
||||
SHLIB_LINK += $(shell test $(shell uname -s) = Darwin && echo "-bundle_loader $(POSTGRES)")
|
||||
rpath :=
|
||||
@@ -35,16 +35,16 @@ enable_shared = yes
|
||||
include $(top_builddir)/src/Makefile.shlib
|
||||
|
||||
uuid.sql: uuid.sql.in
|
||||
- sed -e 's;MODULE_PATHNAME;$(DESTDIR)$(pkglibdir)/uuid$(DLSUFFIX);g' <uuid.sql.in >uuid.sql
|
||||
+ sed -e 's;MODULE_PATHNAME;$(DESTDIR)$(pkglibdir)/ossp-uuid$(DLSUFFIX);g' <uuid.sql.in >uuid.sql
|
||||
|
||||
install: all
|
||||
$(mkinstalldirs) $(DESTDIR)$(pkglibdir)
|
||||
$(mkinstalldirs) $(DESTDIR)$(datadir)
|
||||
- $(INSTALL_SHLIB) $(shlib) $(DESTDIR)$(pkglibdir)/uuid$(DLSUFFIX)
|
||||
+ $(INSTALL_SHLIB) $(shlib) $(DESTDIR)$(pkglibdir)/ossp-uuid$(DLSUFFIX)
|
||||
$(INSTALL_DATA) uuid.sql $(DESTDIR)$(datadir)/uuid.sql
|
||||
|
||||
uninstall:
|
||||
- -rm -f $(DESTDIR)$(pkglibdir)/uuid$(DLSUFFIX)
|
||||
+ -rm -f $(DESTDIR)$(pkglibdir)/ossp-uuid$(DLSUFFIX)
|
||||
-rm -f $(DESTDIR)$(datadir)/uuid.sql
|
||||
|
||||
clean distclean: clean-lib
|
||||
diff -up uuid-1.6.1/uuid.pc.in.BAD uuid-1.6.1/uuid.pc.in
|
||||
--- uuid-1.6.1/uuid.pc.in.BAD 2008-03-06 11:57:29.000000000 -0500
|
||||
+++ uuid-1.6.1/uuid.pc.in 2008-03-06 11:57:36.000000000 -0500
|
||||
@@ -36,7 +36,7 @@
|
||||
Description: Universally Unique Identifier (UUID) Library
|
||||
Version: @UUID_VERSION_RAW@
|
||||
URL: http://www.ossp.org/pkg/lib/uuid/
|
||||
-Cflags: -I${includedir}
|
||||
-Libs: -L${libdir} -luuid
|
||||
+Cflags: -I${includedir}/ossp
|
||||
+Libs: -L${libdir} -lossp-uuid
|
||||
Libs.private: @LIBS@
|
||||
|
||||
diff -up uuid-1.6.1/perl/Makefile.PL.BAD uuid-1.6.1/perl/Makefile.PL
|
||||
--- uuid-1.6.1/perl/Makefile.PL.BAD 2008-03-06 11:12:05.000000000 -0500
|
||||
+++ uuid-1.6.1/perl/Makefile.PL 2008-03-06 11:49:25.000000000 -0500
|
||||
@@ -33,9 +33,9 @@ use Config;
|
||||
use ExtUtils::MakeMaker;
|
||||
|
||||
# determine source directory
|
||||
-my ($srcdir) = map { my $d = $_; $d =~ s/\/libuuid\.la$//; $d }
|
||||
- grep { -f $_ } ("../libuuid.la", glob("../*/libuuid.la"))
|
||||
- or die "no source directory found (where libuuid.la is located)";
|
||||
+my ($srcdir) = map { my $d = $_; $d =~ s/\/libossp-uuid\.la$//; $d }
|
||||
+ grep { -f $_ } ("../libossp-uuid.la", glob("../*/libossp-uuid.la"))
|
||||
+ or die "no source directory found (where libossp-uuid.la is located)";
|
||||
|
||||
# determine extra build options
|
||||
my $compat = 0;
|
||||
@@ -47,7 +47,7 @@ WriteMakefile(
|
||||
VERSION_FROM => 'uuid.pm',
|
||||
ABSTRACT_FROM => 'uuid.pod',
|
||||
PREREQ_PM => {},
|
||||
- LIBS => [ "-L$srcdir/.libs -L$srcdir -luuid" ],
|
||||
+ LIBS => [ "-L$srcdir/.libs -L$srcdir -lossp-uuid" ],
|
||||
DEFINE => '',
|
||||
INC => "-I. -I$srcdir",
|
||||
PM => { 'uuid.pm' => '$(INST_LIBDIR)/uuid.pm',
|
||||
diff -up uuid-1.6.1/Makefile.PL.BAD uuid-1.6.1/Makefile.PL
|
||||
--- uuid-1.6.1/Makefile.PL.BAD 2008-03-06 11:09:49.000000000 -0500
|
||||
+++ uuid-1.6.1/Makefile.PL 2008-03-06 11:10:01.000000000 -0500
|
||||
@@ -44,7 +44,7 @@ ARGS = $ARGS
|
||||
all pure_all:
|
||||
\@if [ ! -d build ]; then mkdir build; fi
|
||||
\@if [ ! -f build/Makefile ]; then (cd build && ../configure --disable-shared); fi
|
||||
- \@if [ ! -f build/libuuid.la ]; then (cd build && \$(MAKE) \$(MFLAGS) libuuid.la); fi
|
||||
+ \@if [ ! -f build/libossp-uuid.la ]; then (cd build && \$(MAKE) \$(MFLAGS) libossp-uuid.la); fi
|
||||
\@if [ ! -f perl/Makefile ]; then (cd perl && \$(PERL) Makefile.PL \$(ARGS)); fi
|
||||
\@cd perl && \$(MAKE) \$(MFLAGS) \$\@
|
||||
|
||||
diff -up uuid-1.6.1/php/config.m4.BAD uuid-1.6.1/php/config.m4
|
||||
--- uuid-1.6.1/php/config.m4.BAD 2008-03-06 11:54:55.000000000 -0500
|
||||
+++ uuid-1.6.1/php/config.m4 2008-03-06 11:55:07.000000000 -0500
|
||||
@@ -34,7 +34,7 @@ if test "$PHP_UUID" != "no"; then
|
||||
PHP_NEW_EXTENSION(uuid, uuid.c, $ext_shared)
|
||||
AC_DEFINE(HAVE_UUID, 1, [Have OSSP uuid library])
|
||||
PHP_ADD_LIBPATH([..], )
|
||||
- PHP_ADD_LIBRARY([uuid],, UUID_SHARED_LIBADD)
|
||||
+ PHP_ADD_LIBRARY([ossp-uuid],, UUID_SHARED_LIBADD)
|
||||
PHP_ADD_INCLUDE([..])
|
||||
PHP_SUBST(UUID_SHARED_LIBADD)
|
||||
|
||||
diff -up uuid-1.6.1/php/Makefile.local.BAD uuid-1.6.1/php/Makefile.local
|
||||
--- uuid-1.6.1/php/Makefile.local.BAD 2008-03-06 11:54:39.000000000 -0500
|
||||
+++ uuid-1.6.1/php/Makefile.local 2008-03-06 11:54:49.000000000 -0500
|
||||
@@ -48,7 +48,7 @@ install: build
|
||||
@version=`$(PHP)-config --version | sed -e 's;^\([0-9]\).*$$;\1;'`; extdir="$(EXTDIR)"; \
|
||||
echo "installing PHP$$version API into $$extdir"; \
|
||||
./build/shtool mkdir -f -p -m 755 $(DESTDIR)$$extdir; \
|
||||
- ./build/shtool install -c -m 755 modules/uuid.so $(DESTDIR)$$extdir/uuid.so; \
|
||||
+ ./build/shtool install -c -m 755 modules/uuid.so $(DESTDIR)$$extdir/ossp-uuid.so; \
|
||||
./build/shtool install -c -m 644 uuid.php$$version $(DESTDIR)$$extdir/uuid.php
|
||||
|
||||
clean:
|
||||
diff -up uuid-1.6.1/php/uuid.ts.BAD uuid-1.6.1/php/uuid.ts
|
||||
--- uuid-1.6.1/php/uuid.ts.BAD 2008-03-06 11:55:38.000000000 -0500
|
||||
+++ uuid-1.6.1/php/uuid.ts 2008-03-06 11:56:03.000000000 -0500
|
||||
@@ -34,9 +34,9 @@
|
||||
|
||||
$php_version = $argv[1];
|
||||
|
||||
-print "++ loading DSO uuid.so (low-level API)\n";
|
||||
+print "++ loading DSO ossp-uuid.so (low-level API)\n";
|
||||
if (!extension_loaded('uuid')) {
|
||||
- dl('modules/uuid.so');
|
||||
+ dl('modules/ossp-uuid.so');
|
||||
}
|
||||
|
||||
print "++ loading PHP uuid.php${php_version} (high-level API)\n";
|
51
libraries/uuid/03-Fix-whatis-entries.patch
Normal file
51
libraries/uuid/03-Fix-whatis-entries.patch
Normal file
|
@ -0,0 +1,51 @@
|
|||
From: Marco Nenciarini <marco.nenciarini@devise.it>
|
||||
Date: Tue, 2 Feb 2010 12:16:49 +0100
|
||||
Subject: [PATCH] Fix whatis entries
|
||||
|
||||
Fix whatis entry of uuid.1, uuid.3ossp and uuid++.3ossp manpages
|
||||
---
|
||||
uuid++.pod | 2 +-
|
||||
uuid.pod | 2 +-
|
||||
uuid_cli.pod | 2 +-
|
||||
3 files changed, 3 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/uuid++.pod b/uuid++.pod
|
||||
index 8b5a4b1..89c5efb 100644
|
||||
--- a/uuid++.pod
|
||||
+++ b/uuid++.pod
|
||||
@@ -31,7 +31,7 @@
|
||||
|
||||
=head1 NAME
|
||||
|
||||
-B<OSSP uuid> - B<Universally Unique Identifier> (C++ API)
|
||||
+B<uuid++> - B<Universally Unique Identifier> (C++ API)
|
||||
|
||||
=head1 VERSION
|
||||
|
||||
diff --git a/uuid.pod b/uuid.pod
|
||||
index 4ad3742..0179a46 100644
|
||||
--- a/uuid.pod
|
||||
+++ b/uuid.pod
|
||||
@@ -31,7 +31,7 @@
|
||||
|
||||
=head1 NAME
|
||||
|
||||
-B<OSSP uuid> - B<Universally Unique Identifier>
|
||||
+B<uuid> - B<Universally Unique Identifier>
|
||||
|
||||
=head1 VERSION
|
||||
|
||||
diff --git a/uuid_cli.pod b/uuid_cli.pod
|
||||
index ddec6bb..df9dc83 100644
|
||||
--- a/uuid_cli.pod
|
||||
+++ b/uuid_cli.pod
|
||||
@@ -31,7 +31,7 @@
|
||||
|
||||
=head1 NAME
|
||||
|
||||
-B<OSSP uuid> - B<Universally Unique Identifier Command-Line Tool>
|
||||
+B<uuid> - B<Universally Unique Identifier Command-Line Tool>
|
||||
|
||||
=head1 VERSION
|
||||
|
||||
--
|
36
libraries/uuid/04-fix-data-uuid-from-string.patch
Normal file
36
libraries/uuid/04-fix-data-uuid-from-string.patch
Normal file
|
@ -0,0 +1,36 @@
|
|||
Description: Support dash-less args to from_string.
|
||||
Author: Tim Retout <diocles@debian.org>
|
||||
Bug-Debian: http://bugs.debian.org/635607
|
||||
|
||||
The module Data::GUID depends on Data::UUID supporting this behaviour.
|
||||
|
||||
--- a/perl/uuid_compat.pm
|
||||
+++ b/perl/uuid_compat.pm
|
||||
@@ -93,7 +93,9 @@
|
||||
$uuid->import('str',
|
||||
$str =~ /^0x/
|
||||
? join '-', unpack('x2 a8 a4 a4 a4 a12', $str)
|
||||
- : $str
|
||||
+ : $str =~ /-/
|
||||
+ ? $str
|
||||
+ : join '-', unpack('A8 A4 A4 A4 A12', $str)
|
||||
);
|
||||
return $uuid->export('bin');
|
||||
}
|
||||
--- a/perl/uuid_compat.ts
|
||||
+++ b/perl/uuid_compat.ts
|
||||
@@ -28,7 +28,7 @@
|
||||
## uuid_compat.ts: Data::UUID Backward Compatibility Perl API (Perl test suite part)
|
||||
##
|
||||
|
||||
-use Test::More tests => 14;
|
||||
+use Test::More tests => 16;
|
||||
|
||||
BEGIN {
|
||||
use_ok('Data::UUID');
|
||||
@@ -53,3 +53,5 @@
|
||||
ok($uuid8 = $ug->from_string("6ba7b811-9dad-11d1-80b4-00c04fd430c8"));
|
||||
ok($ug->compare($uuid7, $uuid8) == 0);
|
||||
|
||||
+ok($uuid9 = $ug->from_string("6ba7b8119dad11d180b400c04fd430c8"));
|
||||
+ok($ug->compare($uuid7, $uuid9) == 0);
|
4
libraries/uuid/README
Normal file
4
libraries/uuid/README
Normal file
|
@ -0,0 +1,4 @@
|
|||
OSSP uuid is a ISO-C:1999 application programming interface (API)
|
||||
and corresponding command line interface (CLI) for the generation of
|
||||
DCE 1.1, ISO/IEC 11578:1996 and IETF RFC-4122 compliant Universally
|
||||
Unique Identifier (UUID).
|
19
libraries/uuid/slack-desc
Normal file
19
libraries/uuid/slack-desc
Normal file
|
@ -0,0 +1,19 @@
|
|||
# HOW TO EDIT THIS FILE:
|
||||
# The "handy ruler" below makes it easier to edit a package description.
|
||||
# Line up the first '|' above the ':' following the base package name, and
|
||||
# the '|' on the right side marks the last column you can put a character in.
|
||||
# You must make exactly 11 lines for the formatting to be correct. It's also
|
||||
# customary to leave one space after the ':' except on otherwise blank lines.
|
||||
|
||||
|-----handy-ruler------------------------------------------------------|
|
||||
uuid: uuid (OSSP Universally Unique Identifier)
|
||||
uuid:
|
||||
uuid: OSSP uuid is a ISO-C:1999 application programming interface (API)
|
||||
uuid: and corresponding command line interface (CLI) for the generation of
|
||||
uuid: DCE 1.1, ISO/IEC 11578:1996 and IETF RFC-4122 compliant Universally
|
||||
uuid: Unique Identifier (UUID).
|
||||
uuid:
|
||||
uuid: Homepage: http://www.ossp.org/pkg/lib/uuid/
|
||||
uuid:
|
||||
uuid:
|
||||
uuid:
|
119
libraries/uuid/uuid.SlackBuild
Normal file
119
libraries/uuid/uuid.SlackBuild
Normal file
|
@ -0,0 +1,119 @@
|
|||
#!/bin/sh
|
||||
|
||||
# Slackware build script for uuid
|
||||
|
||||
# Thanks to Corrado Franco (http://www.conraid.net)
|
||||
# Copyright (c) 2016 Cristiano Urban, Gonars, Italy
|
||||
# All rights reserved.
|
||||
#
|
||||
# Redistribution and use of this script, with or without modification, is
|
||||
# permitted provided that the following conditions are met:
|
||||
#
|
||||
# 1. Redistributions of this script must retain the above copyright
|
||||
# notice, this list of conditions and the following disclaimer.
|
||||
#
|
||||
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
|
||||
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
|
||||
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
|
||||
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
|
||||
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
|
||||
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
|
||||
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
|
||||
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
|
||||
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
|
||||
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
||||
|
||||
PRGNAM=uuid
|
||||
VERSION=${VERSION:-1.6.2}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
if [ -z "$ARCH" ]; then
|
||||
case "$( uname -m )" in
|
||||
i?86) ARCH=i586 ;;
|
||||
arm*) ARCH=arm ;;
|
||||
*) ARCH=$( uname -m ) ;;
|
||||
esac
|
||||
fi
|
||||
|
||||
CWD=$(pwd)
|
||||
TMP=${TMP:-/tmp/SBo}
|
||||
PKG=$TMP/package-$PRGNAM
|
||||
OUTPUT=${OUTPUT:-/tmp}
|
||||
|
||||
if [ "$ARCH" = "i586" ]; then
|
||||
SLKCFLAGS="-O2 -march=i586 -mtune=i686"
|
||||
LIBDIRSUFFIX=""
|
||||
elif [ "$ARCH" = "i686" ]; then
|
||||
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
|
||||
LIBDIRSUFFIX=""
|
||||
elif [ "$ARCH" = "x86_64" ]; then
|
||||
SLKCFLAGS="-O2 -fPIC"
|
||||
LIBDIRSUFFIX="64"
|
||||
else
|
||||
SLKCFLAGS="-O2"
|
||||
LIBDIRSUFFIX=""
|
||||
fi
|
||||
|
||||
set -e
|
||||
|
||||
rm -rf $PKG
|
||||
mkdir -p $TMP $PKG $OUTPUT
|
||||
cd $TMP
|
||||
rm -rf $PRGNAM-$VERSION
|
||||
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
|
||||
cd $PRGNAM-$VERSION
|
||||
chown -R root:root .
|
||||
find -L . \
|
||||
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
|
||||
-o -perm 511 \) -exec chmod 755 {} \; -o \
|
||||
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
|
||||
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
|
||||
|
||||
patch -p1 -i $CWD/01-ossp.patch
|
||||
patch -p1 -i $CWD/03-Fix-whatis-entries.patch
|
||||
patch -p1 -i $CWD/04-fix-data-uuid-from-string.patch
|
||||
|
||||
CFLAGS="$SLKCFLAGS" \
|
||||
CXXFLAGS="$SLKCFLAGS" \
|
||||
./configure \
|
||||
--prefix=/usr \
|
||||
--libdir=/usr/lib${LIBDIRSUFFIX} \
|
||||
--sysconfdir=/etc \
|
||||
--localstatedir=/var \
|
||||
--with-dce \
|
||||
--with-cxx \
|
||||
--with-perl \
|
||||
--with-perl-compat \
|
||||
--mandir=/usr/man \
|
||||
--docdir=/usr/doc/$PRGNAM-$VERSION \
|
||||
--disable-static \
|
||||
--build=$ARCH-slackware-linux
|
||||
|
||||
make
|
||||
|
||||
# Fix man path in perl binding
|
||||
sed 's|/share/man/|/man/|g' -i perl/Makefile
|
||||
|
||||
make install DESTDIR=$PKG
|
||||
|
||||
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
|
||||
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
|
||||
|
||||
find $PKG/usr/man -type f -exec gzip -9 {} \;
|
||||
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
|
||||
|
||||
find $PKG -name perllocal.pod \
|
||||
-o -name ".packlist" \
|
||||
-o -name "*.bs" \
|
||||
| xargs rm -f
|
||||
|
||||
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cp -a ChangeLog INSTALL README $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
|
||||
|
||||
mkdir -p $PKG/install
|
||||
cat $CWD/slack-desc > $PKG/install/slack-desc
|
||||
|
||||
cd $PKG
|
||||
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
|
10
libraries/uuid/uuid.info
Normal file
10
libraries/uuid/uuid.info
Normal file
|
@ -0,0 +1,10 @@
|
|||
PRGNAM="uuid"
|
||||
VERSION="1.6.2"
|
||||
HOMEPAGE="http://www.ossp.org/pkg/lib/uuid/"
|
||||
DOWNLOAD="http://www.mirrorservice.org/sites/ftp.ossp.org/pkg/lib/uuid/uuid-1.6.2.tar.gz"
|
||||
MD5SUM="5db0d43a9022a6ebbbc25337ae28942f"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
REQUIRES=""
|
||||
MAINTAINER="Cristiano Urban"
|
||||
EMAIL="cristiano.urban.slack@gmail.com"
|
Loading…
Reference in a new issue