mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-16 19:50:19 +01:00
business/ledger: Updated for version 3.3.2.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
parent
bad18acc30
commit
2bc1d89451
3 changed files with 4 additions and 18 deletions
|
@ -1,13 +0,0 @@
|
|||
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
||||
index 15cb7ef90..bb8bfa2dc 100644
|
||||
--- a/CMakeLists.txt
|
||||
+++ b/CMakeLists.txt
|
||||
@@ -12,7 +12,7 @@ set(Ledger_TEST_TIMEZONE "America/Chicago")
|
||||
|
||||
# Point CMake at any custom modules we may ship
|
||||
list(APPEND CMAKE_MODULE_PATH "${PROJECT_SOURCE_DIR}/cmake")
|
||||
-if(${CMAKE_VERSION} VERSION_LESS "3.16.0")
|
||||
+if ((${CMAKE_VERSION} VERSION_GREATER_EQUAL "3.7.0") AND (${CMAKE_VERSION} VERSION_LESS "3.16.0"))
|
||||
# use backported module from 3.15 (introduced 3.12) to support older versions of cmake
|
||||
list(APPEND CMAKE_MODULE_PATH "${PROJECT_SOURCE_DIR}/cmake/python-backport")
|
||||
endif()
|
|
@ -12,7 +12,7 @@
|
|||
cd $(dirname $0) ; CWD=$(pwd)
|
||||
|
||||
PRGNAM=ledger
|
||||
VERSION=${VERSION:-3.2.1}
|
||||
VERSION=${VERSION:-3.3.2}
|
||||
BUILD=${BUILD:-2}
|
||||
TAG=${TAG:-_SBo}
|
||||
PKGTYPE=${PKGTYPE:-tgz}
|
||||
|
@ -51,7 +51,6 @@ find -L . \
|
|||
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
|
||||
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
|
||||
|
||||
patch -p1 < $CWD/CMakeLists.txt.patch
|
||||
patch -p1 < $CWD/boost-176.patch
|
||||
|
||||
# 20220301 bkw: do not look for utfcpp's headers in /usr/include, use
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
PRGNAM="ledger"
|
||||
VERSION="3.2.1"
|
||||
VERSION="3.3.2"
|
||||
HOMEPAGE="https://ledger-cli.org"
|
||||
DOWNLOAD="https://github.com/ledger/ledger/archive/v3.2.1/ledger-3.2.1.tar.gz"
|
||||
MD5SUM="4f82445bf8a39010e51b6367cf82c6d9"
|
||||
DOWNLOAD="https://github.com/ledger/ledger/archive/v3.3.2/ledger-3.3.2.tar.gz"
|
||||
MD5SUM="802bb7ed40be62bfbf68b70f15731f63"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
REQUIRES=""
|
||||
|
|
Loading…
Reference in a new issue