network/vimb: Updated for version 3.2.0.

Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
This commit is contained in:
Leonard Schmidt 2018-06-28 22:26:35 +01:00 committed by David Spencer
parent 00c06305c1
commit 2a7df0d587
4 changed files with 29 additions and 6 deletions

View file

@ -0,0 +1,11 @@
--- src/Makefile.orig 2018-06-28 04:21:53.000000000 +0200
+++ src/Makefile 2018-06-28 04:21:22.000000000 +0200
@@ -16,6 +16,8 @@
$(OBJ): config.h ../config.mk
+input.o: scripts/scripts.h
+
normal.o: scripts/scripts.h
setting.o: scripts/scripts.h

3
network/vimb/doinst.sh Normal file
View file

@ -0,0 +1,3 @@
if [ -x /usr/bin/update-desktop-database ]; then
/usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
fi

View file

@ -23,8 +23,8 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=vimb
VERSION=${VERSION:-3.1.0}
BUILD=${BUILD:-2}
VERSION=${VERSION:-3.2.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@ -69,7 +69,15 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
make PREFIX=/usr DESTDIR="$PKG" MANPREFIX=$PKG/usr/man DEXTENSIONDIR=$PKG/usr/lib/vimb install
patch -p0 < $CWD/Makefile.patch
make \
PREFIX=/usr \
DESTDIR="$PKG" \
MANPREFIX="$PKG"/usr/man \
LIBDIR="$PKG"/usr/lib${LIBDIRSUFFIX}/vimb \
EXTENSIONDIR=/usr/lib${LIBDIRSUFFIX}/vimb \
install
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
@ -79,6 +87,7 @@ for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; r
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}

View file

@ -1,8 +1,8 @@
PRGNAM="vimb"
VERSION="3.1.0"
VERSION="3.2.0"
HOMEPAGE="https://fanglingsu.github.io/vimb"
DOWNLOAD="https://github.com/fanglingsu/vimb/archive/3.1.0/vimb-3.1.0.tar.gz"
MD5SUM="52b28e286a2529407684d9f221279822"
DOWNLOAD="https://github.com/fanglingsu/vimb/archive/3.2.0/vimb-3.2.0.tar.gz"
MD5SUM="c0848041b6f6d618d5d4d0e169c1ea5c"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="webkit2gtk"