mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-22 19:44:21 +01:00
desktop/flatpak: Updated for version 1.6.2.
Signed-off-by: Vincent Batts <vbatts@hashbangbash.com>
This commit is contained in:
parent
8b9555e125
commit
2a155623e4
3 changed files with 5 additions and 39 deletions
|
@ -1,32 +0,0 @@
|
|||
From e3232bb3d0649f3fdce01091e1948fb8e906f9eb Mon Sep 17 00:00:00 2001
|
||||
From: Matthew Leeds <matthew.leeds@endlessm.com>
|
||||
Date: Mon, 3 Feb 2020 11:24:41 -0800
|
||||
Subject: [PATCH] portal: Add g_autoptr() defines for old GLib versions
|
||||
|
||||
We don't need to check for GLib 2.44 (the first release with g_autoptr()
|
||||
support) since Flatpak requires that version in configure.ac.
|
||||
|
||||
Fixes https://github.com/flatpak/flatpak/issues/3403
|
||||
---
|
||||
portal/flatpak-portal.c | 8 ++++++++
|
||||
1 file changed, 8 insertions(+)
|
||||
|
||||
diff --git a/portal/flatpak-portal.c b/portal/flatpak-portal.c
|
||||
index aa0d2d399..060987b7f 100644
|
||||
--- a/portal/flatpak-portal.c
|
||||
+++ b/portal/flatpak-portal.c
|
||||
@@ -50,6 +50,14 @@
|
||||
#include "portal-impl.h"
|
||||
#include "flatpak-permission-dbus.h"
|
||||
|
||||
+/* GLib 2.47.92 was the first release to define these in gdbus-codegen */
|
||||
+#if !GLIB_CHECK_VERSION (2, 47, 92)
|
||||
+G_DEFINE_AUTOPTR_CLEANUP_FUNC (PortalFlatpakProxy, g_object_unref)
|
||||
+G_DEFINE_AUTOPTR_CLEANUP_FUNC (PortalFlatpakSkeleton, g_object_unref)
|
||||
+G_DEFINE_AUTOPTR_CLEANUP_FUNC (PortalFlatpakUpdateMonitorProxy, g_object_unref)
|
||||
+G_DEFINE_AUTOPTR_CLEANUP_FUNC (PortalFlatpakUpdateMonitorSkeleton, g_object_unref)
|
||||
+#endif
|
||||
+
|
||||
#define IDLE_TIMEOUT_SECS 10 * 60
|
||||
|
||||
static GHashTable *client_pid_data_hash = NULL;
|
|
@ -23,8 +23,8 @@
|
|||
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
||||
|
||||
PRGNAM=flatpak
|
||||
VERSION=${VERSION:-1.6.1}
|
||||
BUILD=${BUILD:-2}
|
||||
VERSION=${VERSION:-1.6.2}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
if [ -z "$ARCH" ]; then
|
||||
|
@ -69,8 +69,6 @@ find -L . \
|
|||
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
|
||||
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
|
||||
|
||||
patch -p1 < $CWD/3405.patch
|
||||
|
||||
CFLAGS="$SLKCFLAGS" \
|
||||
CXXFLAGS="$SLKCFLAGS" \
|
||||
./configure \
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
PRGNAM="flatpak"
|
||||
VERSION="1.6.1"
|
||||
VERSION="1.6.2"
|
||||
HOMEPAGE="https://flatpak.org/"
|
||||
DOWNLOAD="https://github.com/flatpak/flatpak/releases/download/1.6.1/flatpak-1.6.1.tar.xz"
|
||||
MD5SUM="d417d90f7cc6bc871ac295e64a160fd0"
|
||||
DOWNLOAD="https://github.com/flatpak/flatpak/releases/download/1.6.2/flatpak-1.6.2.tar.xz"
|
||||
MD5SUM="59cd8b14f63164506e7891bba09afb97"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
REQUIRES="bubblewrap ostree appstream-glib json-glib libseccomp xdg-desktop-portal-gtk"
|
||||
|
|
Loading…
Reference in a new issue