mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-21 19:42:24 +01:00
system/set_rlimits: Initial import
This commit is contained in:
parent
1b81462a76
commit
29d89a1909
5 changed files with 115 additions and 0 deletions
29
system/set_rlimits/Makefile.patch
Normal file
29
system/set_rlimits/Makefile.patch
Normal file
|
@ -0,0 +1,29 @@
|
|||
--- Makefile 2007-04-22 14:18:21.000000000 -0400
|
||||
+++ Makefile.new 2007-04-22 14:31:49.000000000 -0400
|
||||
@@ -12,16 +12,16 @@
|
||||
gcc -Wall -g -o set_rlimits set_rlimits.c
|
||||
|
||||
install: set_rlimits
|
||||
- test -d $(PREFIX)/bin || mkdir -p $(PREFIX)/bin
|
||||
- test -d $(PREFIX)/man/man8 || mkdir -p $(PREFIX)/man/man8
|
||||
- test -d $(SYSCONFDIR) || mkdir -p $(SYSCONFDIR)
|
||||
- cp -p set_rlimits $(PREFIX)/bin/
|
||||
- chown root.root $(PREFIX)/bin/set_rlimits
|
||||
- chmod u+s $(PREFIX)/bin/set_rlimits
|
||||
- test -e $(SYSCONFDIR)/set_rlimits.conf || cp set_rlimits.conf $(SYSCONFDIR)/
|
||||
- chown root.root $(SYSCONFDIR)/set_rlimits.conf
|
||||
- cp -p set_rlimits.8 $(PREFIX)/man/man8/
|
||||
- chown root.root $(PREFIX)/man/man8/set_rlimits.8
|
||||
+ test -d $(DESTDIR)$(PREFIX)/bin || mkdir -p $(DESTDIR)$(PREFIX)/bin
|
||||
+ test -d $(DESTDIR)$(PREFIX)/man/man8 || mkdir -p $(DESTDIR)$(PREFIX)/man/man8
|
||||
+ test -d $(DESTDIR)$(SYSCONFDIR) || mkdir -p $(DESTDIR)$(SYSCONFDIR)
|
||||
+ cp -p set_rlimits $(DESTDIR)$(PREFIX)/bin/
|
||||
+ chown root.root $(DESTDIR)$(PREFIX)/bin/set_rlimits
|
||||
+ chmod u+s $(DESTDIR)$(PREFIX)/bin/set_rlimits
|
||||
+ test -e $(DESTDIR)$(SYSCONFDIR)/set_rlimits.conf || cp set_rlimits.conf $(DESTDIR)$(SYSCONFDIR)/
|
||||
+ chown root.root $(DESTDIR)$(SYSCONFDIR)/set_rlimits.conf
|
||||
+ cp -p set_rlimits.8 $(DESTDIR)$(PREFIX)/man/man8/
|
||||
+ chown root.root $(DESTDIR)$(PREFIX)/man/man8/set_rlimits.8
|
||||
|
||||
.PHONY: clean tidy
|
||||
|
8
system/set_rlimits/README
Normal file
8
system/set_rlimits/README
Normal file
|
@ -0,0 +1,8 @@
|
|||
This is a small program written to give unpriviledged users access to
|
||||
realtime scheduling via the new rlimits added to kernel 2.6.12. The
|
||||
new name reflects the fact that the program can control resource
|
||||
limits rather than just those related to realtime priorities.
|
||||
|
||||
set_rlimits was developed by Jonathan Woithe
|
||||
http://www.physics.adelaide.edu.au/~jwoithe/
|
||||
|
59
system/set_rlimits/set_rlimits.SlackBuild
Normal file
59
system/set_rlimits/set_rlimits.SlackBuild
Normal file
|
@ -0,0 +1,59 @@
|
|||
#!/bin/sh
|
||||
|
||||
# Slackware build script for set_rlimits 1.2.0
|
||||
# Slackbuild script by paul wisehart wise@lupulin.net
|
||||
|
||||
# Modified by the SlackBuilds Project
|
||||
|
||||
set -e
|
||||
|
||||
PKGNAME=set_rlimits
|
||||
VERSION=1.2.0
|
||||
ARCH=${ARCH:-i486}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
CWD=$(pwd)
|
||||
TMP=${TMP:-/tmp/SBo}
|
||||
PKG=$TMP/package-$PKGNAME
|
||||
OUTPUT=${OUTPUT:-/tmp}
|
||||
|
||||
if [ "$ARCH" = "i486" ]; then
|
||||
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
|
||||
elif [ "$ARCH" = "i686" ]; then
|
||||
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
|
||||
fi
|
||||
|
||||
rm -rf $PKG
|
||||
mkdir -p $TMP $PKG $OUTPUT
|
||||
cd $TMP
|
||||
rm -rf $PKGNAME-$VERSION
|
||||
tar xvzf $CWD/$PKGNAME-$VERSION.tgz || exit 1
|
||||
cd $PKGNAME-$VERSION || exit 1
|
||||
chown -R root:root .
|
||||
chmod -R u+w,go+r-w,a-s .
|
||||
|
||||
patch < ${CWD}/Makefile.patch || exit 1
|
||||
|
||||
make || exit 1
|
||||
make install PREFIX=/usr SYSCONFDIR=/etc DESTDIR=$PKG || exit 1
|
||||
|
||||
( cd $PKG
|
||||
find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
|
||||
find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
|
||||
)
|
||||
|
||||
mkdir -p $PKG/usr/doc/$PKGNAME-$VERSION
|
||||
cp -a AUTHORS COPYING Changelog README $PKG/usr/doc/$PKGNAME-$VERSION
|
||||
cat $CWD/$PKGNAME.SlackBuild > $PKG/usr/doc/$PKGNAME-$VERSION/$PKGNAME.SlackBuild
|
||||
|
||||
( cd $PKG/usr/man
|
||||
find . -type f -exec gzip -9 {} \;
|
||||
for i in `find . -type l` ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done )
|
||||
|
||||
mv $PKG/etc/set_rlimits.conf $PKG/etc/set_rlimits.conf.new
|
||||
|
||||
mkdir -p $PKG/install
|
||||
cat $CWD/slack-desc > $PKG/install/slack-desc
|
||||
|
||||
cd $PKG
|
||||
/sbin/makepkg -l y -c n $OUTPUT/$PKGNAME-$VERSION-$ARCH-$BUILD$TAG.tgz
|
8
system/set_rlimits/set_rlimits.info
Normal file
8
system/set_rlimits/set_rlimits.info
Normal file
|
@ -0,0 +1,8 @@
|
|||
PRGNAM="set_rlimits"
|
||||
VERSION="1.2.0"
|
||||
HOMEPAGE="http://www.physics.adelaide.edu.au/~jwoithe/"
|
||||
DOWNLOAD="http://www.physics.adelaide.edu.au/~jwoithe/set_rlimits-1.2.0.tgz"
|
||||
MD5SUM="b7385886aecbfb1c3a1631c93c7311d2"
|
||||
MAINTAINER="paul wisehart"
|
||||
EMAIL="wise@lupulin.net"
|
||||
APPROVED="BP{k}"
|
11
system/set_rlimits/slack-desc
Normal file
11
system/set_rlimits/slack-desc
Normal file
|
@ -0,0 +1,11 @@
|
|||
set_rlimits: set_rlimits
|
||||
set_rlimits:
|
||||
set_rlimits: This is a small program written to give unpriviledged users
|
||||
set_rlimits: access to realtime scheduling via the new rlimits added to
|
||||
set_rlimits: kernel 2.6.12. The new name reflects the fact that the program
|
||||
set_rlimits: can control resource limits rather than just those related to
|
||||
set_rlimits: realtime priorities.
|
||||
set_rlimits:
|
||||
set_rlimits: set_rlimits was developed by Jonathan Woithe
|
||||
set_rlimits: homepage: http://www.physics.adelaide.edu.au/~jwoithe/
|
||||
set_rlimits:
|
Loading…
Reference in a new issue