office/keepnote: Updated for version 0.6.2.

Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
This commit is contained in:
mccnews 2010-06-13 15:04:07 -05:00 committed by Robby Workman
parent ef3f670978
commit 28ac7ec060
6 changed files with 16 additions and 61 deletions

View file

@ -1,10 +1,8 @@
KeepNote is a note taking application. KeepNote is a note taking application.
With KeepNote, you can store your class notes, TODO lists, research notes, With KeepNote, you can store your class notes, TODO lists, research notes,
journal entries, paper outlines, etc in a simple notebook hierarchy journal entries, paper outlines, etc in a simple notebook hierarchy
with rich-text formatting, images, and more. Using full-text search, with rich-text formatting, images, and more. Using full-text search,
you can retrieve any note for later reference. you can retrieve any note for later reference.
KeepNote is implemented in Python and PyGTK To use spell checking (optional), you will need python-gnome2-extras.
To use spell checking (optional) you will need:
python-gnome2-extras

View file

@ -1,22 +0,0 @@
--- ./index_ori.py 2009-11-24 17:06:09.000000000 +0100
+++ ./index.py 2010-02-01 23:33:13.000000000 +0100
@@ -30,7 +30,18 @@
import sys
import traceback
from thread import get_ident
-import sqlite3 as sqlite
+#import sqlite3 as sqlite
+
+#modif mcc
+try:
+ import sqlite3 as sqlite
+except ImportError:
+ try:
+ from pysqlite2 import dbapi2 as sqlite
+ except ImportError:
+ raise ImportError, "no module sqlite3 or pysqlite2"
+
+
sqlite.enable_shared_cache(True)
#sqlite.threadsafety = 0

View file

@ -7,3 +7,4 @@ if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
/usr/bin/gtk-update-icon-cache usr/share/icons/hicolor >/dev/null 2>&1 /usr/bin/gtk-update-icon-cache usr/share/icons/hicolor >/dev/null 2>&1
fi fi
fi fi

View file

@ -24,16 +24,14 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=keepnote PRGNAM=keepnote
VERSION=0.6.1 VERSION=${VERSION:-0.6.2}
BUILD=${BUILD:-1} BUILD=${BUILD:-1}
TAG=${TAG:-_SBo} TAG=${TAG:-_SBo}
# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then if [ -z "$ARCH" ]; then
case "$( uname -m )" in case "$( uname -m )" in
i?86) ARCH=i486 ;; i?86) ARCH=i486 ;;
arm*) ARCH=arm ;; arm*) ARCH=arm ;;
# Unless $ARCH is already set, use uname -m for all other archs:
*) ARCH=$( uname -m ) ;; *) ARCH=$( uname -m ) ;;
esac esac
fi fi
@ -45,25 +43,12 @@ OUTPUT=${OUTPUT:-/tmp}
DOCS="CHANGES COPYING INSTALL LICENSE PKG-INFO README README.translations.txt" DOCS="CHANGES COPYING INSTALL LICENSE PKG-INFO README README.translations.txt"
if [ "$ARCH" = "i486" ]; then set -e
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
LIBDIRSUFFIX="64"
else
SLKCFLAGS="-O2"
LIBDIRSUFFIX=""
fi
set -e # Exit on most errors rm -fr $PKG
rm -fr $TMP/$PRGNAM-$VERSION $PKG
mkdir -p $TMP $PKG $OUTPUT mkdir -p $TMP $PKG $OUTPUT
cd $TMP cd $TMP
rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION cd $PRGNAM-$VERSION
chown -R root.root . chown -R root.root .
@ -73,22 +58,15 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \; -exec chmod 644 {} \;
# Correction for python without sqlite3
patch keepnote/notebook/index.py < $CWD/difsql1.patch
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
# Build
python setup.py install --root=$PKG python setup.py install --root=$PKG
# Add documentation
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh
# Make package
cd $PKG cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz} /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}

View file

@ -1,10 +1,10 @@
PRGNAM="keepnote" PRGNAM="keepnote"
VERSION="0.6.1" VERSION="0.6.2"
HOMEPAGE="http://rasm.ods.org/keepnote/" HOMEPAGE="http://rasm.ods.org/keepnote/"
DOWNLOAD="http://rasm.ods.org/keepnote/download/keepnote-0.6.1.tar.gz" DOWNLOAD="http://rasm.ods.org/keepnote/download/keepnote-0.6.2.tar.gz"
MD5SUM="3153159d83c26b26d14e6621fe7d99c1" MD5SUM="84b9edaa2dbd86f6fd4d78dd9d3c641d"
DOWNLOAD_x86_64="" DOWNLOAD_x86_64=""
MD5SUM_x86_64="" MD5SUM_x86_64=""
MAINTAINER="mccnews" MAINTAINER="mccnews"
EMAIL="mccnews@free.fr" EMAIL="mccnews@free.fr"
APPROVED="dsomero" APPROVED="rworkman"

View file

@ -13,7 +13,7 @@ keepnote: research notes, journal entries, paper outlines, etc in a simple
keepnote: notebook hierarchy with rich-text formatting, images, and more. keepnote: notebook hierarchy with rich-text formatting, images, and more.
keepnote: Using full-text search, you can retrieve any note keepnote: Using full-text search, you can retrieve any note
keepnote: for later reference. keepnote: for later reference.
keepnote: keepnote:
keepnote:
keepnote: Homepage: http://rasm.ods.org/keepnote/ keepnote: Homepage: http://rasm.ods.org/keepnote/
keepnote: keepnote:
keepnote: