mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-21 19:42:24 +01:00
academic/csparse: Updated for version 3.1.9.
Signed-off-by: Kyle Guinn <elyk03@gmail.com>
This commit is contained in:
parent
b11534756d
commit
2855967923
3 changed files with 21 additions and 17 deletions
|
@ -25,14 +25,14 @@
|
|||
PRGNAM=csparse
|
||||
SRCNAM=SuiteSparse
|
||||
SUBDIR=CSparse
|
||||
VERSION=${VERSION:-3.1.4}
|
||||
SRCVER=${SRCVER:-4.4.6}
|
||||
BUILD=${BUILD:-2}
|
||||
VERSION=${VERSION:-3.1.9}
|
||||
SRCVER=${SRCVER:-4.5.3}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
if [ -z "$ARCH" ]; then
|
||||
case "$(uname -m)" in
|
||||
i?86) ARCH=i486 ;;
|
||||
i?86) ARCH=i586 ;;
|
||||
arm*) ARCH=arm ;;
|
||||
*) ARCH=$(uname -m) ;;
|
||||
esac
|
||||
|
@ -48,6 +48,9 @@ DOCS="README.txt Doc/ChangeLog Doc/License.txt Doc/lesser.txt"
|
|||
if [ "$ARCH" = "i486" ]; then
|
||||
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
|
||||
LIBDIRSUFFIX=""
|
||||
elif [ "$ARCH" = "i586" ]; then
|
||||
SLKCFLAGS="-O2 -march=i586 -mtune=i686"
|
||||
LIBDIRSUFFIX=""
|
||||
elif [ "$ARCH" = "i686" ]; then
|
||||
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
|
||||
LIBDIRSUFFIX=""
|
||||
|
@ -73,10 +76,9 @@ cd $SRCNAM/$SUBDIR
|
|||
chown -R root:root .
|
||||
chmod -R u+w,go-w,a+rX-st .
|
||||
|
||||
patch -p1 < $CWD/autotoolize.diff
|
||||
patch -p1 < $CWD/patches/autotoolize.diff
|
||||
autoreconf -vif
|
||||
|
||||
CFLAGS="$SLKCFLAGS" \
|
||||
./configure \
|
||||
--prefix=/usr \
|
||||
--libdir=/usr/lib${LIBDIRSUFFIX} \
|
||||
|
@ -88,7 +90,8 @@ CFLAGS="$SLKCFLAGS" \
|
|||
--enable-shared \
|
||||
--disable-static \
|
||||
--disable-dependency-tracking \
|
||||
--build=$ARCH-slackware-linux
|
||||
--build=$ARCH-slackware-linux \
|
||||
CFLAGS="$SLKCFLAGS" \
|
||||
|
||||
make
|
||||
make check
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
PRGNAM="csparse"
|
||||
VERSION="3.1.4"
|
||||
VERSION="3.1.9"
|
||||
HOMEPAGE="http://faculty.cse.tamu.edu/davis/suitesparse.html"
|
||||
DOWNLOAD="http://faculty.cse.tamu.edu/davis/SuiteSparse/SuiteSparse-4.4.6.tar.gz"
|
||||
MD5SUM="131a3a5e2dee784cd946284e44ce9af2"
|
||||
DOWNLOAD="http://faculty.cse.tamu.edu/davis/SuiteSparse/SuiteSparse-4.5.3.tar.gz"
|
||||
MD5SUM="8ec57324585df3c6483ad7f556afccbd"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
REQUIRES=""
|
||||
|
|
|
@ -59,11 +59,10 @@ diff --git a/Makefile.am b/Makefile.am
|
|||
new file mode 100644
|
||||
--- /dev/null
|
||||
+++ b/Makefile.am
|
||||
@@ -0,0 +1,5 @@
|
||||
@@ -0,0 +1,4 @@
|
||||
+SUBDIRS = Include Source Matrix Demo
|
||||
+EXTRA_DIST = README.txt Doc/ChangeLog Doc/License.txt Doc/lesser.txt
|
||||
+
|
||||
+pkgconfigdir = $(libdir)/pkgconfig
|
||||
+pkgconfig_DATA = csparse.pc
|
||||
diff --git a/Matrix/Makefile.am b/Matrix/Makefile.am
|
||||
new file mode 100644
|
||||
|
@ -152,12 +151,12 @@ diff --git a/configure.ac b/configure.ac
|
|||
new file mode 100644
|
||||
--- /dev/null
|
||||
+++ b/configure.ac
|
||||
@@ -0,0 +1,40 @@
|
||||
@@ -0,0 +1,42 @@
|
||||
+# -*- Autoconf -*-
|
||||
+# Process this file with autoconf to produce a configure script.
|
||||
+
|
||||
+AC_PREREQ([2.69])
|
||||
+AC_INIT([CSparse],[3.1.4],[DrTimothyAldenDavis@gmail.com],[csparse],[http://www.suitesparse.com/])
|
||||
+AC_INIT([CSparse],[3.1.9],[DrTimothyAldenDavis@gmail.com],[csparse],[http://www.suitesparse.com/])
|
||||
+AC_CONFIG_SRCDIR([Source/cs_print.c])
|
||||
+AC_CONFIG_HEADERS([config.h])
|
||||
+AM_INIT_AUTOMAKE([foreign])
|
||||
|
@ -167,7 +166,7 @@ new file mode 100644
|
|||
+AC_PROG_INSTALL
|
||||
+AC_PROG_CC
|
||||
+
|
||||
+LIBS_SAVED=$LIBS
|
||||
+AS_VAR_SET([LIBS_SAVED], [$LIBS])
|
||||
+
|
||||
+# Checks for libraries.
|
||||
+AC_CHECK_LIB([m], [sqrt])
|
||||
|
@ -183,15 +182,17 @@ new file mode 100644
|
|||
+AC_FUNC_REALLOC
|
||||
+AC_CHECK_FUNCS([sqrt])
|
||||
+
|
||||
+LIBS=$LIBS_SAVED
|
||||
+AS_VAR_SET([LIBS], [$LIBS_SAVED])
|
||||
+
|
||||
+PKG_INSTALLDIR
|
||||
+AC_CONFIG_FILES([
|
||||
+ csparse.pc
|
||||
+ Makefile
|
||||
+ Demo/Makefile
|
||||
+ Include/Makefile
|
||||
+ Matrix/Makefile
|
||||
+ Source/Makefile])
|
||||
+ Source/Makefile
|
||||
+])
|
||||
+AC_OUTPUT
|
||||
diff --git a/csparse.pc.in b/csparse.pc.in
|
||||
new file mode 100644
|
Loading…
Reference in a new issue