mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-18 22:06:04 +01:00
audio/TiMidity++: Misc tweaks including +jack +speex -arts
For clarity's sake, this commit adds jack and speex support, removes artsd support, and has various other minor cleanups. Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
This commit is contained in:
parent
3ea4389ecf
commit
28091409e5
4 changed files with 65 additions and 9 deletions
|
@ -1,11 +1,17 @@
|
||||||
TiMidity++ is a software synthesizer. It can play MIDI files by converting
|
TiMidity++ is a software synthesizer. It can play MIDI files by converting
|
||||||
them into PCM waveform data or other various audio file formats.
|
them into PCM waveform data or other various audio file formats.
|
||||||
|
|
||||||
|
To add JACK support, install jack-audio-connection-kit and build with:
|
||||||
|
JACK=yes ./TiMidity++.SlackBuild
|
||||||
|
|
||||||
|
To add speex support, install speex and build with:
|
||||||
|
SPEEX=yes ./TiMidity++.SlackBuild
|
||||||
|
|
||||||
TiMidity++ can also be run as an ALSA sequencer client. To do this, make
|
TiMidity++ can also be run as an ALSA sequencer client. To do this, make
|
||||||
/etc/rc.d/rc.timidity executable and add this line to /etc/rc.d/rc.local:
|
/etc/rc.d/rc.timidity executable and add this line to /etc/rc.d/rc.local:
|
||||||
|
|
||||||
/etc/rc.d/rc.timidity start
|
/etc/rc.d/rc.timidity start
|
||||||
|
|
||||||
You will need a set of instrument patch files for TiMidity++ to be of any
|
You will need a set of instrument patch files for TiMidity++ to be of any
|
||||||
use. The freepats and eawpats packages, also available at SlackBuilds.org,
|
use. The freepats and eawpats packages both provide a set of patch files,
|
||||||
both provide a set of patch files.
|
so one of those will be needed.
|
||||||
|
|
|
@ -2,21 +2,18 @@
|
||||||
|
|
||||||
# Slackware build script for TiMidity++
|
# Slackware build script for TiMidity++
|
||||||
# Written by Kyle Guinn <elyk03@gmail.com>
|
# Written by Kyle Guinn <elyk03@gmail.com>
|
||||||
|
|
||||||
# Changes for Slackware 12.1 by Richard Hoyle <hoyle.richard@gmail.com>
|
# Changes for Slackware 12.1 by Richard Hoyle <hoyle.richard@gmail.com>
|
||||||
# Modified by Michiel van Wessem. <michiel.van.wessem@gmail.com>
|
# Modified by Michiel van Wessem. <michiel.van.wessem@gmail.com>
|
||||||
|
|
||||||
PRGNAM="TiMidity++"
|
PRGNAM="TiMidity++"
|
||||||
VERSION="2.13.2"
|
VERSION="2.13.2"
|
||||||
BUILD=${BUILD:-4}
|
BUILD=${BUILD:-5}
|
||||||
TAG=${TAG:-_SBo}
|
TAG=${TAG:-_SBo}
|
||||||
|
|
||||||
# Automatically determine the architecture we're building on:
|
|
||||||
if [ -z "$ARCH" ]; then
|
if [ -z "$ARCH" ]; then
|
||||||
case "$( uname -m )" in
|
case "$( uname -m )" in
|
||||||
i?86) ARCH=i486 ;;
|
i?86) ARCH=i486 ;;
|
||||||
arm*) ARCH=arm ;;
|
arm*) ARCH=arm ;;
|
||||||
# Unless $ARCH is already set, use uname -m for all other archs:
|
|
||||||
*) ARCH=$( uname -m ) ;;
|
*) ARCH=$( uname -m ) ;;
|
||||||
esac
|
esac
|
||||||
fi
|
fi
|
||||||
|
@ -27,6 +24,21 @@ PKG=$TMP/package-$PRGNAM-$VERSION
|
||||||
OUTPUT=${OUTPUT:-/tmp}
|
OUTPUT=${OUTPUT:-/tmp}
|
||||||
|
|
||||||
DOCS="AUTHORS COPYING ChangeLog* INSTALL* NEWS README* TODO doc/C/README* doc/C/FAQ doc/C/CHANGES.02i"
|
DOCS="AUTHORS COPYING ChangeLog* INSTALL* NEWS README* TODO doc/C/README* doc/C/FAQ doc/C/CHANGES.02i"
|
||||||
|
ENABLE_AUDIO="alsa,oss,esd,ao,vorbis,flac"
|
||||||
|
ENABLE_DYNAMIC="gtk,ncurses,motif,tcltk,emacs,vt100"
|
||||||
|
|
||||||
|
# Support JACK. Requires JACK, of course.
|
||||||
|
# Disabled by default for those who don't want to install/configure it.
|
||||||
|
JACK=${JACK:-no}
|
||||||
|
if [ "$JACK" = "yes" ]; then
|
||||||
|
ENABLE_AUDIO="$ENABLE_AUDIO,jack"
|
||||||
|
fi
|
||||||
|
|
||||||
|
# Support speex. Also disabled by default.
|
||||||
|
SPEEX=${SPEEX:-no}
|
||||||
|
if [ "$SPEEX" = "yes" ]; then
|
||||||
|
ENABLE_AUDIO="$ENABLE_AUDIO,speex"
|
||||||
|
fi
|
||||||
|
|
||||||
if [ "$ARCH" = "i486" ]; then
|
if [ "$ARCH" = "i486" ]; then
|
||||||
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
|
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
|
||||||
|
@ -78,8 +90,8 @@ EXTRACFLAGS="$SLKCFLAGS" \
|
||||||
--mandir=/usr/man \
|
--mandir=/usr/man \
|
||||||
--docdir=/usr/doc/$PRGNAM-$VERSION \
|
--docdir=/usr/doc/$PRGNAM-$VERSION \
|
||||||
--with-module-dir=/usr/lib${LIBDIRSUFFIX}/timidity \
|
--with-module-dir=/usr/lib${LIBDIRSUFFIX}/timidity \
|
||||||
--enable-audio=alsa,oss,arts,esd,ao,vorbis,flac \
|
--enable-audio=${ENABLE_AUDIO} \
|
||||||
--enable-dynamic=gtk,ncurses,motif,tcltk,emacs,vt100 \
|
--enable-dynamic=${ENABLE_DYNAMIC} \
|
||||||
--enable-alsaseq \
|
--enable-alsaseq \
|
||||||
--enable-server \
|
--enable-server \
|
||||||
--enable-network \
|
--enable-network \
|
||||||
|
|
|
@ -7,4 +7,4 @@ DOWNLOAD_x86_64=""
|
||||||
MD5SUM_x86_64=""
|
MD5SUM_x86_64=""
|
||||||
MAINTAINER="Kyle Guinn"
|
MAINTAINER="Kyle Guinn"
|
||||||
EMAIL="elyk03@gmail.com"
|
EMAIL="elyk03@gmail.com"
|
||||||
APPROVED="Erik Hanson"
|
APPROVED="rworkman"
|
||||||
|
|
38
audio/TiMidity++/patches/speex.diff
Normal file
38
audio/TiMidity++/patches/speex.diff
Normal file
|
@ -0,0 +1,38 @@
|
||||||
|
diff --git a/configure b/configure
|
||||||
|
--- a/configure
|
||||||
|
+++ b/configure
|
||||||
|
@@ -14785,7 +14785,7 @@
|
||||||
|
cat >>conftest.$ac_ext <<_ACEOF
|
||||||
|
/* end confdefs.h. */
|
||||||
|
|
||||||
|
- #include <speex.h>
|
||||||
|
+ #include <speex/speex.h>
|
||||||
|
#include <ogg/ogg.h>
|
||||||
|
|
||||||
|
int
|
||||||
|
diff --git a/configure.in b/configure.in
|
||||||
|
--- a/configure.in
|
||||||
|
+++ b/configure.in
|
||||||
|
@@ -1230,7 +1230,7 @@
|
||||||
|
if test "x$au_enable_speex" = xyes; then
|
||||||
|
AC_CACHE_VAL(have_speex,
|
||||||
|
[AC_TRY_LINK([
|
||||||
|
- #include <speex.h>
|
||||||
|
+ #include <speex/speex.h>
|
||||||
|
#include <ogg/ogg.h>
|
||||||
|
],
|
||||||
|
[
|
||||||
|
diff --git a/timidity/speex_a.c b/timidity/speex_a.c
|
||||||
|
--- a/timidity/speex_a.c
|
||||||
|
+++ b/timidity/speex_a.c
|
||||||
|
@@ -33,8 +33,8 @@
|
||||||
|
#include <fcntl.h>
|
||||||
|
#endif
|
||||||
|
|
||||||
|
-#include <speex.h>
|
||||||
|
-#include <speex_header.h>
|
||||||
|
+#include <speex/speex.h>
|
||||||
|
+#include <speex/speex_header.h>
|
||||||
|
#include <ogg/ogg.h>
|
||||||
|
|
||||||
|
#include "timidity.h"
|
Loading…
Reference in a new issue