mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-22 19:44:21 +01:00
development/sdcc: Updated for version 4.3.0
Signed-off-by: Kyle Guinn <elyk03@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
parent
c7f71aab98
commit
25f32fbdf9
3 changed files with 12 additions and 10 deletions
|
@ -1,7 +1,7 @@
|
|||
diff --git a/device/lib/Makefile.in b/device/lib/Makefile.in
|
||||
--- a/device/lib/Makefile.in
|
||||
+++ b/device/lib/Makefile.in
|
||||
@@ -649,19 +649,11 @@
|
||||
@@ -661,19 +661,11 @@
|
||||
$(CP_U) -r $(MODELS) mcs51 ds390 ds400 z80 z180 ez80_z80 z80n r2k r2ka r3ka tlcs90 sm83 hc08 s08 stm8 pdk13 pdk14 pdk15 $(sdcc_libdir)/src
|
||||
|
||||
for src in $(MODELS) ds390 ds400 z80 z180 ez80_z80 z80n r2k r2ka r3ka tlcs90 sm83 hc08 s08 mos6502 mos65c02 stm8 pdk13 pdk14 pdk15 pic14 pic16; do \
|
||||
|
|
|
@ -2,7 +2,7 @@
|
|||
|
||||
# Slackware build script for sdcc
|
||||
|
||||
# Copyright 2014-2022 Kyle Guinn <elyk03@gmail.com>
|
||||
# Copyright 2014-2023 Kyle Guinn <elyk03@gmail.com>
|
||||
# All rights reserved.
|
||||
#
|
||||
# Redistribution and use of this script, with or without modification, is
|
||||
|
@ -25,7 +25,7 @@
|
|||
cd $(dirname $0) ; CWD=$(pwd)
|
||||
|
||||
PRGNAM=sdcc
|
||||
VERSION=${VERSION:-4.2.0}
|
||||
VERSION=${VERSION:-4.3.0}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
PKGTYPE=${PKGTYPE:-tgz}
|
||||
|
@ -98,12 +98,12 @@ ARCH= \
|
|||
EARCH= \
|
||||
./configure \
|
||||
--prefix=/usr \
|
||||
--libdir=/usr/lib${LIBDIRSUFFIX}/$PRGNAM \
|
||||
--libdir=\${exec_prefix}/lib${LIBDIRSUFFIX}/$PRGNAM \
|
||||
--sysconfdir=/etc \
|
||||
--localstatedir=/var \
|
||||
--mandir=/usr/man \
|
||||
--infodir=/usr/info \
|
||||
--docdir=/usr/doc/$PRGNAM-$VERSION \
|
||||
--mandir=\${prefix}/man \
|
||||
--infodir=\${prefix}/info \
|
||||
--docdir=\${prefix}/doc/$PRGNAM-$VERSION \
|
||||
--enable-libgc \
|
||||
$enable_doc \
|
||||
$enable_pic \
|
||||
|
@ -117,6 +117,8 @@ make install DESTDIR=$PKG
|
|||
find $PKG -exec file {} + | grep -e "executable" -e "shared object" | grep ELF \
|
||||
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
|
||||
|
||||
find $PKG/usr/man -type f -exec gzip -9 {} +
|
||||
|
||||
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cp -a sdas/doc $PKG/usr/doc/$PRGNAM-$VERSION/sdas
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
PRGNAM="sdcc"
|
||||
VERSION="4.2.0"
|
||||
VERSION="4.3.0"
|
||||
HOMEPAGE="http://sdcc.sourceforge.net/"
|
||||
DOWNLOAD="https://sourceforge.net/projects/sdcc/files/sdcc/4.2.0/sdcc-src-4.2.0.tar.bz2"
|
||||
MD5SUM="cc5042a207b15c387185867ca1b32145"
|
||||
DOWNLOAD="https://sourceforge.net/projects/sdcc/files/sdcc/4.3.0/sdcc-src-4.3.0.tar.bz2"
|
||||
MD5SUM="799a1c0b906a016aca96ef0c1733d831"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
REQUIRES=""
|
||||
|
|
Loading…
Reference in a new issue