mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-16 19:50:19 +01:00
development/qt-creator: Updated for version 4.12.3.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
parent
d941d20990
commit
23a5e73b82
4 changed files with 57 additions and 24 deletions
16
development/qt-creator/add-mime-types.patch
Normal file
16
development/qt-creator/add-mime-types.patch
Normal file
|
@ -0,0 +1,16 @@
|
||||||
|
--- share/applications/org.qt-project.qtcreator.desktop 2020-03-27 04:34:53.000000000 +0100
|
||||||
|
+++ share/applications/org.qt-project.qtcreator.desktop 2020-04-10 18:27:44.756614495 +0200
|
||||||
|
@@ -2,11 +2,10 @@
|
||||||
|
Type=Application
|
||||||
|
Exec=qtcreator %F
|
||||||
|
Name=Qt Creator
|
||||||
|
-GenericName=C++ IDE for developing Qt applications
|
||||||
|
+GenericName=C/C++ and Qt IDE
|
||||||
|
X-KDE-StartupNotify=true
|
||||||
|
Icon=QtProject-qtcreator
|
||||||
|
StartupWMClass=qtcreator
|
||||||
|
Terminal=false
|
||||||
|
Categories=Development;IDE;Qt;
|
||||||
|
-MimeType= text/x-c++src;text/x-c++hdr;text/x-xsrc;application/x-designer;application/vnd.qt.qmakeprofile;application/vnd.qt.xml.resource;
|
||||||
|
-
|
||||||
|
+MimeType=text/x-csrc;text/x-c++src;text/x-c++hdr;text/x-xsrc;text/x-python;application/x-designer;application/vnd.qt.qmakeprofile;application/vnd.qt.xml.resource;
|
|
@ -3,7 +3,7 @@
|
||||||
# Slackware build script for Qt Creator
|
# Slackware build script for Qt Creator
|
||||||
|
|
||||||
# Copyright 2016 Andre Barboza, Belo Horizonte - Brazil
|
# Copyright 2016 Andre Barboza, Belo Horizonte - Brazil
|
||||||
# Copyright 2019 Andrzej Telszewski, Szczecin
|
# Copyright 2020 Andrzej Telszewski, Szczecin
|
||||||
# All rights reserved.
|
# All rights reserved.
|
||||||
#
|
#
|
||||||
# Redistribution and use of this script, with or without modification, is
|
# Redistribution and use of this script, with or without modification, is
|
||||||
|
@ -27,7 +27,7 @@
|
||||||
# VERSION=4.2.0_rc1 or VERSION=4.2.0_beta1 (note the underscore).
|
# VERSION=4.2.0_rc1 or VERSION=4.2.0_beta1 (note the underscore).
|
||||||
|
|
||||||
PRGNAM=qt-creator
|
PRGNAM=qt-creator
|
||||||
VERSION=${VERSION:-4.9.2}
|
VERSION=${VERSION:-4.12.3}
|
||||||
SRCVER=$(echo $VERSION | tr _ -)
|
SRCVER=$(echo $VERSION | tr _ -)
|
||||||
BUILD=${BUILD:-1}
|
BUILD=${BUILD:-1}
|
||||||
TAG=${TAG:-_SBo}
|
TAG=${TAG:-_SBo}
|
||||||
|
@ -64,52 +64,66 @@ set -e
|
||||||
rm -rf $PKG
|
rm -rf $PKG
|
||||||
mkdir -p $TMP $PKG $OUTPUT
|
mkdir -p $TMP $PKG $OUTPUT
|
||||||
cd $TMP
|
cd $TMP
|
||||||
|
|
||||||
rm -rf $PRGNAM-$SRCVER
|
rm -rf $PRGNAM-$SRCVER
|
||||||
tar xvf $CWD/$PRGNAM-opensource-src-$SRCVER.tar.gz
|
tar xvf $CWD/$PRGNAM-opensource-src-$SRCVER.tar.gz
|
||||||
mv $PRGNAM-opensource-src-$SRCVER $PRGNAM-$SRCVER
|
mv $PRGNAM-opensource-src-$SRCVER $PRGNAM-$SRCVER
|
||||||
cd $PRGNAM-$SRCVER
|
cd $PRGNAM-$SRCVER
|
||||||
|
|
||||||
chown -R root:root .
|
chown -R root:root .
|
||||||
find -L . \
|
chmod -R a-st,u+rwX,go-w+rX .
|
||||||
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
|
|
||||||
-o -perm 511 \) -exec chmod 755 {} \; -o \
|
|
||||||
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
|
|
||||||
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
|
|
||||||
|
|
||||||
# Adjust docs location.
|
# Adjust docs location.
|
||||||
sed -i "s|share/doc/qtcreator|doc/$PRGNAM-$VERSION|g" qtcreator.pri
|
|
||||||
sed -i "s|share/doc/qtcreator|doc/$PRGNAM-$VERSION|g" doc/api/qtcreator-documentation.qdoc
|
sed -i "s|share/doc/qtcreator|doc/$PRGNAM-$VERSION|g" qtcreator.pri
|
||||||
sed -i "s|share/doc/qtcreator|doc/$PRGNAM-$VERSION|g" src/plugins/coreplugin/icore.cpp
|
sed -i "s|share/doc/qtcreator|doc/$PRGNAM-$VERSION|g" doc/qtcreatordev/src/qtcreator-documentation.qdoc
|
||||||
|
sed -i "s|share/doc/\${IDE_ID}|doc/$PRGNAM-$VERSION|g" cmake/QtCreatorAPI.cmake
|
||||||
|
|
||||||
# LLVM/Clang can be used to extend Qt Creator functionality.
|
# LLVM/Clang can be used to extend Qt Creator functionality.
|
||||||
if [ "${USE_LLVM:-no}" = yes -o "${CODE_MODEL:-no}" = "yes" ]; then
|
|
||||||
|
if [ "${USE_LLVM:-no}" = yes ] || [ "${CODE_MODEL:-no}" = "yes" ]; then
|
||||||
LLVM_INSTALL_ROOT=/usr/libexec/qtcreator/clang
|
LLVM_INSTALL_ROOT=/usr/libexec/qtcreator/clang
|
||||||
QMAKE_LFLAGS=-L${LLVM_INSTALL_ROOT}/lib
|
QMAKE_LFLAGS=-L${LLVM_INSTALL_ROOT}/lib
|
||||||
|
export QTC_ENABLE_CLANG_LIBTOOLING=1
|
||||||
|
|
||||||
if [ ! -x $LLVM_INSTALL_ROOT/bin/clang ]; then
|
if [ ! -x ${LLVM_INSTALL_ROOT}/bin/clang ]; then
|
||||||
echo "error: You must install \"qt-creator-llvm\" package in order to"
|
echo "error: You must install \"qt-creator-llvm\" package in order to"
|
||||||
echo "error: use LLVM/Clang tools integration."
|
echo "error: use LLVM/Clang tools integration."
|
||||||
|
|
||||||
exit 1
|
exit 1
|
||||||
fi
|
fi
|
||||||
fi
|
fi
|
||||||
|
|
||||||
|
# -Wunguarded-availability-new is not supported.
|
||||||
|
|
||||||
patch -p0 < $CWD/remove-w-error-unguarded-availability-new.patch
|
patch -p0 < $CWD/remove-w-error-unguarded-availability-new.patch
|
||||||
|
|
||||||
|
# Tell DEs that Qt Creator supports some more MIME types.
|
||||||
|
|
||||||
|
patch -p0 < $CWD/add-mime-types.patch
|
||||||
|
|
||||||
# Fix for https://lists.qt-project.org/pipermail/qt-creator/2019-May/008050.html
|
# Fix for https://lists.qt-project.org/pipermail/qt-creator/2019-May/008050.html
|
||||||
|
|
||||||
QMAKE_LFLAGS="$QMAKE_LFLAGS -L/usr/lib$LIBDIRSUFFIX"
|
QMAKE_LFLAGS="$QMAKE_LFLAGS -L/usr/lib$LIBDIRSUFFIX"
|
||||||
|
|
||||||
qmake-qt5 -r qtcreator.pro \
|
qmake-qt5 -r qtcreator.pro \
|
||||||
QMAKE_CXXFLAGS="$SLKCFLAGS" \
|
QMAKE_CXXFLAGS="$SLKCFLAGS" \
|
||||||
QMAKE_LFLAGS="$QMAKE_LFLAGS" \
|
QMAKE_LFLAGS="$QMAKE_LFLAGS" \
|
||||||
QTC_PREFIX=/usr \
|
QTC_PREFIX=/usr \
|
||||||
IDE_LIBRARY_BASENAME=lib$LIBDIRSUFFIX \
|
IDE_LIBRARY_BASENAME=lib$LIBDIRSUFFIX \
|
||||||
LLVM_INSTALL_DIR=$LLVM_INSTALL_ROOT \
|
LLVM_INSTALL_DIR=$LLVM_INSTALL_ROOT \
|
||||||
QBS_INSTALL_DIR=/usr \
|
QBS_INSTALL_DIR=/usr \
|
||||||
DEFINES+=QBS_ENABLE_PROJECT_FILE_UPDATES
|
DEFINES+=QBS_ENABLE_PROJECT_FILE_UPDATES
|
||||||
|
|
||||||
make
|
make
|
||||||
make install INSTALL_ROOT=$PKG
|
make install INSTALL_ROOT=$PKG
|
||||||
make docs
|
|
||||||
make install_docs INSTALL_ROOT=$PKG
|
if which qdoc-qt5 &>/dev/null; then
|
||||||
|
make docs
|
||||||
|
make install_docs INSTALL_ROOT=$PKG
|
||||||
|
else
|
||||||
|
echo "qdoc-qt5 not found. Docs won't be built nor installed."
|
||||||
|
fi
|
||||||
|
|
||||||
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
|
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
|
||||||
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
|
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
|
||||||
|
|
|
@ -1,8 +1,8 @@
|
||||||
PRGNAM="qt-creator"
|
PRGNAM="qt-creator"
|
||||||
VERSION="4.9.2"
|
VERSION="4.12.3"
|
||||||
HOMEPAGE="https://wiki.qt.io/Qt_Creator"
|
HOMEPAGE="https://wiki.qt.io/Qt_Creator"
|
||||||
DOWNLOAD="https://download.qt.io/official_releases/qtcreator/4.9/4.9.2/qt-creator-opensource-src-4.9.2.tar.gz"
|
DOWNLOAD="https://download.qt.io/official_releases/qtcreator/4.12/4.12.3/qt-creator-opensource-src-4.12.3.tar.gz"
|
||||||
MD5SUM="c226740c66cb7cb231180d4cbe572cbd"
|
MD5SUM="7ee294ef4316875a355c43f62918e13f"
|
||||||
DOWNLOAD_x86_64=""
|
DOWNLOAD_x86_64=""
|
||||||
MD5SUM_x86_64=""
|
MD5SUM_x86_64=""
|
||||||
REQUIRES="qbs"
|
REQUIRES="qbs"
|
||||||
|
|
|
@ -3,7 +3,10 @@
|
||||||
<mime-type type="application/x-qt-creator">
|
<mime-type type="application/x-qt-creator">
|
||||||
<sub-class-of type="text/plain"/>
|
<sub-class-of type="text/plain"/>
|
||||||
<comment>Qt Creator Project</comment>
|
<comment>Qt Creator Project</comment>
|
||||||
|
<glob pattern="*.creator"/>
|
||||||
<glob pattern="*.pro"/>
|
<glob pattern="*.pro"/>
|
||||||
|
<glob pattern="*.pyproject"/>
|
||||||
|
<glob pattern="*.pyqtc"/>
|
||||||
<glob pattern="*.qbs"/>
|
<glob pattern="*.qbs"/>
|
||||||
</mime-type>
|
</mime-type>
|
||||||
</mime-info>
|
</mime-info>
|
||||||
|
|
Loading…
Reference in a new issue