games/neverball: Make flags added. Make patch removed.

Signed-off-by: bedlam <dave@slackbuilds.org>

Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
Johannes Schoepfer 2023-04-21 01:43:13 +01:00 committed by Willy Sudiarto Raharjo
parent 2d2c304598
commit 2382f374fe
No known key found for this signature in database
GPG key ID: 3F617144D7238786
2 changed files with 15 additions and 29 deletions

View file

@ -1,12 +0,0 @@
diff -Naur neverball-1.6.0.orig/Makefile neverball-1.6.0/Makefile
--- neverball-1.6.0.orig/Makefile 2014-05-21 15:21:43.000000000 +0200
+++ neverball-1.6.0/Makefile 2015-04-23 04:30:07.093366557 +0200
@@ -21,7 +21,7 @@
# Paths (packagers might want to set DATADIR and LOCALEDIR)
USERDIR := .neverball
-DATADIR := ./data
+DATADIR := /usr/share/neverball/data
LOCALEDIR := ./locale
ifeq ($(PLATFORM),mingw)

View file

@ -2,11 +2,11 @@
# Slackware build script for Neverball
# Copyright 2007-2009 Frank Caraballo <fecaraballo{at}gmail{dot}com>
# Copyright 2007-2009 Frank Caraballo
# Modified by Brad Hermanson
# Copyright 2023 Johannes Schoepfer, Germany
# All rights reserved.
#
# Modified by Brad Hermanson <apeitheo@gmail.com>
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
#
@ -41,9 +41,6 @@ if [ -z "$ARCH" ]; then
esac
fi
# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
# the name of the created package would be, and then exit. This information
# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@ -84,21 +81,19 @@ find -L . \
patch -p1 < $CWD/gcc10.patch
# Patch Makefile to change data directory and to make it compile
# with appropriate flags
patch -p1 < $CWD/Makefile.diff || exit 1
make CFLAGS="$SLKCFLAGS" || exit 1
make LOCALEDIR=/usr/share/locale DATADIR=/usr/share/$PRGNAM \
CPPFLAGS="$SLKCFLAGS -DNDEBUG" CFLAGS="$SLKCFLAGS"
# Fix map permissions that were created by mapc during compile
find data/ -name '*.sol' -exec chmod 644 {} \;
find data/ -name '*.sol' -exec chmod 644 {} +
# Delete the .map files that are no longer required
find data/ -name '*.map' -exec rm {} \;
find data/ -name '*.map' -exec rm {} +
mkdir -p $PKG/usr/{bin,share/$PRGNAM}
cp -a mapc $PRGNAM $BONUS $PKG/usr/bin || exit 1
cp -a data/ $PKG/usr/share/$PRGNAM || exit 1
cp -a mapc $PRGNAM $BONUS $PKG/usr/bin
cp -a data/* $PKG/usr/share/$PRGNAM
cp -a locale $PKG/usr/share/
( cd dist
for i in $PRGNAM $BONUS ; do
@ -112,7 +107,9 @@ cp -a data/ $PKG/usr/share/$PRGNAM || exit 1
install -D -m 0644 ${i}_256.png $PKG/usr/share/icons/hicolor/256x256/apps/$i.png
install -D -m 0644 ${i}_512.png $PKG/usr/share/icons/hicolor/512x512/apps/$i.png
done
cp -a ${PRGNAM}_replay.png $PKG/usr/share/icons/hicolor/48x48/apps/${PRGNAM}_replay.png
# fix png icon size
convert ${PRGNAM}_replay.png -resize 48x48\! \
$PKG/usr/share/icons/hicolor/48x48/apps/${PRGNAM}_replay.png
install -D -m 0644 neverlogos.svg $PKG/usr/share/icons/hicolor/scalable/apps/neverlogos.svg
install -D -m 0644 mapc.1 $PKG/usr/man/man1/mapc.1
install -D -m 0644 $PRGNAM.6 $PKG/usr/man/man6/$PRGNAM.6
@ -126,7 +123,8 @@ find $PKG/usr/man -type f -exec gzip -9 {} \;
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a LICENSE.md README.md doc/* $PKG/usr/doc/$PRGNAM-$VERSION
cp -a LICENSE.md README.md doc/{authors.txt,changes.txt,manual.txt,release-notes.md} \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install