graphics/fontmatrix: fix build

Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
Larry Hajali 2016-02-07 10:49:47 -08:00 committed by Willy Sudiarto Raharjo
parent 0898924fcc
commit 2355494a80
3 changed files with 51 additions and 12 deletions

View file

@ -1,11 +0,0 @@
diff -Naur fontmatrix-0.6.0-Source.orig/cmake/modules/FindLIBPODOFO.cmake fontmatrix-0.6.0-Source/cmake/modules/FindLIBPODOFO.cmake
--- fontmatrix-0.6.0-Source.orig/cmake/modules/FindLIBPODOFO.cmake 2009-07-03 15:26:41.000000000 +0000
+++ fontmatrix-0.6.0-Source/cmake/modules/FindLIBPODOFO.cmake 2009-07-04 02:15:14.000000000 +0000
@@ -32,6 +32,7 @@
"${LIBPODOFO_DIR}/src"
"${LIBPODOFO_DIR}"
/usr/lib /usr/local/lib
+ /usr/lib64 /usr/local/lib64
)
IF(LIBPODOFO_INCLUDE_DIR AND LIBPODOFO_LIBRARY)

View file

@ -0,0 +1,47 @@
diff -ur old.fontmatrix-0.9.99-Source/src/icushaper.cpp fontmatrix-0.9.99-Source/src/icushaper.cpp
--- old.fontmatrix-0.9.99-Source/src/icushaper.cpp 2011-10-03 08:02:54.369203955 +0200
+++ fontmatrix-0.9.99-Source/src/icushaper.cpp 2015-10-29 12:58:30.806886446 +0100
@@ -248,7 +248,7 @@
}
-const void * IcuFontImpl::getFontTable ( LETag tableTag ) const
+const void * IcuFontImpl::getFontTable ( LETag tableTag, size_t &olength ) const
{
// qDebug()<< "IcuFontImpl::getFontTable" << OTF_tag_name( tableTag );
FT_Face face ( otf->face() );
@@ -263,13 +263,21 @@
FT_Load_Sfnt_Table ( face, tableTag, 0, bA, &length );
regTables( tableTag, bA );
+ olength = length;
return (const void*) tables.value(tableTag);
}
}
+ olength = length;
return 0;
}
+const void * IcuFontImpl::getFontTable ( LETag tableTag ) const
+{
+ size_t length(0);
+ return getFontTable( tableTag, length);
+}
+
le_int32 IcuFontImpl::getUnitsPerEM() const
{
return otf->face()->units_per_EM;
diff -ur old.fontmatrix-0.9.99-Source/src/icushaper.h fontmatrix-0.9.99-Source/src/icushaper.h
--- old.fontmatrix-0.9.99-Source/src/icushaper.h 2011-10-03 08:02:54.363203913 +0200
+++ fontmatrix-0.9.99-Source/src/icushaper.h 2015-10-29 12:55:57.983050904 +0100
@@ -27,7 +27,8 @@
~IcuFontImpl();
// implements pure virtual methods of LEFontInstance
- const void* getFontTable(LETag tableTag ) const;
+ const void* getFontTable(LETag tableTag, size_t &length ) const;
+ const void* getFontTable(LETag tableTag ) const; // DEPRECATED
le_bool canDisplay (LEUnicode32 ch) const {return true;}
le_int32 getUnitsPerEM () const;
LEGlyphID mapCharToGlyph (LEUnicode32 ch) const ;

View file

@ -6,7 +6,7 @@
PRGNAM=fontmatrix
VERSION=${VERSION:-r1220}
BUILD=${BUILD:-1}
BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@ -55,6 +55,9 @@ find -L . \
echo "StartupNotify=false" >> $PRGNAM.desktop
sed -i 's|share/man|man|' CMakeLists.txt
# Fix fontmatrix build against icu 0.56.
patch -p1 < $CWD/fontmatrix-0.9.99-adapt-to-icu-56.patch
# Cmake uses the static python lib. Let's use the shared lib instead.
PYVER=$(python -c 'import sys; print sys.version[:3]')
PY_LIB_SHARED="/usr/lib${LIBDIRSUFFIX}/libpython${PYVER}.so"