mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-18 22:06:04 +01:00
multimedia/grip: Added to 12.2 repository
This commit is contained in:
parent
d566c1777a
commit
2263fd4df9
9 changed files with 246 additions and 0 deletions
15
multimedia/grip/README
Normal file
15
multimedia/grip/README
Normal file
|
@ -0,0 +1,15 @@
|
|||
Grip is a gtk-based cd-player and cd-ripper. It has the ripping
|
||||
capabilities of cdparanoia builtin, but can also use external rippers
|
||||
(such as cdda2wav).
|
||||
|
||||
This is an older version of Grip that does not require GNOME.
|
||||
|
||||
Although a .desktop file is included for KDE menu integration, this
|
||||
package is mainly intended for non-KDE environments (since KDE includes
|
||||
its own CD-ripping facilities, this package would be redundant anyway).
|
||||
|
||||
Before running grip for the first time, you may want to copy the file
|
||||
"/usr/doc/grip-2.96/dot.grip.sample" to "$HOME/.grip". This sets the
|
||||
default encoder to oggenc, and puts the track number at the front of
|
||||
each output filename.
|
||||
|
3
multimedia/grip/doinst.sh
Normal file
3
multimedia/grip/doinst.sh
Normal file
|
@ -0,0 +1,3 @@
|
|||
if [ -x /usr/bin/update-desktop-database ]; then
|
||||
/usr/bin/update-desktop-database -q usr/share/applications &> /dev/null
|
||||
fi
|
55
multimedia/grip/dot.grip.sample
Normal file
55
multimedia/grip/dot.grip.sample
Normal file
|
@ -0,0 +1,55 @@
|
|||
GRIP 1
|
||||
ripexename /usr/bin/cdparanoia
|
||||
ripcmdline -d %c %t:[.%b]-%t:[.%e] %f
|
||||
wav_filter_cmd
|
||||
mp3exename /usr/bin/oggenc
|
||||
mp3cmdline -o %o -a "%A" -l "%d" -t "%n" %f
|
||||
dbserver freedb.freedb.org
|
||||
ripfileformat ~/mp3/%a/%d/%n.wav
|
||||
mp3fileformat ~/mp3/%a/%d/%n.ogg
|
||||
m3ufileformat ~/mp3/%a-%d.m3u
|
||||
delete_wavs 1
|
||||
add_m3u 1
|
||||
rel_m3u 1
|
||||
add_to_db 0
|
||||
outputdir
|
||||
use_proxy 0
|
||||
proxy_name
|
||||
proxy_port 8000
|
||||
cdupdate
|
||||
user_email nobody@example.com
|
||||
ripnice 0
|
||||
mp3nice 0
|
||||
doid3 1
|
||||
max_wavs 99
|
||||
auto_rip 0
|
||||
eject_after_rip 0
|
||||
eject_delay 0
|
||||
beep_after_rip 0
|
||||
faulty_eject 0
|
||||
use_proxy_env 0
|
||||
db_cgi ~cddb/cddb.cgi
|
||||
cddb_submit_email freedb-submit@freedb.org
|
||||
dbserver2
|
||||
db2_cgi ~cddb/cddb.cgi
|
||||
no_interrupt 0
|
||||
stop_first 0
|
||||
play_first 1
|
||||
automatic_cddb 1
|
||||
automatic_reshuffle 1
|
||||
no_lower_case 0
|
||||
no_underscore 0
|
||||
allow_high_bits 0
|
||||
allow_these_chars
|
||||
keep_min_size 1
|
||||
num_cpu 1
|
||||
kbits_per_sec 128
|
||||
selected_encoder 6
|
||||
selected_ripper 0
|
||||
disable_paranoia 0
|
||||
disable_extra_paranoia 0
|
||||
disable_scratch_detect 0
|
||||
disable_scratch_repair 0
|
||||
play_mode 0
|
||||
playloop 1
|
||||
volume 255
|
82
multimedia/grip/grip.SlackBuild
Normal file
82
multimedia/grip/grip.SlackBuild
Normal file
|
@ -0,0 +1,82 @@
|
|||
#!/bin/sh
|
||||
|
||||
# Slackware build script for grip
|
||||
|
||||
# Written by B. Watson (yalhcru@gmail.com)
|
||||
|
||||
PRGNAM=grip
|
||||
VERSION=${VERSION:-2.96}
|
||||
ARCH=${ARCH:-i486}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
CWD=$(pwd)
|
||||
TMP=${TMP:-/tmp/SBo}
|
||||
PKG=$TMP/package-$PRGNAM
|
||||
OUTPUT=${OUTPUT:-/tmp}
|
||||
|
||||
if [ "$ARCH" = "i486" ]; then
|
||||
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
|
||||
elif [ "$ARCH" = "i686" ]; then
|
||||
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
|
||||
elif [ "$ARCH" = "x86_64" ]; then
|
||||
SLKCFLAGS="-O2 -fPIC"
|
||||
fi
|
||||
|
||||
set -e
|
||||
|
||||
rm -rf $PKG
|
||||
mkdir -p $TMP $PKG $OUTPUT
|
||||
cd $TMP
|
||||
rm -rf $PRGNAM-$VERSION
|
||||
tar xvf $CWD/$PRGNAM-$VERSION.tgz
|
||||
cd $PRGNAM-$VERSION
|
||||
chown -R root:root .
|
||||
chmod -R a-s,u+w,go+r-w .
|
||||
|
||||
# Slack 12.2 keeps cdda headers in /usr/include/cdda, 12.1 has them
|
||||
# in /usr/include itself. Be adaptable.
|
||||
if [ -r /usr/include/cdda/cdda_interface.h ]; then
|
||||
SLKCFLAGS="$SLKCFLAGS -I/usr/include/cdda"
|
||||
fi
|
||||
|
||||
# Patch to use system-installed cdparanoia libs:
|
||||
patch -p1 --verbose < $CWD/system_cdparanoia_libs.diff
|
||||
|
||||
# Patch to fix a compile issue with threads (probably came from gentoo):
|
||||
patch -p1 --verbose < $CWD/grip2-nptl.diff
|
||||
|
||||
# The Makefile ignores any CFLAGS we pass in, so:
|
||||
perl -i.bak -pe 's,(CFLAGS\s*=\s*),$1 '"$SLKCFLAGS"' ,' Makefile
|
||||
|
||||
make
|
||||
|
||||
# DESTDIR not supported.
|
||||
make install PREFIX=$PKG/usr
|
||||
|
||||
strip $PKG/usr/bin/*
|
||||
|
||||
rm -f $PKG/usr/man/man1/gcd.1
|
||||
gzip $PKG/usr/man/man1/$PRGNAM.1
|
||||
( cd $PKG/usr/man/man1 && ln -s $PRGNAM.1.gz gcd.1.gz )
|
||||
|
||||
# Why does it create an empty usr/lib dir?
|
||||
rm -rf $PKG/usr/lib
|
||||
|
||||
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cp $CWD/dot.grip.sample CHANGES CREDITS LICENSE README TODO \
|
||||
$PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
|
||||
|
||||
mkdir -p $PKG/usr/share/pixmaps
|
||||
cp pixmaps/grip.xpm $PKG/usr/share/pixmaps
|
||||
|
||||
mkdir -p $PKG/usr/share/applications
|
||||
cp $CWD/grip.desktop $PKG/usr/share/applications
|
||||
|
||||
mkdir -p $PKG/install
|
||||
cat $CWD/slack-desc > $PKG/install/slack-desc
|
||||
cat $CWD/doinst.sh > $PKG/install/doinst.sh
|
||||
|
||||
cd $PKG
|
||||
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
|
8
multimedia/grip/grip.desktop
Normal file
8
multimedia/grip/grip.desktop
Normal file
|
@ -0,0 +1,8 @@
|
|||
[Desktop Entry]
|
||||
Encoding=UTF-8
|
||||
Name=Grip
|
||||
Exec=grip
|
||||
Type=Application
|
||||
Icon=grip
|
||||
GenericName=Grip CD Ripper
|
||||
Categories=AudioVideo;Audio;
|
8
multimedia/grip/grip.info
Normal file
8
multimedia/grip/grip.info
Normal file
|
@ -0,0 +1,8 @@
|
|||
PRGNAM="grip"
|
||||
VERSION="2.96"
|
||||
HOMEPAGE="http://nostatic.org/grip/"
|
||||
DOWNLOAD="http://downloads.sourceforge.net/grip/grip-2.96.tgz"
|
||||
MD5SUM="29d03b2874c5cb60096ac3051fbbc4e3"
|
||||
MAINTAINER="B. Watson"
|
||||
EMAIL="yalhcru@gmail.com"
|
||||
APPROVED="dsomero"
|
12
multimedia/grip/grip2-nptl.diff
Normal file
12
multimedia/grip/grip2-nptl.diff
Normal file
|
@ -0,0 +1,12 @@
|
|||
diff -Naur grip-2.93.orig/grip.c grip-2.93/grip.c
|
||||
--- grip-2.93.orig/grip.c 2007-04-19 01:15:23.000000000 -0400
|
||||
+++ grip-2.93/grip.c 2007-04-19 01:34:39.000000000 -0400
|
||||
@@ -1637,7 +1637,7 @@
|
||||
#if defined(SOLARIS) || defined(__FreeBSD__)
|
||||
pthread_exit(&status);
|
||||
#else
|
||||
- pthread_kill_other_threads_np();
|
||||
+ /* pthread_kill_other_threads_np(); */
|
||||
#endif
|
||||
Debug("Aborted\n");
|
||||
looking_up=FALSE;
|
19
multimedia/grip/slack-desc
Normal file
19
multimedia/grip/slack-desc
Normal file
|
@ -0,0 +1,19 @@
|
|||
# HOW TO EDIT THIS FILE:
|
||||
# The "handy ruler" below makes it easier to edit a package description. Line
|
||||
# up the first '|' above the ':' following the base package name, and the '|'
|
||||
# on the right side marks the last column you can put a character in. You must
|
||||
# make exactly 11 lines for the formatting to be correct. It's also
|
||||
# customary to leave one space after the ':'.
|
||||
|
||||
|-----handy-ruler------------------------------------------------------|
|
||||
grip: grip (graphical CD player and ripper)
|
||||
grip:
|
||||
grip: Grip is a gtk-based cd-player and cd-ripper. It has the ripping
|
||||
grip: capabilities of cdparanoia builtin, but can also use external
|
||||
grip: rippers (such as cdda2wav).
|
||||
grip:
|
||||
grip: This is an older version of Grip that does not require GNOME.
|
||||
grip:
|
||||
grip:
|
||||
grip:
|
||||
grip:
|
44
multimedia/grip/system_cdparanoia_libs.diff
Normal file
44
multimedia/grip/system_cdparanoia_libs.diff
Normal file
|
@ -0,0 +1,44 @@
|
|||
diff -Naur grip-2.96.orig/Makefile grip-2.96/Makefile
|
||||
--- grip-2.96.orig/Makefile 2001-07-16 12:15:32.000000000 -0400
|
||||
+++ grip-2.96/Makefile 2009-02-05 00:38:28.000000000 -0500
|
||||
@@ -28,8 +28,8 @@
|
||||
ifeq ($(OS), FreeBSD)
|
||||
LIBS+= -pthread
|
||||
endif
|
||||
-PARLIBS= cdparanoia/interface/libcdda_interface.a \
|
||||
- cdparanoia/paranoia/libcdda_paranoia.a
|
||||
+PARLIBS= -lcdda_interface \
|
||||
+ -lcdda_paranoia
|
||||
|
||||
# This is needed for "make install"
|
||||
OWNER = root
|
||||
diff -Naur grip-2.96.orig/cdpar.c grip-2.96/cdpar.c
|
||||
--- grip-2.96.orig/cdpar.c 2001-07-16 12:15:32.000000000 -0400
|
||||
+++ grip-2.96/cdpar.c 2009-02-05 00:39:02.000000000 -0500
|
||||
@@ -36,9 +36,9 @@
|
||||
#define size16 short
|
||||
#define size32 int
|
||||
|
||||
-#include "cdparanoia/interface/cdda_interface.h"
|
||||
-#include "cdparanoia/paranoia/cdda_paranoia.h"
|
||||
-#include "cdparanoia/utils.h"
|
||||
+#include <cdda_interface.h>
|
||||
+#include <cdda_paranoia.h>
|
||||
+#include <utils.h>
|
||||
|
||||
static void PutNum(long num,int f,int endianness,int bytes);
|
||||
static void WriteWav(int f,long bytes);
|
||||
diff -Naur grip-2.96.orig/grip.c grip-2.96/grip.c
|
||||
--- grip-2.96.orig/grip.c 2001-07-16 12:15:32.000000000 -0400
|
||||
+++ grip-2.96/grip.c 2009-02-05 00:42:26.000000000 -0500
|
||||
@@ -57,8 +57,8 @@
|
||||
#ifdef CDPAR
|
||||
#define size16 short
|
||||
#define size32 int
|
||||
-#include "cdparanoia/interface/cdda_interface.h"
|
||||
-#include "cdparanoia/paranoia/cdda_paranoia.h"
|
||||
+#include <cdda_interface.h>
|
||||
+#include <cdda_paranoia.h>
|
||||
#endif
|
||||
|
||||
void ShutDownCB(void);
|
Loading…
Reference in a new issue