mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-24 10:02:29 +01:00
system/sudosh2: Fixed install path.
Signed-off-by: David Spencer <baildon.research@googlemail.com>
This commit is contained in:
parent
38c5cf743d
commit
222fe7eb23
3 changed files with 21 additions and 8 deletions
13
system/sudosh2/sudosh2-destdir.patch
Normal file
13
system/sudosh2/sudosh2-destdir.patch
Normal file
|
@ -0,0 +1,13 @@
|
||||||
|
diff -u -r sudosh2-1.0.4-orig/src/Makefile.am sudosh2-1.0.4/src/Makefile.am
|
||||||
|
--- sudosh2-1.0.4-orig/src/Makefile.am 2010-07-09 21:37:01.000000000 +0100
|
||||||
|
+++ sudosh2-1.0.4/src/Makefile.am 2016-05-29 11:51:19.902051323 +0100
|
||||||
|
@@ -7,7 +7,7 @@
|
||||||
|
sysconfdir = @sysconfdir@
|
||||||
|
|
||||||
|
install-sudosh.conf:
|
||||||
|
- test -z "$(sysconfdir)" || $(mkdir_p) "$(DESTDIR)$(sysconfdir)"
|
||||||
|
- test -f $(sysconfdir)/sudosh.conf || $(INSTALL) -o 0 -g 0 -m 0444 '$(srcdir)/sudosh.conf' '$(sysconfdir)/sudosh.conf'
|
||||||
|
+ $(mkdir_p) "$(DESTDIR)$(sysconfdir)"
|
||||||
|
+ $(INSTALL) -o 0 -g 0 -m 0444 '$(srcdir)/sudosh.conf' '$(DESTDIR)$(sysconfdir)/sudosh.conf'
|
||||||
|
|
||||||
|
install: install-am install-sudosh.conf
|
|
@ -71,10 +71,13 @@ tar xvf $CWD/$PRGNAM-$VERSION.tgz
|
||||||
cd $PRGNAM-$VERSION
|
cd $PRGNAM-$VERSION
|
||||||
chown -R root:root .
|
chown -R root:root .
|
||||||
find -L . \
|
find -L . \
|
||||||
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
|
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
|
||||||
-exec chmod 755 {} \; -o \
|
-o -perm 511 \) -exec chmod 755 {} \; -o \
|
||||||
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
|
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
|
||||||
-exec chmod 644 {} \;
|
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
|
||||||
|
|
||||||
|
patch -p1 < $CWD/sudosh2-destdir.patch
|
||||||
|
autoreconf -vif
|
||||||
|
|
||||||
CFLAGS="$SLKCFLAGS" \
|
CFLAGS="$SLKCFLAGS" \
|
||||||
CXXFLAGS="$SLKCFLAGS" \
|
CXXFLAGS="$SLKCFLAGS" \
|
||||||
|
@ -90,9 +93,6 @@ CXXFLAGS="$SLKCFLAGS" \
|
||||||
make
|
make
|
||||||
make install-strip DESTDIR=$PKG
|
make install-strip DESTDIR=$PKG
|
||||||
|
|
||||||
# manually install the conf file
|
|
||||||
install -m 0644 -D $TMP/$PRGNAM-$VERSION/src/sudosh.conf $PKG/etc/sudosh.conf.new
|
|
||||||
|
|
||||||
find $PKG/usr/man -type f -exec gzip -9 {} \;
|
find $PKG/usr/man -type f -exec gzip -9 {} \;
|
||||||
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
|
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
|
||||||
|
|
||||||
|
|
|
@ -1,6 +1,6 @@
|
||||||
PRGNAM="sudosh2"
|
PRGNAM="sudosh2"
|
||||||
VERSION="1.0.4"
|
VERSION="1.0.4"
|
||||||
HOMEPAGE="http://www.shortcutsolutions.net/sudosh2-shell-auditing-software.html"
|
HOMEPAGE="https://github.com/squash/sudosh2"
|
||||||
DOWNLOAD="http://downloads.sourceforge.net/project/sudosh2/sudosh2-1.0.4.tgz"
|
DOWNLOAD="http://downloads.sourceforge.net/project/sudosh2/sudosh2-1.0.4.tgz"
|
||||||
MD5SUM="28c0b6cfd60299a6c339cf9b07f2367f"
|
MD5SUM="28c0b6cfd60299a6c339cf9b07f2367f"
|
||||||
DOWNLOAD_x86_64=""
|
DOWNLOAD_x86_64=""
|
||||||
|
|
Loading…
Reference in a new issue