mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-16 19:50:19 +01:00
audio/faac: Added external libmp4v2 patch.
Other misc cleanup. This is a BUILD bump. Signed-off-by: Erik Hanson <erik@slackbuilds.org>
This commit is contained in:
parent
ffb0447d93
commit
21fb22933f
2 changed files with 63 additions and 7 deletions
47
audio/faac/faac-1.28-external-libmp4v2.patch
Normal file
47
audio/faac/faac-1.28-external-libmp4v2.patch
Normal file
|
@ -0,0 +1,47 @@
|
|||
diff -ur faac-1.28.orig/configure.in faac-1.28/configure.in
|
||||
--- faac-1.28.orig/configure.in 2009-02-05 02:55:38.000000000 +0200
|
||||
+++ faac-1.28/configure.in 2009-07-10 13:21:34.000000000 +0300
|
||||
@@ -28,14 +28,17 @@
|
||||
AC_CHECK_LIB(gnugetopt, getopt_long)
|
||||
|
||||
AM_CONDITIONAL(WITH_MP4V2, false)
|
||||
+AM_CONDITIONAL(WITH_EXTERNAL_MP4V2, false)
|
||||
|
||||
AC_CHECK_DECLS([MP4Create, MP4MetadataDelete],
|
||||
AC_CHECK_LIB(mp4v2, MP4MetadataDelete, external_mp4v2=yes,
|
||||
external_mp4v2=no, -lstdc++),
|
||||
- external_mp4v2=no, [#include <mp4.h>])
|
||||
+ external_mp4v2=no, [#include <mp4v2/mp4v2.h>])
|
||||
|
||||
if test x$external_mp4v2 = xyes; then
|
||||
AC_MSG_NOTICE([*** Building with external mp4v2 ***])
|
||||
+ MY_DEFINE(HAVE_LIBMP4V2)
|
||||
+ AM_CONDITIONAL(WITH_EXTERNAL_MP4V2, true)
|
||||
else
|
||||
if test x$WITHMP4V2 = xyes; then
|
||||
AC_MSG_NOTICE([*** Building with internal mp4v2 ***])
|
||||
diff -ur faac-1.28.orig/frontend/main.c faac-1.28/frontend/main.c
|
||||
--- faac-1.28.orig/frontend/main.c 2009-01-24 03:10:20.000000000 +0200
|
||||
+++ faac-1.28/frontend/main.c 2009-07-10 13:22:18.000000000 +0300
|
||||
@@ -30,7 +30,7 @@
|
||||
#endif
|
||||
|
||||
#ifdef HAVE_LIBMP4V2
|
||||
-# include <mp4.h>
|
||||
+# include <mp4v2/mp4v2.h>
|
||||
#endif
|
||||
|
||||
#define DEFAULT_TNS 0
|
||||
diff -ur faac-1.28.orig/frontend/Makefile.am faac-1.28/frontend/Makefile.am
|
||||
--- faac-1.28.orig/frontend/Makefile.am 2008-12-16 02:56:00.000000000 +0200
|
||||
+++ faac-1.28/frontend/Makefile.am 2009-07-10 13:21:55.000000000 +0300
|
||||
@@ -8,5 +8,9 @@
|
||||
LDADD = $(top_builddir)/libfaac/libfaac.la $(top_srcdir)/common/mp4v2/libmp4v2.a -lm -lstdc++
|
||||
else
|
||||
INCLUDES = -I$(top_srcdir)/include
|
||||
+if WITH_EXTERNAL_MP4V2
|
||||
+LDADD = $(top_builddir)/libfaac/libfaac.la -lm -lmp4v2
|
||||
+else
|
||||
LDADD = $(top_builddir)/libfaac/libfaac.la -lm
|
||||
endif
|
||||
+endif
|
|
@ -1,6 +1,6 @@
|
|||
#!/bin/sh
|
||||
|
||||
# Slackware build script for faac
|
||||
# Slackware build script for faac
|
||||
|
||||
# Copyright (c) 2008, Antonio Hernández Blas <hba.nihilismus@gmail.com>
|
||||
# All rights reserved.
|
||||
|
@ -27,7 +27,7 @@
|
|||
|
||||
PRGNAM=faac
|
||||
VERSION=${VERSION:-1.28}
|
||||
BUILD=${BUILD:-1}
|
||||
BUILD=${BUILD:-2}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
# Automatically determine the architecture we're building on:
|
||||
|
@ -70,7 +70,7 @@ fi
|
|||
# desired result in every case *except* where one wants to use the internal
|
||||
# implementation, and that creates other problems, so we don't support it.
|
||||
#
|
||||
# From what used to be in our README:
|
||||
# From what used to be in our README:
|
||||
# faac comes with its own version of libmp4v2, but if you use it, you have to
|
||||
# uninstall faac everytime you want to update it, as faac would otherwise
|
||||
# detect the already installed libmp4v2 and build against it. Then, when you
|
||||
|
@ -93,6 +93,17 @@ find . \
|
|||
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
|
||||
-exec chmod 644 {} \;
|
||||
|
||||
# http://lists.slackbuilds.org/pipermail/slackbuilds-users/2010-May/005680.html
|
||||
# Fix compilation problem faac-1.28 and external libmp4v2 1.9.1
|
||||
# see http://sourceforge.net/tracker/?func=detail&aid=2894310&group_id=704&atid=100704
|
||||
# and http://ftp.eenet.ee/gentoo-portage/media-libs/faac/files/faac-1.28-external-libmp4v2.patch
|
||||
patch -p1 < $CWD/faac-1.28-external-libmp4v2.patch
|
||||
# having just patched configure.in, we need to bludgeon automake
|
||||
libtoolize --force --copy
|
||||
aclocal
|
||||
autoconf
|
||||
automake --add-missing
|
||||
|
||||
CFLAGS="$SLKCFLAGS" \
|
||||
CXXFLAGS="$SLKCFLAGS" \
|
||||
./configure \
|
||||
|
@ -107,10 +118,8 @@ CXXFLAGS="$SLKCFLAGS" \
|
|||
make
|
||||
make install-strip DESTDIR=$PKG
|
||||
|
||||
( cd $PKG/usr/man || exit 1
|
||||
find . -type f -exec gzip -9 {} \;
|
||||
for i in $(find . -type l) ; do ln -s $(readlink $i).gz $i.gz ; rm $i ; done
|
||||
)
|
||||
find $PKG/usr/man -type f -exec gzip -9 {} \;
|
||||
for i in $(find $PKG/usr/man -type l) ; do ln -s $(readlink $i).gz $i.gz ; rm $i ; done
|
||||
|
||||
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cp -a AUTHORS ChangeLog COPYING INSTALL NEWS README TODO docs/* \
|
||||
|
|
Loading…
Reference in a new issue