system/vhba-module: Included patch for kernel 2.6.37.x

Signed-off-by: Niels Horn <niels.horn@slackbuilds.org>
This commit is contained in:
Niels Horn 2011-03-17 23:44:10 -03:00 committed by Robby Workman
parent 93d4ecdfe4
commit 21cbd209c6
4 changed files with 55 additions and 2 deletions

View file

@ -2,3 +2,6 @@ This is VHBA (Virtual SCSI Host Bus adapter), a Linux kernel module which
acts as a low-level SCSI driver and which provides the SCSI layer with a
virtual SCSI adapter which can have multiple virtual devices. It is part
of the userspace-cdemu suite, a free GPL CD/DVD-ROM device emulator for linux.
NOTE:
The resulting package will be specific for the kernel it was built on.

View file

@ -24,11 +24,11 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
# Maintained as of version 20100822 by Niels Horn <niels.horn@gmail.com>
# Revision date: 2010/11/20
# Revision date: 2011/03/17
PRGNAM=vhba-module
VERSION=${VERSION:-20100822}
BUILD=${BUILD:-1}
BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@ -58,6 +58,13 @@ cd $PRGNAM-$VERSION
chown -R root:root .
chmod -R u+w,go+r-w,a-s .
# Patch from upstream for kernels 2.6.37.x
# (thanks to Melvin Xavier for pointing me to this)
patch -p2 < $CWD/vhba-module_v730_SCSI.patch
# Patch from upstream to stop building on warnings
patch -p2 < $CWD/vhba-module_v735_Werror.patch
# Use -j1 to avoid problems if larger number of jobs is defined in MAKEFLAGS
make -j1 KERNELRELEASE=$KERNEL

View file

@ -0,0 +1,32 @@
--- trunk/vhba-module/vhba.c 2010/08/15 20:11:18 691
+++ trunk/vhba-module/vhba.c 2011/02/27 15:56:27 730
@@ -363,7 +363,7 @@
spin_unlock_irqrestore(&vhost->cmd_lock, flags);
}
-static int vhba_queuecommand(struct scsi_cmnd *cmd, void (*done)(struct scsi_cmnd *))
+static int vhba_queuecommand_lck(struct scsi_cmnd *cmd, void (*done)(struct scsi_cmnd *))
{
struct vhba_device *vdev;
int retval;
@@ -388,6 +388,12 @@
return retval;
}
+#ifdef DEF_SCSI_QCMD
+DEF_SCSI_QCMD(vhba_queuecommand)
+#else
+#define vhba_queuecommand vhba_queuecommand_lck
+#endif
+
static int vhba_abort(struct scsi_cmnd *cmd)
{
struct vhba_device *vdev;
@@ -796,7 +802,7 @@
.poll = vhba_ctl_poll,
.unlocked_ioctl = vhba_ctl_ioctl,
#ifdef CONFIG_COMPAT
- .compat_ioctl = vhba_ctl_compat_ioctl,
+ .compat_ioctl = vhba_ctl_compat_ioctl,
#endif
};

View file

@ -0,0 +1,11 @@
--- trunk/vhba-module/Makefile 2010/08/22 22:17:02 696
+++ trunk/vhba-module/Makefile 2011/03/11 21:20:08 735
@@ -1,7 +1,7 @@
VHBA_VERSION = $(shell date +%Y%m%d)
PACKAGE = vhba-module-$(VHBA_VERSION)
-EXTRA_CFLAGS += -DVHBA_VERSION=\"$(VHBA_VERSION)\" -I$(PWD)
+EXTRA_CFLAGS += -DVHBA_VERSION=\"$(VHBA_VERSION)\" -I$(PWD) -Werror
obj-m += vhba.o