academic/ITK: Updated for version 4.13.1.

Signed-off-by: Benjamin Trigona-Harany <bosth@alumni.sfu.ca>
This commit is contained in:
Benjamin Trigona-Harany 2018-09-06 22:17:20 -07:00 committed by Willy Sudiarto Raharjo
parent f22197f7a8
commit 20d6873f04
No known key found for this signature in database
GPG key ID: 887B8374D7333381
3 changed files with 4 additions and 41 deletions

View file

@ -26,7 +26,7 @@
PRGNAM=ITK
SRCNAM=InsightToolkit
VERSION=${VERSION:-4.13.0}
VERSION=${VERSION:-4.13.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@ -76,9 +76,6 @@ sed -i "s/lib\b/lib${LIBDIRSUFFIX}/" CMakeLists.txt
sed -i "s|/opj_config.h|& \$\{CMAKE_CURRENT_BINARY_DIR\}/openjpeg_mangle.h|" \
Modules/ThirdParty/GDCM/src/gdcm/Utilities/gdcmopenjpeg/src/lib/openjp2/CMakeLists.txt
# allow compilation under GCC 8
patch -p1 Modules/ThirdParty/VNL/src/vxl/vcl/vcl_compiler.h < $CWD/gcc8.patch
mkdir -p build
cd build
cmake \

View file

@ -1,8 +1,8 @@
PRGNAM="ITK"
VERSION="4.13.0"
VERSION="4.13.1"
HOMEPAGE="https://itk.org"
DOWNLOAD="https://sourceforge.net/projects/itk/files/itk/4.13/InsightToolkit-4.13.0.tar.xz"
MD5SUM="3badf70cfb0093054453f66c5974c5a4"
DOWNLOAD="https://sourceforge.net/projects/itk/files/itk/4.13/InsightToolkit-4.13.1.tar.xz"
MD5SUM="bc7296e7faccdcb5656a7669d4d875d2"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="double-conversion gtest hdf5"

View file

@ -1,34 +0,0 @@
From 2662860491ff44a16e01581a6b3727d53997fee8 Mon Sep 17 00:00:00 2001
From: Pablo Hernandez-Cerdan <pablo.hernandez.cerdan@outlook.com>
Date: Tue, 15 May 2018 16:17:01 -0400
Subject: [PATCH] COMP: Add gcc8 support to vcl_compiler.
It just adds a if/else branch to the existing logic.
Triggered here: https://discourse.itk.org/t/building-and-compiling-with-gcc-8-1/934/4
---
vcl/vcl_compiler.h | 11 +++++++++++
1 file changed, 11 insertions(+)
diff --git a/vcl/vcl_compiler.h b/vcl/vcl_compiler.h
index 6a3f2e2152..5ca624603d 100644
--- a/vcl/vcl_compiler.h
+++ b/vcl/vcl_compiler.h
@@ -86,6 +86,17 @@
# else
# define VCL_GCC_70
# endif
+# elif (__GNUC__==8)
+# define VCL_GCC_8
+# if (__GNUC_MINOR__ > 2 )
+# define VCL_GCC_83
+# elif (__GNUC_MINOR__ > 1 )
+# define VCL_GCC_82
+# elif (__GNUC_MINOR__ > 0 )
+# define VCL_GCC_81
+# else
+# define VCL_GCC_80
+# endif
# else
# error "Dunno about this gcc"
# endif