academic/bpp1.9-phyl: Added (Bio++ 1.9 Phyl Library)

Signed-off-by: Dave Woodfall <dave@slackbuilds.org>
This commit is contained in:
Petar Petrov 2022-09-09 03:07:45 +01:00 committed by Dave Woodfall
parent 15bcc39c2b
commit 1f0ff62f35
5 changed files with 197 additions and 0 deletions

View file

@ -0,0 +1,10 @@
Bio++ is a set of C++ libraries for Bioinformatics, including sequence
analysis, phylogenetics, molecular evolution and population genetics.
Bio++ is Object Oriented and is designed to be both easy to use and
computer efficient. Bio++ intends to help programmers to write
computer expensive programs, by providing them a set of re-usable
tools.
This contains the Bio++ 1.9 (April 2010) Phyl Library. It can be
installed along the current Bio++ suite libraries, however they better
not be present at compile time.

View file

@ -0,0 +1,119 @@
#!/bin/bash
# Slackware build script for bpp1.9-phyl
# Copyright 2020-2022 Petar Petrov slackalaxy@gmail.com
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
#
# 1. Redistributions of this script must retain the above copyright
# notice, this list of conditions and the following disclaimer.
#
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=bpp1.9-phyl
SRCNAM=bpp-phyl
VERSION=${VERSION:-1.9.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
fi
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
fi
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
if [ "$ARCH" = "i586" ]; then
SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
LIBDIRSUFFIX="64"
else
SLKCFLAGS="-O2"
LIBDIRSUFFIX=""
fi
LIBDIRPATH="-Wl,-rpath,/usr/lib${LIBDIRSUFFIX}/Bpp1.9"
set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $SRCNAM-$VERSION
tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
-o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
# CAPS wants TreeTemplateTools to be modified a bit...
patch -p1 -i $CWD/caps_TreeTemplateTools.patch
# Use custom install place, so libs can coexist with latest bpp
export PATH="/usr/lib${LIBDIRSUFFIX}/Bpp1.9/:$PATH"
sed -i "s:/lib/:/lib${LIBDIRSUFFIX}/Bpp1.9/:g" Phyl.spec
source /etc/profile.d/gcc5.sh
mkdir -p build
cd build
cmake \
-DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS $LIBDIRPATH" \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_BUILD_TYPE=Release ..
sed -i "s:/lib/:/lib${LIBDIRSUFFIX}/Bpp1.9/:g" Phyl/cmake_install.cmake
sed -i "s:/lib\b:/lib${LIBDIRSUFFIX}/Bpp1.9:g" Phyl/cmake_install.cmake
make
make DESTDIR=$PKG install
cd ..
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
chmod 0644 AUTHORS ChangeLog COPYING
cp -a \
AUTHORS ChangeLog COPYING \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE

View file

@ -0,0 +1,10 @@
PRGNAM="bpp1.9-phyl"
VERSION="1.9.0"
HOMEPAGE="http://biopp.univ-montp2.fr/"
DOWNLOAD="https://raw.githubusercontent.com/slackalaxy/sources/main/bpp-phyl-1.9.0.tar.gz"
MD5SUM="1b100b688faca52419e9f782798b8add"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="bpp1.9-seq"
MAINTAINER="Petar Petrov"
EMAIL="slackalaxy@gmail.com"

View file

@ -0,0 +1,39 @@
diff -pruN orig/Phyl/TreeTemplateTools.h new/Phyl/TreeTemplateTools.h
--- orig/Phyl/TreeTemplateTools.h 2010-04-01 16:37:04.000000000 +0300
+++ new/Phyl/TreeTemplateTools.h 2017-02-03 14:33:11.000000000 +0200
@@ -191,7 +191,7 @@ class TreeTemplateTools
static void dropLeaf(TreeTemplate<N>& tree, const std::string& leafName) throw (NodeNotFoundException, Exception)
{
N* leaf = tree.getNode(leafName);
- if (!leaf->hasfather())
+ if (!leaf->hasFather())
throw Exception("TreeTemplateTools::dropLeaf(). Leaf is the only node in the tree, can't remove it.");
N* parent = leaf->getFather();
if (parent->getNumberOfSons() > 2)
@@ -203,7 +203,7 @@ class TreeTemplateTools
else if (parent->getNumberOfSons() == 2)
{
//We have to delete the parent node as well:
- N* brother = parent->getson(0);
+ N* brother = parent->getSon(0);
if (brother == leaf) brother = parent->getSon(1);
if (!parent->hasFather())
{
@@ -212,7 +212,7 @@ class TreeTemplateTools
{
brother->setDistanceToFather(brother->getDistanceToFather() + leaf->getDistanceToFather());
}
- tree->setRootNode(brother);
+ tree.setRootNode(brother);
delete parent;
delete leaf;
}
@@ -223,7 +223,7 @@ class TreeTemplateTools
{
brother->setDistanceToFather(brother->getDistanceToFather() + parent->getDistanceToFather());
}
- unsigned int pos = gParent->getsonPosition(parent);
+ unsigned int pos = gParent->getSonPosition(parent);
gParent->setSon(pos, brother);
delete parent;
delete leaf;

View file

@ -0,0 +1,19 @@
# HOW TO EDIT THIS FILE:
# The "handy ruler" below makes it easier to edit a package description.
# Line up the first '|' above the ':' following the base package name, and
# the '|' on the right side marks the last column you can put a character in.
# You must make exactly 11 lines for the formatting to be correct. It's also
# customary to leave one space after the ':' except on otherwise blank lines.
|-----handy-ruler------------------------------------------------------|
bpp1.9-phyl: bpp1.9-phyl (Bio++ 1.9 Phyl Library)
bpp1.9-phyl:
bpp1.9-phyl: Contains the Bio++ 1.9 Phyl Library.
bpp1.9-phyl:
bpp1.9-phyl:
bpp1.9-phyl:
bpp1.9-phyl:
bpp1.9-phyl:
bpp1.9-phyl:
bpp1.9-phyl:
bpp1.9-phyl: