system/virt-manager: Updated for version 1.1.0.

Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
This commit is contained in:
Matteo Bernardini 2014-09-11 07:01:50 +02:00 committed by Willy Sudiarto Raharjo
parent c76b5681a2
commit 1e5aa5fb58
4 changed files with 76 additions and 31 deletions

View file

@ -0,0 +1,70 @@
diff -Naur virt-manager-1.1.0.orig/virtinst/osdict.py virt-manager-1.1.0/virtinst/osdict.py
--- virt-manager-1.1.0.orig/virtinst/osdict.py 2014-09-07 16:47:13.000000000 +0200
+++ virt-manager-1.1.0/virtinst/osdict.py 2014-09-11 06:58:39.498034667 +0200
@@ -48,6 +48,7 @@
"rhel5" : "rhel5.0",
"rhel6" : "rhel6.0",
"rhel7" : "rhel7.0",
+ "slackware" : "slackware14.1",
"ubuntuhardy" : "ubuntu8.04",
"ubuntuintrepid" : "ubuntu8.10",
"ubuntujaunty" : "ubuntu9.04",
@@ -444,8 +445,9 @@
# We should fix this in a new libosinfo version, and then drop
# this hack
if name in ["rhel7.0", "rhel7.1", "fedora19", "fedora20", "fedora21",
- "debian6", "debian7", "ubuntu13.04", "ubuntu13.10", "ubuntu14.04",
- "ubuntu14.10", "win8", "win8.1", "win2k12", "win2k12r2"]:
+ "debian6", "debian7", "slackware14.1", "ubuntu13.04", "ubuntu13.10",
+ "ubuntu14.04", "ubuntu14.10", "win8", "win8.1", "win2k12",
+ "win2k12r2"]:
return True
return False
diff -Naur virt-manager-1.1.0.orig/virtinst/urlfetcher.py virt-manager-1.1.0/virtinst/urlfetcher.py
--- virt-manager-1.1.0.orig/virtinst/urlfetcher.py 2014-09-07 20:35:55.000000000 +0200
+++ virt-manager-1.1.0/virtinst/urlfetcher.py 2014-09-11 06:55:10.870047611 +0200
@@ -1022,6 +1022,43 @@
return False
+class SlackwareDistro(Distro):
+ # slackware doesn't have installable URLs, so this is just for a
+ # mounted ISO
+ name = "Slackware"
+ urldistro = "slackware"
+ os_variant = "linux"
+
+ _boot_iso_paths = []
+ _xen_kernel_paths = []
+
+ def __init__(self, *args, **kwargs):
+ Distro.__init__(self, *args, **kwargs)
+ if re.match(r'i[4-9]86', self.arch):
+ self.arch = 'i486'
+ self.kname = 'hugesmp.s'
+ else:
+ self.arch = 'x86_64'
+ self.kname = 'huge.s'
+
+ self._hvm_kernel_paths = [("kernels/%s/bzImage" % self.kname,
+ "isolinux/initrd.img")]
+
+ def isValidStore(self):
+ # Don't support any paravirt installs
+ if self.type is not None and self.type != "hvm":
+ return False
+
+ # Slackware website / media appear to have a Slackware-HOWTO
+ # file in top level which we can use as our 'magic'
+ # check for validity
+ if not self.fetcher.hasFile("Slackware-HOWTO"):
+ return False
+
+ logging.debug("Regex didn't match, not a %s distro", self.name)
+ return False
+
+
# Build list of all *Distro classes
def _build_distro_list():
allstores = []

View file

@ -7,7 +7,7 @@
# Lots of mods by rworkman for 1.x
PRGNAM=virt-manager
VERSION=${VERSION:-1.0.1}
VERSION=${VERSION:-1.1.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@ -57,7 +57,7 @@ find -L . \
sed -i "s|3\.10|3.8|" ui/gfxdetails.ui ui/netlist.ui ui/addstorage.ui
# Add Slackware support
patch -p1 < $CWD/virtinst-osdict.py-Add-Slackware-to-OS-choices.patch
patch -p1 < $CWD/Add-Slackware-to-OS-choices.patch
python setup.py configure
python setup.py install --root=$PKG

View file

@ -1,10 +1,10 @@
PRGNAM="virt-manager"
VERSION="1.0.1"
VERSION="1.1.0"
HOMEPAGE="http://virt-manager.et.redhat.com"
DOWNLOAD="https://fedorahosted.org/released/virt-manager/virt-manager-1.0.1.tar.gz"
MD5SUM="4741c0d93d69cef5f936b2ea2d8348c5"
DOWNLOAD="https://fedorahosted.org/released/virt-manager/virt-manager-1.1.0.tar.gz"
MD5SUM="baf6eaa88b02bdd7a3c2fdd293eeb6ac"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="libvirt-glib libvirt-python gnome-python2-gconf tunctl ipaddr-py urlgrabber pygobject3 gtk-vnc spice-gtk vte3"
REQUIRES="libosinfo libvirt-glib libvirt-python gnome-python2-gconf tunctl ipaddr-py urlgrabber pygobject3 gtk-vnc spice-gtk vte3"
MAINTAINER="Robby Workman"
EMAIL="rworkman@slackbuilds.org"

View file

@ -1,25 +0,0 @@
From ae298e5c0cf64d8d9d01f3b2eddfaa783f85ecf9 Mon Sep 17 00:00:00 2001
From: Robby Workman <rworkman@slackware.com>
Date: Mon, 11 Nov 2013 17:24:57 -0600
Subject: [PATCH] virtinst/osdict.py: Add Slackware to OS choices
---
virtinst/osdict.py | 2 ++
1 file changed, 2 insertions(+)
diff --git a/virtinst/osdict.py b/virtinst/osdict.py
index 5dd727a..82ffef1 100644
--- a/virtinst/osdict.py
+++ b/virtinst/osdict.py
@@ -276,6 +276,8 @@ _add_var("mageia1", "Mageia 1 (or later)", urldistro="mandriva", supported=True,
_add_var("altlinux", "ALT Linux (or later)", urldistro="altlinux", supported=True, virtiodisk=True, virtionet=True, inputtype="tablet", inputbus="usb", parent="linux")
+_add_var("slackware14.1", "Slackware 14.1 (or later)", parent="linux", supported=True, virtiodisk=True, virtionet=True, inputtype="tablet", inputbus="usb")
+
_add_var("debianetch", "Debian Etch", urldistro="debian", sortby="debian4", parent="linux")
_add_var("debianlenny", "Debian Lenny", sortby="debian5", supported=True, virtiodisk=True, virtionet=True, parent="debianetch")
_add_var("debiansqueeze", "Debian Squeeze", sortby="debian6", virtiodisk=True, virtionet=True, inputtype="tablet", inputbus="usb", parent="debianlenny")
--
1.8.4